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This document is an installation guide for SmartPlant 3D reference data and product software. 
The purpose of this document is to explain how to install and configure SmartPlant 3D and all 
necessary prerequisite software. 

 This document does not cover basic Windows Server 2008, Windows 7, Windows 
XP Professional, Windows Vista, Oracle®, or Microsoft SQL Server operation. Refer to those 
products' printed documentation for basic operation information. 
Intergraph® gives you permission to print as many copies of this document as you need for 
non-commercial use at your company. You cannot print this document for resale or redistribution 
outside your company. 

 For information on SmartPlant 3D commands, refer to the SmartPlant 3D on-line Help. 
You can find the most recent guides and on-line Help at Intergraph's eCustomer support site: 
https://crmweb.intergraph.com/ecustomer_enu/. 

SmartPlant 3D Documentation Set 
SmartPlant 3D documentation is available as Adobe PDF files. The content is the same as 
online Help. To access these PDF documents, click Help > Printable Guides in the software. 
The documentation set is divided into four categories: 
 Administrative guides contain information about installing, configuring, customizing, and 

troubleshooting SmartPlant 3D. 
 User's guides provide command reference and how-to information for working in each 

SmartPlant 3D task. 
 Reference data guides define the reference data workbooks. Not all tasks have reference 

data. 
 ISOGEN guides 

Administrative Guides 
SmartPlant 3D Installation Guide - Provides instructions on installing and configuring the 
software. 
Project Management User's Guide - Provides instructions for setting up the databases, creating 
permission groups, backing up and restoring project data, assigning access permissions to the 
model, defining and managing locations for Global Workshare, and version migration. 
SmartPlant 3D Global Workshare Guide - Provides instructions for setting up the software and 
the databases to work in a workshare environment. 
SmartPlant 3D Interference Checking Guide - Provides information on installing, configuring, 
and using the interference detection service. 
SmartPlant 3D Integration Reference Guide - Provides information about installing, configuring, 
and using SmartPlant 3D in an integrated environment. 
SmartPlant 3D Interpreting Human Piping Specifications - Provides information about how to 
interpret human piping specifications so that you can create the corresponding piping 
specification in the software. 
SmartPlant 3D Export to PDMS - Provides information about how to export model data from 
SmartPlant 3D to PDMS. Specific guidelines relating to best practices and known limitations of 
the export functionality are also included. 

Preface 
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SmartPlant 3D Point Cloud Reference - Provides information for referencing point cloud files 
provided by point cloud vendors in SmartPlant 3D. 
SmartPlant 3D Troubleshooting Guide - Provides information on how to resolve errors that you 
may encounter in the software by documenting troubleshooting tips, error messages, and To Do 
List messages. 
SmartPlant 3D Plant Design System (PDS) Guide - Provides all information needed to use PDS 
with SmartPlant 3D. Topics include referencing active PDS projects in SmartPlant 3D, exporting 
PDS data and importing that data into SmartPlant 3D, and converting PDS reference data to 
SmartPlant 3D reference data. 
SmartPlant 3D/SmartMarine 3D Programmer's Guide - Provides information about custom 
commands, naming rules, and symbol programming. This document is delivered, if you install 
the Programming Resources, to the [Product Folder]\3D\Programming\Help folder. 

User's Guides 
Catalog User's Guide - Provides information about viewing, editing, and creating reference data 
and select lists (codelists). 
Common User's Guide - Provides information about defining workspaces, manipulating views, 
and running reports. 
Electrical User's Guide - Provides information about routing electrical cable, cableway, cable 
tray, and conduit. 
Equipment and Furnishings User's Guide - Provides information about placing equipment. 
Grids User's Guide - Provides instructions for creating coordinate systems, elevation grid 
planes, vertical grid planes, radial cylinders, radial planes, grid arcs, and grid lines. 
Hangers and Supports User's Guide - Provides instructions on placing piping, duct, and 
cableway supports in the model. 
HVAC User's Guide - Provides instructions for routing HVAC duct. 
Orthographic Drawings User's Guide - Provides information about creating and managing 
orthographic drawings. 
Piping Isometric Drawings User's Guide - Provides information about creating and managing 
piping isometric drawings. 
Piping User's Guide - Provides instructions for routing pipe and placing valves, taps, and pipe 
joints. 
Reports User's Guide - Provides information about creating and managing spreadsheet reports. 
Space Management User's Guide - Provides instructions for placing space objects such as 
areas, zones, interference volumes, and drawing volumes in the model. 
Structural Analysis User's Guide - Provides instructions for defining loads, load cases, load 
combinations, and the importing and exporting of analytical data. 
Structure User's Guide - Provides instructions for placing structural members such as: beams, 
columns, slabs, openings, stairs, ladders, equipment foundations, and handrails. 
Systems and Specifications User's Guide - Provides instructions for creating systems and 
selecting which specifications are available for each system type. 

Reference Data Guides 
SmartPlant 3D 2D Symbols User's Guide - Provides command reference information and 
procedural instructions for creating 2D symbols used to represent collars, clips, profiles, 
brackets, and other items. 
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SmartPlant 3D 2D Symbols Reference Data Guide - Provides information about the 
two-dimensional symbols used in all tasks. 
Drawings and Reports Reference Data Guide - Provides information about reports reference 
data. 
Electrical Reference Data Guide - Provides information about electrical cable, cableway, cable 
tray, and conduit reference data. 
Electrical 3D Symbols Reference - Provides information about the cable tray and conduit 3D 
symbols that are available. 
Equipment and Furnishings Reference Data Guide - Provides information about equipment 
reference data. 
Equipment 3D Symbols Reference - Provides information about the equipment, equipment 
component, design shapes, and design aides 3D symbols that are available. 
Hangers and Supports Reference Data Guide - Provides information about hangers and 
supports reference data. 
Hangers and Supports 3D Symbols Reference - Provides information about the hanger and 
support 3D symbols that are available. 
Hangers and Supports SmartPart Symbols Reference - Provides information about the hanger 
and support SmartPart symbols that are available. 
HVAC Reference Data Guide - Provides information about HVAC reference data. 
HVAC 3D Symbols Reference - Provides information about the HVAC 3D symbols that are 
available. 
SmartPlant 3D Reference Data Guide - Provides instructions about the Bulkload utility, 
codelists, and the reference data common to several disciplines. 
Piping Reference Data Guide - Provides information about piping reference data including piping 
specifications, piping specification rules, piping parts, and piping symbols. 
Piping 3D Symbols Reference - Provides information about the piping 3D symbols that are 
available. 
Space Management Reference Data Guide - Provides information about space management 
reference data. 
Structure Reference Data Guide - Provides information about structural reference data. 
Structure 3D Symbols Reference - Provides information about the stair, ladder, footings, and 
equipment foundation 3D symbols that are available. 

ISOGEN Guides 
Symbol Keys Reference Guide - Provides information about the symbol keys for isometric 
drawings. This guide is from Alias, the makers of ISOGEN. 

Documentation Comments 
We welcome comments or suggestions about this documentation. You can send us an email at: 
PPMdoc@intergraph.com. 
Documentation updates for supported software versions are available from eCustomer 
https://crmweb.intergraph.com. 
 

https://crmweb.intergraph.com/


Preface 
 

 
10 SmartPlant 3D Installation Guide 

 

What's New in the Installation Guide 
The following changes have been made to the installation guide. 
Version 2011 R1 (9.1) 
 SmartPlant 3D now uses Intergraph Batch Services to help you run large, time-consuming 

operations on a separate computer or during off hours, leaving your workstations available 
for other tasks. For more information, see Installing Intergraph Batch Services (on page 
163). (P3 CP: 169878) 

 A new utility, ConfigureDrawingsBatch, must be run each time mapped account settings 
are changed. For more information, see Configuring the Batch Services Server for Drawings 
Tasks (on page 172). 
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S E C T I O N  1  

The Intergraph SmartPlant family of process industry solutions is an open line of 
discipline-specific software tools that provide an integrated solution for the entire plant life cycle. 
SmartPlant provides knowledge-based, intuitive, easy-to-use, accessible, flexible, and 
data-driven tools that support global workflows. The software enables users to create logical and 
physical definitions of the plant model and enables access to plant data from conceptual design 
through decommissioning. 
SmartPlant is the fulfillment of the Intergraph vision to speed and improve the creation of 
information and provide this data to multiple users at any moment in the appropriate form. 
Workflows are compressed, reducing production time, lowering costs, enhancing global 
execution, and extending the life and usability of plant information. 

SmartPlant 3D 
SmartPlant 3D uses Web and Windows technologies to provide a familiar interface for the user 
to produce step- changes in three-dimensional detailed plant design, procurement, construction, 
and operational system performance. This new data-centric solution approach generated by 
SmartPlant 3D synchronizes key elements of integration and relationships. 
 Integration - SmartPlant 3D allows multiple engineering disciplines to work concurrently 

and in real-time against relational databases. 
 Relationships - SmartPlant 3D's relationship manager controls design changes across 

disciplines, which in turn establishes and maintains appropriate behaviors among structures, 
equipment, and systems. 

SmartPlant 3D understands that plant design encompasses more than just 3D modeling. As 
such, SmartPlant 3D is designed to integrate the SmartPlant Product Model with Enterprise 
Resource Planning (ERP), Operations and Maintenance (O&M), and Front End Engineering and 
Design (FEED). Traditionally, the only way to extract and load data from one application to 
another was through neutral format text files. 
Session files are used by SmartPlant 3D to empower users to define their own view of objects in 
the database. The Project Management task enables users to administer and restrict user 
permissions to areas within the design catalog and the plant model. The optimistic locking 
feature in SmartPlant 3D makes it possible for users to work concurrently in the same 
environment and with the same component, whether it's specific to plant design or associated 
with the relationship of the components themselves. Additional features, such as angle locking 
and interference checking, make SmartPlant 3D the ideal software to manage system 
performance and maintain design intent. 
 

Welcome to SmartPlant 3D 



Welcome to SmartPlant 3D 
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S E C T I O N  2  

Equipment Modeling Capability 
Whether using one of the delivered symbols or a custom symbol that you define yourself, 
symbols are a key building block used to create your model. The software uses two basic types 
of symbols: 2D and 3D. 
The 2D symbols are used to represent structural member cross-sections. Two-dimensional 
symbols for structural cross-sections are delivered in the [Product 
Folder]\SharedContent\CrossSections folder. You can use any of the defined cross-sections or 
define your own cross-sections using the software's 2D Symbols application. This application 
allows you to define different representations for the cross-section using layers. You can also 
define variables to drive the dimensions of the cross-section symbol. 
An extensive library of 3D symbols is delivered in the various subfolders located in the [Product 
Folder]\SharedContent folder on the reference data server computer. The 3D symbols are used 
to represent equipment, hangers, HVAC components, piping components, and so forth in your 
model. You can also create custom three- dimensional symbols using the SmartPlant 3D 
Symbol/Part Definition Wizard or Solid Edge®. 
The SmartPlant 3D Symbol/Part Definition Wizard allows you to create and customize 
three-dimensional symbols that fit your company or project. The wizard produces a Visual 
Basic® project for building the symbol ports and graphics, and generates an Excel workbook for 
bulkloading the symbol data into the Catalog database. 
While not prerequisite software, you can also use Solid Edge with SmartPlant 3D. With Solid 
Edge, you can build intelligent equipment reference data libraries of base parts that can be 
placed into the SmartPlant 3D model. An entire catalog of standard equipment can be modeled 
with Solid Edge, as well as custom, one-of-a-kind equipment for specific plants. 
Additional information on the software's equipment modeling capabilities, including parameter 
descriptions of the delivered symbols, how to create 2D and 3D symbols and incorporate them 
into your reference data, is available in the SmartPlant 3D Reference Data Guide, the 
SmartPlant 3D 2D Symbols User's Guide, and the SmartPlant 3D Symbols Reference Data 
Guide. Each of these documents is available from Help > Printable Guides in the software. 

Isometric Drawing Capability 
The software's isometric drawing interface gives users the ability to create piping isometric 
drawings by extracting data from 3D models. Additionally, the SmartPlant 3D isometric drawing 
interface works with ISOGEN® software that not only enables users to create piping isometric 
drawings, including dimensioning, but that also allows users to generate notes, recognize 
attribute changes, and define which symbols to use in the final drawings. Knowledge of 
isometric drawings is required to effectively utilize this functionality. For more information on 
isometric drawing capabilities, see the Piping Isometric Drawings User's Guide. 
 
 

Third-Party Integration 



Third-Party Integration 
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S E C T I O N  3  

Working with the software in an integrated environment allows you to standardize and improve 
the communication among the various authoring tools you use in the course of designing, 
constructing, and operating a Plant. SmartPlant Foundation acts as a central repository for data 
and a medium through which information is shared among other tools, such as SmartPlant 
Instrumentation, SmartPlant P&ID, and SmartPlant 3D. 
The following graphic displays what SmartPlant 3D publishes and retrieves and additional 
information about what data is exchanged. 

 
Most of the commands that provide access to SmartPlant integration functionality exist on the 
SmartPlant menu in the various SmartPlant 3D task environments. For example, in the 
Drawings and Reports task, you can use the commands on the SmartPlant menu to publish 
orthographic drawings, 3D model data, isometric drawings, and reports. You can also use the 
SmartPlant menu to access the SmartPlant Foundation Web Client in order to browse in 
SmartPlant Foundation and subscribe to change notifications and compare documents. In other 
SmartPlant 3D tasks, you can use the SmartPlant menu commands to correlate items between 
the Plant and the SmartPlant Foundation database and retrieve P&IDs, DDP files, Cable 
Schedules, Plant Breakdown Structure and Work Breakdown Structure, and Project Lists. 

Working in an Integrated Environment 



Working in an Integrated Environment 
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For detailed information about using the SmartPlant integration commands found in SmartPlant 
3D, see the Common User's Guide and the Orthographic Drawings User's Guide. Both 
documents are available with the Help > Printable Guides command in the software. 
For more information about configuring SmartPlant 3D to work in an integrated environment, see 
Configure for an Integrated Environment (on page 115). 

SmartPlant Enterprise Work Process Documentation 
Integration between SmartPlant Enterprise applications is described in Integration Capability 
Statements. These documents are available on http://crmweb.intergraph.com/ 
https://crmweb.intergraph.com under Product Documentation > Enterprise Work Processes. 
Integration Capability Statements provide guidance about how SmartPlant Enterprise technical 
capabilities map to work processes. Each document describes out-of-the box capabilities for 
implementing the work process, including:  
 Swim lane diagram of work process  
 Critical suggestions and precautions 
 
 

https://crmweb.intergraph.com/
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S E C T I O N  4  

Supporting internationalization in a homogeneous environment is one of the enhancements 
available in SmartPlant Enterprise. A homogeneous environment uses elements from only a 
single locale. For example, a German customer running on a German operating system using 
only German characters and German cultural conventions is a fully supported homogeneous 
environment configuration. 

Homogeneous Environments 
When starting a new project, use extra care during installation and configuration to ensure the 
proper creation and maintenance of homogeneous environments: 
 All the computers (servers and clients) within an integrated SmartPlant Enterprise 

implementation must have the same regional settings, and no one should change the 
regional settings after the project has started. 

 Do not cross the decimal locale boundary. This is the most common cause of numeric data 
corruption and calculation errors. Having users with different regional settings (like with a 
period versus a comma for the decimal point) causes the software to interpret values 
unpredictably. For example, a pipe run with a pressure of 35.3 psi can be read by the 
software as 353 psi to the user with different regional settings. A cable length defined as 39 
ft 11,21 inches has been interpreted as 121718910971323 meters when published to an 
XML file. These incorrect interpretations may be used in internal software calculations and 
can be impossible to backtrack or correct. Do not change the decimal point character to try 
to solve an issue. Doing so will only corrupt values in the database or in text files. 

 Do not cross the character-set locale boundary. For example, the character set boundary 
between Western (Latin-based) and Eastern Europe (Cyrillic-based), or between Eastern 
Europe and Japan. 

 Create Oracle databases using AL32UTF8 for the database character set and AL16UTF16 
for the NLS character set. 

 Never modify the NLS_LANG registry entry on an Oracle client. Doing so causes the 
character data not to convert to Unicode. 

 Create Microsoft SQL Server databases with locale-specific collation settings and ensure 
that all databases have the same setting. 

Heterogeneous Environments 
In contrast, a heterogeneous environment using elements from different, or even multiple 
locales, is not supported. Many customers are currently operating in unsupported 
heterogeneous environments and are often not aware of that fact. Examples of heterogeneous 
environments: 
 Entering or viewing Japanese data on an US/English operating system 
 Using German Regional Settings (where the decimal point is a comma) on a US/English 

operating system 
 Using databases with different character encodings such as CL8MSWIN1251 or JA16SJIS 
 Using multiple languages in a project, especially when crossing language-group boundaries 
 Using an English server with different local language clients 

Internationalization 
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International / Bi-lingual Projects 
International bi-lingual projects are possible; however, great care must be used when 
configuring these environments. Limitations exist and must be properly understood: 
 Oracle and MS SQL Server databases can reside on any language operating system, as 

long as the databases have been created and configured with proper Unicode and collation 
settings. 

 All Microsoft operating systems (Japanese, Russian, German, and so forth) can enter 
English characters. The reverse, however, is not true in most cases. 

 Keyboard-locale can be changed as long as a character-set and code-page boundary is not 
crossed. For example, English, German, French, and Spanish characters can all be used in 
the same project because the same Windows® code-page (1252) is used. However, Russian 
characters (code-page 1251) cannot be used in a US/English environment. 

 You must decide which language operating system will be the master for bi- lingual projects. 
The following is an example of a Russian-based project: 
Companies in the United States and the United Kingdom are working a project with a Russian 
company and the deliverables (drawings, reports, and so forth) must ultimately be provided in 
Russian. The companies in the U.S. and the U.K. are working the project using the "master" 
Russian operating systems (possibly using virtual Russian operating systems running on 
VMware Workstation). The U.S. and U.K. companies can install and use English Microsoft 
Office products on the Russian operating system because Office products are globally enabled. 
If a Russian interface exists for the SmartPlant Enterprise application, then Russian users can 
use the Russian interface while the English-speaking users would continue to use the 
US/English interface. English-speaking engineers can enter English characters. 
Russian-speaking engineers can enter Russian characters. 
However, because the Russian locale uses different decimal and character-set locales, 
everyone (English and Russian engineers) must use the Russian decimal symbol which is a 
comma. For customization purposes, databases can be modified to accommodate new 
Russian-specific requirements (fields, properties, and so forth.) Using filters, display sets, and 
other software features, bi-lingual projects can be further customized. Graphic data, reports, and 
so forth can be created in either or both languages. 

 Do not change regional settings to reflect a U.S. environment in order to resolve 
problems in a non-US/English homogeneous configuration. Doing this creates a heterogeneous 
configuration that will cause other possibly hidden problems that cannot be corrected. Everyone 
working on a project must use the same regional settings and character set throughout the life of 
the project. 

Questions and Assistance 
Please contact your support representative for assistance and answers to your questions: 
Intergraph Customer Support (http://support.intergraph.com (http://support.intergraph.com)). 
 

http://support.intergraph.com/
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S E C T I O N  5  

A typical data flow between client and server computers is shown below. Before beginning an 
installation of SmartPlant 3D, verify that your computers meet the hardware recommendations 
and software requirements. 

 Multiple services can be installed on the same physical computer for small projects. 

 
 

SmartPlant 3D Hardware and Software 
Recommendations 
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SmartPlant 3D Database Server Recommendations 
Before beginning an installation of SmartPlant 3D, verify that your servers meet the following 
hardware recommendations and software requirements. 

Applicable Hardware 
 Database server 
 File server 

Hardware Recommendations 
 Intel Xeon® 5600 Series or better (64-bit instruction set, not Itanium®) 
 4 GB to 32 GB or greater RAM depending on project size 
 For hard drive size, see SmartPlant 3D Project Hardware Sizing Recommendations (on 

page 28) 
 Backup system for server 
 Access to DVD drive, either locally or through a network connection 
 1 GbE or higher network interface for client connections 

Supported Operating Systems 
 Microsoft Windows Standard/Enterprise Server 2008 R2 (64-bit) 

Supported Database Servers 
 Microsoft SQL Server 2008 Service Pack 3 (Standard edition for stand-alone environments; 

Enterprise edition for Global Workshare environments; 64-bit) 
 Oracle 11g R2 (11.2.0.2) with Patch 8 (Standard edition for stand-alone environments; 

Enterprise edition for Global Workshare environments; 64-bit) 
 There are internationalization considerations concerning the SQL Server collation 

settings you specify that relate to reference data, using SmartPlant Enterprise integrated 
systems, Global Workshare Configuration, multiple locales, backup/restore, reports, and 
upgrading to future releases. Please contact Intergraph Customer Support for specific 
configuration questions. 
With SmartPlant 3D, 64-bit servers can be used with 32-bit operating systems, databases, and 
workstations. For increased performance, Intergraph recommends a 64-bit server, operating 
system, and database, especially for medium and large projects. The 64-bit versions of SQL 
Server 2008 SP3 and Oracle 11g R2 (11.2.0.2) with Patch 8run on the 64-bit version of 
Microsoft Windows Server 2008 R2. 

Software Prerequisites 
 Adobe Reader (required to view the Software License Agreement and Printable Guides. You 

can download Acrobat Reader from the Adobe web site.) 
 Microsoft XML Core Services (MSXML) 6.0 (Database server only) 
 Microsoft .NET 3.5 SP1 (Database server only) 

 
 For more information on hardware requirements, see SmartPlant 3D Project Hardware 

Sizing Recommendations (on page 28). 
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 For information on disk space usage and determining RAID configuration, see Disk Usage 
(on page 64). 

 For specifications regarding minimum hard drive disk space requirements by the product 
setup, see Disk Partitioning Guidelines (on page 27). 

 On the server, distribute files across several disk drives with the following minimum 
distribution: operating system and database software on one drive, database data files on 
another drive, and the database log file on the third drive. 

See Also 
SmartPlant 3D Hardware and Software Recommendations (on page 19) 
 

SmartPlant 3D Workstation Recommendations 
Before beginning the installation of SmartPlant 3D, verify that your end-user workstation 
computers meet the following hardware recommendations and software requirements. 

Applicable Hardware 
 Administrative client 
 Modeling client 
 Interference detection computer 
 Drawing batch computer 
 Name generator computer 
 Duplication and synchronization computer 
 SmartPlant Piping Specification Remote computer 

Hardware Recommendations 
 Intel Core i7, Quad Core 
 6 GB RAM 
 Access to a DVD drive, either locally or through a network connection 
 Monitor capable of a minimum of 1280 x 1024 resolution 
 Graphics card designed for 3D intensive applications that meets the following requirements: 

 32-bit main RGBA pixel buffer 
 Hardware OpenGL 2.1 support 
 Hardware Z buffer: 24 bit or higher 
 256 MB RAM 
 8-bit stencil buffer 
 Hardware Alpha blending support 
 Graphics acceleration set to full 
 Hardware Anti-aliasing support recommended 
 Latest available drivers should be installed 

 1 GbE network interface 

Video Cards 
There have been many enhancements to the graphic engine of SmartPlant 3D. Most issues are 
resolved by loading the most current display driver or rolling your current display driver back one 
version. If the current driver does not fix your particular card's problem, then please copy the 
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"CoreDisplaySettings.ini" file from [Product Folder]/Core/Tools/Administrator/Bin to [Product 
Folder]/Core/Shared/bin and contact your SmartPlant 3D support representative. 
We recommend workstation class graphics cards (designed for use with CAD applications) with 
as much RAM as is affordable. The minimum RAM is 256MB, but more RAM is better. Because 
the world of graphics cards changes so quickly, we can only document the specifications 
required by SmartPlant 3D and publish the cards we have actually used in certification. 

 All clients referencing Z+F Point Cloud data need to turn off the SmartPlant 3D hardware 
with the CoreDisplaySettings.ini file.  
The following graphics cards have been tested and support the display enhancements: 
 ATI Fire GL V3600  

To obtain better graphic performance with SmartPlant 3D, change the following settings: 
 On ATI FireGL video cards, right-click on the desktop and select Properties > Settings 

> Advanced. On the Configuration tab, create a new configuration profile called 
SmartPlant 3D. After this configuration profile is created, select the SmartPlant 3D 
profile, select Modify, and then check Force copy swap. 

 ATI Radeon HD 2400 Pro 
 NVidia GeForce 7600 GT 

To obtain better graphic performance with SmartPlant 3D, enter change following settings: 
 On NVidia GeForce cards, right-click on the desktop and select Properties > Settings 

> Advanced. On the NVIDIA Card tab, select OpenGL Settings in the Performance 
and Quality Settings section. In the dialog box that opens, change the Buffer-Flipping 
Mode selection to Use block transfer, and then click OK. 

 NVidia Quadro FX 580 
 NVidia Quadro FX 880M 
 NVidia Quadro FX 1800 
The following graphics cards do not support the display enhancements: 
 ATI Fire GL V3100 
 ATI Radeon x1300/1500 
 Intel 82945G Express 
 NVidia GeForce FX 5200 
 NVidia Quadro FX 3450/4000 
As a supplement to this information, a Microsoft Excel workbook is provided on eCustomer that 
records anecdotal evidence obtained from users. Please go to eCustomer at 
https://crmweb.intergraph.com (https://crmweb.intergraph.com/ecustomer_enu) and select 
Download Software Updates > Products > SmartPlant 3D > Technical Notes and White papers 
> Graphics cards used with SmartPlant 3D. 
Neither of the previous lists is comprehensive. In some cases, the SmartPlant 3D middle tier 
error log (with the error logging level set to at least "2-Detailed") will provide more information. 
Please see the examples of messages returned in the error log listed below: 
 The graphics card or graphics card driver does not support Textures/Shaders. An updated 

graphics driver could improve performance.  
This indicates that the graphics adapter, driver or display settings do not support the 
"Shaded with Hardware Enhanced Edges" Render Mode on the Format View dialog box. In 
addition, the graphics adapter, driver or display settings do not support textures.  

 The graphics card or graphics card driver does not support Shaders. An updated graphics 
driver could improve performance.  

https://crmweb.intergraph.com/ecustomer_enu
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This indicates that the graphics adapter, driver or display settings do not support the 
"Shaded with Hardware Enhanced Edges" Render Mode on the Format View dialog box. 
However, textures are supported.  

 The graphics card or graphics card driver does not support Textures. An updated graphics 
driver could improve performance.  
This indicates that the graphics adapter, driver or display settings do not support textures. 
However, the "Shaded with Hardware Enhanced Edges" Render Mode on the Format View 
dialog box is supported. Please note that the performance may be slow on an ATI card.  

 Hardware Acceleration is Turned off VBO Texture and Hardware edges will not be 
supported.  
This message indicates that Hardware Acceleration in Display Settings is disabled or the 
client is being accessed via Remote Desktop or Citrix Client. If Hardware Acceleration in 
Display Settings is disabled, it should be enabled by selecting the "Advanced" button on the 
Settings tab of the Display Properties dialog. Then, the Hardware Acceleration can be 
modified from the Troubleshoot tab.  

 Due to the 32-bit precision limitations of graphic cards, you may need to create 
several design coordinate systems so that the objects being modeled are within 10,000 meters 
(6.2 miles) of the global coordinate system. Objects modeled outside this limit will not display 
correctly. If your model coordinate values are larger that this limit (for example, E = 20,000, N = 
30,000), to get the coordinate readout that you want, you should define a coordinate system at 
correspondingly large negative values (example, E = -20,000, N = -30,000). Then, use the 
coordinate system you created as your active coordinate system for modeling and output. Do 
not bring this new coordinate system into your workspace or you will have the display problems 
that you are trying to avoid. 

Supported Operating Systems 
 Microsoft Windows 7 Service Pack 1 - Professional or Enterprise with UAC 'On' at Level 3 

(Default) (32-bit and 64-bit) 
 Microsoft Windows Vista Business with Service Pack 2 with UAC 'On' (Default) (32-bit and 

64-bit) 
 Microsoft Windows Server 2008 R2 (64-bit) only as a client for Citrix XEN App 6.0 

 Citrix XENApp 6.0 can be installed only on the Windows 2008 Server R2 64-bit 
operating system. The Windows 2008 Server acts as a client in this case. The Windows 
2008 Server R2 64-bit operating system can also be used to install an ancillary server, such 
as IFC, Drawings, or Intergraph Batch Services. 

 Microsoft Windows XP Professional SP3 (32-bit) 
 Microsoft Windows XP Professional SP2 (64-bit) 

Supported Database Clients 
 Microsoft SQL Server 2008 Standard Service Pack 3 (32-bit and 64-bit) (Required for 

Project Management and Interference Checking, otherwise optional) 
 Oracle 11g R2 (11.2.0.2) with Patch 8; 32-bit only (Required for all client computers) 

Software Prerequisites 
 Microsoft Internet Explorer 8.0 or greater (required for viewing the documentation delivered 

with the software) 
 Adobe Reader 9.0 or later (required for viewing the Software License Agreement and 

Printable Guides. You can download Acrobat Reader from the Adobe web site.) 
 Microsoft XML Core Services (MSXML) 6.0 (required for extracting isometric drawings) 
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 Microsoft .NET Framework 3.5 SP1 
 Microsoft Visual C++ 2008 SP1 Redistributable Package with MFC Security Update 
 Microsoft Office 2003 (Windows XP only), Microsoft Office 2007, or Microsoft Office 2010 

(32-bit only) (Windows Vista, Windows 7, or Windows Server 2008 R2) 
 Intergraph Batch Services 6.1.0.3 or later if you plan to use the computer for remote batch 

processing 

 
 For specifications regarding minimum hard drive disk space requirements by the product 

setup, see Disk Partitioning Guidelines (on page 27). 
 Dual screen configurations should have either a single graphics card with two VGA outputs 

or two identical graphics cards. The graphics cards should otherwise meet the requirements 
of the specified graphics card recommendations. 

 Use thread safe video drivers and CAD application certified video cards when using multiple 
processor systems. 

See Also  
SmartPlant 3D Hardware and Software Recommendations (on page 19) 
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Software Loading Order 
The ability to run the software successfully is greatly affected by the order in which all the 
necessary and underlying products are loaded. Follow the loading order below to prevent 
components being out-of-sync. Following this loading order also helps with analysis of any 
post-installation problems you might encounter. 
The following table outlines the established load order for the prerequisites associated with each 
of the SmartPlant 3D installations: 

Database Server Installation Workstation Installation 

Windows Server 2008 R2 (64-bit) Windows 7 SP1 Professional or Enterprise with 
UAC 'On' at :Level 3 (Default) (32-bit and 64-bit), 
Windows Vista Business SP2 (32-bit and 64-bit), 
Microsoft Windows XP Professional SP3 (32-bit), 
or Microsoft Windows XP Professional SP2 (64-bit) 

Microsoft .NET 3.5 SP1 Microsoft .NET Framework 3.5 SP1 

 Microsoft Visual C++ 2008 SP1 Redistributable 
Package with MFC Security Update 

 Internet Explorer 8.0 or greater 

 Microsoft XML 6.0  
 Microsoft SQL Server 2008 requires XML 

6.0 and will automatically install it as part of the 
SQL Server 2008 Prerequisite installation. 

Adobe Reader Adobe Reader 

 Microsoft Office 2003, Office 2007, or Office 2010 
(32-bit)2 

Oracle 11g R2 (11.2.0.2) with Patch 8 (Standard 
Edition for stand-alone environments; Enterprise 
Edition for Global Workshare environments; 
64-bit) or  

Oracle 11g R2 (11.2.0.2) with Patch 8 Client 
Release (32-bit only); (Do not use the Oracle "light 
client" as it does not include some DLLs required 
by SmartPlant 3D.) or 

Microsoft SQL Server 2008 Service Pack 3 
(Standard Edition for stand-alone environments; 
Enterprise Edition for Global Workshare 
environments; 64-bit) 

Microsoft SQL Server 2008 Client Service Pack 31; 
(32-bit and 64-bit) 

 SmartPlant License Manager 2010 (11.0) or higher 

1 Microsoft SQL Server 2008 Client (with SQL Server 2008 SP3) is required only for the client 
software installation if the Project Management option is installed; otherwise, they are not 
integral to the default workstation software installation. 
2 When creating drawing borders or embedded reports within the Drawings and Reports task on 
computers with Microsoft Office 2003, Office 2007, Office 2010 (32-bit), you must modify the 
security settings in Excel to allow Visual Basic projects to run. For more information about Office 
2003, Office 2007, Office 2010, and service packs, refer to the Microsoft web site 
(http://www.microsoft.com/). 
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 Do not skip any restarts recommended by the system. Doing so can have 
unintended consequences. 
Other users who want to perform different tasks in the overall design workflow might need 
additional software, such as Visual Basic 6.0; Visual Studio 2008 SP1; Siemens Solid Edge 
Version 20 or ST3; Tekla Structures Version 16.0, 16.1, or 17.0; or AceCad StruCad Version 16. 
Additionally, if you intend to reference or export PDS projects, you must install the appropriate 
PDS add-in. The PDS data reference and export add-ins are delivered on the product DVD. 

 
 This version of the software supports PDS 2010 SE and PDS 2011 SE. 
 PDS software and all of its prerequisite software are also required in order to use the PDS 

integration functionality. For more information, see Integrating with PDS (on page 116). 
 If you are installing the Name Generator Service on an Oracle 32-bit Client computer, the 

computer must be configured to access the Oracle database server through Net Manager. 
 If you are installing the 64-bit Name Generator Service on an Oracle 64-bit Client computer, 

the firewall must be configured to allow DCOM Dynamic Ports. For more information, see 
Configure the Firewall to Allow DCOM Communication in Windows 2008 Server (on page 
79). 

Special Consideration for Non-English Locales 
The system language specified for Microsoft Office must be the same as the system language 
specified by the operating system. For example, if your operating system language is English, 
Microsoft Office must also be set to English. For overall assistance with installing the software in 
a non-US English environment, visit the Intergraph Support web site at 
http://www.intergraph.com/support. 

Virus Scanners and Performance  
Other programs running on the computer, such as virus scanners, media players, and mail 
programs, might affect the performance of SmartPlant 3D. Virus scanners affect performance by 
continuously checking the data files and log files. Exclude the database data folder on the 
database server from the virus scanner. For maximum performance, reduce the number of 
processes running while using SmartPlant 3D. 

See Also 
SmartPlant 3D Hardware and Software Recommendations (on page 19) 
 

Installation Checklist 
For the recommended installation workflow, please see the installation checklist 
(SP3DInstall_Checklist.pdf), available in the Help folder on the product media. This checklist is 
also delivered during product set up to c:\Program Files\Common 
Files\Intergraph\SmartPlant\Help folder for future reference. 
 

Disk Partitioning Guidelines 
For best performance when loading and running the software, partition the hard drive according 
to the following guidelines: 
 Format all partitions as NTFS file systems (FAT is not supported). 
 By default, the software is installed to C:\Program Files\SmartPlant\3D. Verify that you have 

sufficient free space on your C:\ partition (or another partition if you want to install there). 
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Recommended Disk Space for Software Setup 
SmartPlant 3D Installation - Default setup for a workstation computer1 1.8 GB 

SmartMarine 3D Installation - Default setup for a workstation computer1 2.8 GB 

SmartPlant 3D Installation - Complete setup for a workstation computer2 2.25 GB 

SmartPlant 3D Reference Data - Default setup for database server 1.27 GB 

SmartMarine 3D Reference Data - Default setup for database server 1.95 GB 
1 The default setup for a SmartPlant 3D workstation computer provides all the environments 
necessary for general SmartPlant 3D modeling. 
2 The complete setup for a SmartPlant 3D workstation computer includes all features and adds 
the administrative functionality: plant creation, database migration, access management, 
database interference detection, and includes the following options only: Project Management, 
SmartPlant 3D Server Connectivity, Bulkload Reference Data, and Database Interference 
Detection Service. Additionally, a complete setup includes the 3D Model Import and Piping 
Specification Remote Access Server options, which installs the required components for 
importing model data into SmartPlant 3D and the necessary software for correlating piping 
specification data between SmartPlant 3D and SmartPlant P&ID, respectively. 
You also will need additional disk space if you intend to use other products, such as Visual 
Studio or Solid Edge. Please consult your system administrator for this and additional software 
not provided by Intergraph Process, Power & Marine. 

 Do not continue with installation until enough disk space is free on the computer 
acting as the database server and each workstation computer as stated in the aforementioned 
guidelines. 
 
 

SmartPlant 3D Project Hardware Sizing 
Recommendations 

Use these guidelines and examples in sizing SmartPlant 3D hardware configurations, including 
those that include Global Workshare Configuration (GWC). The recommendations are based 
SQL Server 2008 SP3 and Oracle 11g R2 (11.2.0.2) with Patch 8. 
Hardware sizing, especially for servers, depends on many factors such as: 
 The number of concurrent users per site 
 The number of sites (Global workshare) 
 The size of the project (which translates into the size of the databases) 
 Other software that is running on the machine 
For best performance in medium to large Global Workshare Configurations, Intergraph 
recommends using 64-bit hardware and operating system. It is possible to use 64-bit hardware 
and a 32-bit operating system. 
With a Microsoft SQL database on 64-bit hardware and operating system, SmartPlant 3D was 
tested with 11 Global Workshare sites. The 64-bit version of Oracle can support a few more 
sites. It is possible to combine 64-bit hardware and operating systems on servers with 64-bit or 
32-bit client workstations running 32-bit operating systems. 
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Concurrent Users 
The size of the system depends partly on the number of concurrent users, that is, users actively 
working at the same time. In a Global Workshare Configuration (GWC), it is probable that work 
will be done at several sites in a non-concurrent way. In this case, there is less impact on 
performance. For example, if you have two sites with 60 users at each site but the users at the 
two sites do not work at the same time, you could consider the user load to be 60 users. 
In a Global Workshare Configuration when users are working concurrently at several sites, the 
work done at one site will impact each site as the data is pushed to the other sites. In a hub and 
spokes configuration, the data is first pushed to the hub then the hub pushes it to the other sites. 
We estimate that the equivalent user load (the number of effective users) for each server to be 
the users on that server plus 25% of the total concurrent users of all the other sites. For 
example, in a configuration with 6 sites and 40 users at 5 sites, and 5 users at 1 site: 
 When 3 sites (with 40 users) are working concurrently, the equivalent number of users at 

each site is: 40 (concurrent users for this site) + (0.25 * (2 * 40)) (users for the 2 other sites) 
= 60 users. 

 When all 6 sites are working concurrently: 
a. The equivalent number of users at each of the 40-user sites is: 40 + (0.25 * (165)) = 81 

users 
b. The equivalent number of users at the 5-user site is: 5 + (0.25 * (200)) = 55 users. 

 

Project Size Estimates 
Use the following estimates to help define project size. The model database is an important 
factor in determining project size. 
The number of users for each project size below (small, medium, and large) is the effective 
number connected to a single server. The effective number of users should be calculated by 
taking into consideration: 
1. Global Workshare Setup - use the 25% formula above 
2. Drawing Batch server - add 3 users 
3. Remote IFC - add 1 user 

One small project 
 1 to 15 effective users on one database server 
 Model database up to 8 GB 
 Server is used for model and catalog databases and catalog file server 
 Separate interference checking (IFC) computer 
 Separate drawing batch computer 
 Name generator server and licensing computer 
 Modeling (detail design) and administrator workstations can be on separate or on the same 

computers 

One medium project 
 16 to 50 effective users on one database server 
 Model database 8 – 15 GB 
 Databases and catalog file server 
 Separate interference checking (IFC) computer 
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 One or more separate drawing batch computer 
 Name generator server and licensing computer 
 Modeling (detail design) and administrator computers can be on separate or on the same 

computer 
 Use a separate distribution server for Global Workshare Configuration 

One large project 
 51 to 100 effective users on one database server (contact Intergraph if you plan to have 

more than 100 effective users on one database server) 
 Model database 15 GB or more 
 Databases and catalog file server (have a separate catalog file server for multiple large 

projects or plants sharing the same catalog) 
 Separate interference checking (IFC) computer 
 Multiple separate drawing batch computer 
 Name generator server and licensing computer 
 Modeling (detail design) computers 
 Use a separate distribution server for Global Workshare Configuration 
 Administrator computer 
 

Modeling (Detail Design) Workstation Sizing 
The project size does not have a significant impact on the workstation because users will use 
filters to define the objects with which they will be working. 
 Intel Core i7, Quad Core 
 6 GB RAM 
 Access to a DVD drive, either locally or through a network connection 
 Monitor capable of a minimum of 1280 x 1024 resolution 
 1 GbE network interface 

OpenGL Graphics Cards 
 The following graphics card information is specific to 32-bit workstations. Intergraph is 

investigating graphics cards for 64-bit workstations. 
Graphics cards designed for 3D intensive applications that generate low CPU overhead and 
meet the following requirements (AGP or better): 
 32-bit main RGBA pixel buffer 
 Hardware OpenGL 2.1 support 
 Hardware Z buffer: 24 bit or higher 
 256 MB RAM, 8-bit stencil buffer 
 Hardware Alpha blending support recommended to improve speed of translucent object 

display 
 Hardware Anti-aliasing support recommended 
 Use latest available drivers 
Not all OpenGL graphics cards provide satisfactory results. Many of the recent generation video 
cards provide some level of OpenGL acceleration. Some manufacturers provide poor OpenGL 
drivers that can cause artifacts. Testing has shown that NVIDIA provides good drivers for its 
Geforce2 and beyond Graphics Processing Units (GPU). Cards with double-buffered overlay 
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planes (such as the Wildcat cards) have an advantage because highlighting can be done 
without having to do saves and restores, which may benefit performance in specific cases. 

See Also 
SmartPlant 3D Workstation Recommendations (on page 22) 
 

System Administrator Workstation Sizing 
The Administrator Server includes Project Management synchronization, a memory intensive 
process. 
 Intel Core i7, Quad Core 
 6 GB RAM 
 Access to a DVD drive, either locally or through a network connection 
 Monitor capable of a minimum of 1280 x 1024 resolution 
 1 GbE network interface 
 

Database Server Sizing 
With SmartPlant 3D, 64-bit servers can be used with 32-bit operating systems, databases, and 
workstations. For increased performance, Intergraph recommends a 64-bit server, operating 
system and database, especially for medium and large projects. The 64-bit versions of Microsoft 
SQL Server 2008 SP3 and Oracle 11g R2 (11.2.0.2) with Patch 8run on the 64-bit version of 
Microsoft Windows Server 2008 R2. 
For large projects, Intergraph recommends having a database server that is dedicated to 
SmartPlant 3D and runs only one project. For medium and small projects, several projects can 
be run on the same database server. However, having multiple projects on the same server 
increases the server requirements. When sharing several projects, add additional hard drives 
and increase the memory and CPUs. Also consider the impact of sharing on your network. 

Server Specifications 

Project size Small Medium Large 

Number of processor cores (one Core 2 Duo 
counts as two) 

2 2 – 4 4 – 8 or more 

Memory for SQL Server 2008 SP3 and Oracle 
11g R2 (11.2.0.2) with Patch 8 

4 – 8 GB 8 – 16 GB 32+ GB 

Bus Size, OS, and Database 64-bit 64-bit 64-bit 

The type of memory has a limited impact on the overall performance. 
 Running a Microsoft SQL Server or Oracle database on an Itanium processor-based 

server has not been certified and should not be done. 

Hard Drives 
Distribute files across several disk drives on the server. Each drive does not need a large 
capacity. The speed of the drive is important, so use 15K RPM or faster. Add disk arrays to 
maximize performance if you experience any I/O bottleneck. 
Intergraph recommends RAID 10 for performance and redundancy. 
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Small Project with SQL Server 
The following example shows a configuration for a small project using Microsoft SQL Server 
2008 SP3. The minimum distribution is three physical drives. 

C: Drive Operating system and SQL Server software 

E: Drive Database data files (.mdf files) 

F: Drive Database log files (.ldf files) 

Large Project with SQL Server 
The following example shows a configuration for a large project using Microsoft SQL Server 
2008 SP3. 

C: Drive RAID 1 2 hard drives internal to the server for the operating system 
and the Page File 

E: Drive RAID 10 8-12 SAN drives for the data files for the SQL Server Master, 
Site, Site Schema, Catalog, Catalog Schema, Model, Report, 
and Report Schema databases. 

F: Drive RAID 10 4-8 SAN drives for log files for the SQL Server Master, Site, 
Site Schema, Catalog, Catalog Schema, Model, Report, and 
Report Schema databases. 

G: Drive RAID 0 or 1 hard 
drive 

2 SAN drives for the SQL Server temp database and 
SmartPlant 3D backup files and the Page file 

Large Project with Oracle 
The general recommendation for a large project on an Oracle database is: 

User RAID  
Level 

Physical Disks 
in Array 

Disk Space Requirement Purpose or Contents 

S3D .d files 10 12 No specific requirement 
(N.S.R.) / 500 GB 

Oracle .d data files for 
databases 

S3D .i files 10 8 N.S.R. / 150 GB Oracle .l index files for 
databases 

Redo Log 
& SYSAUX 

10 4 N.S.R. / 150 GB Oracle Redo Logs, 
StreamsTableSpace 
(Workshare only) 

Undo Log 10 4 N.S.R. / 150 GB Oracle Undo Logs and 
Oracle System Files 

Archive 
Log 

5 3 500 GB Oracle Archive Log 

OS, page 
file 

1 2 N.S.R. operating system and 
page file 

 Be sure to spread the Oracle files across separate arrays for added redundancy. 
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Global Workshare Configuration Distribution Server Sizing 
Global Workshare Configuration (GWC) might require a separate server for distribution for large 
projects. 
 Intel Xeon® 5600 Series or better (64-bit instruction set, not Itanium®) 
 4 GB to 32 GB or greater RAM depending on project size 
 For hard drive size, see SmartPlant 3D Project Hardware Sizing Recommendations (on 

page 28) 
 Backup system for server 
 Access to DVD drive, either locally or through a network connection 
 1 GbE or higher network interface for client connections 
 Distribution database on a RAID 1 or RAID 10 disk array (RAID 5 is not ideal because of the 

many writes produced by replication.) 
 Distribution database log file on its own dedicated RAID 1 disk array 
For small projects, a single server (the hub in a hub and spoke configuration) can act as a 
publisher, a distributor, and a subscriber all at the same time. For medium projects in a Global 
Workshare Configuration, the database server can also serve as the distribution server. 
For large projects with many sites, use two different servers: one as publisher and subscriber 
and the other as the distributor. Using a separate server as the distributor helps to reduce the 
load on the publisher. 
 

Interference Checking (IFC) Server Sizing 
You should have a remote project processing computer for interference checking (IFC) that is 
separate from the computer hosting the databases. The interference checking computer can 
process more than one Plant. This computer does not need to be a high-end server, but should 
meet the minimum hardware requirements for a client computer. See SmartPlant 3D 
Workstation recommendations (on page 22) for these requirements. 
There is not a specific hard drive size requirement because the interference detection service 
does not store information locally. 
 
 

Batch Server Sizing 
You can use remote project processing computers, or batch servers, to off-load compute 
intensive tasks such as updating drawings in the Drawings task or running database backups 
and integrity checks in Project Management. 
You should have at least one remote project processing computer for each site database. This 
remote computer does not have to be a high-end server, but should at least meet the minimum 
hardware requirements for a client computer. See SmartPlant 3D Workstation 
Recommendations (on page 22) for these requirements. 

  
 A batch server runs only one batch job at a time. The maximum number of batch jobs that 

can run in parallel for a site database is equal to the number of batch servers. 
 You can use one or more batch servers for a single site database containing multiple model 

databases. 
 You cannot use a single batch server for multiple site databases. 
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File Server Sizing 
You will need a computer to act as a file server with enough disk space for symbols and files. 
This computer does not need to be a high end-server, but should meet the minimum hardware 
requirements for a client computer. See SmartPlant 3D Workstation Recommendations (on 
page 22) for these requirements. 
 
 

License Server and Name Generator Server Sizing 
The Name Generator Service can be installed on a stand-alone computer or can be installed on 
the same computer used for the file server, batch server, IFC server, or license server. 
 

License Server 
SmartPlant License Manager (SPLM) uses server/client architecture to distribute licenses for 
SmartPlant 3D (and other SmartPlant Enterprise products.) SPLM requires very little system 
resources and so can be installed on the batch server, file server, IFC server, or database 
server as long as the hardware configurations below are observed. 

Hardware Configurations 
The SmartPlant License Manager licensing computer software should be installed on a stable, 
single node, hardware configuration (such as a simple PC), with a static IP address, because 
license key installation and license seat usage authentication depends on the information 
gathered from the physical hardware. Any automated changes that cause the hardware 
information not to match with the information used to generate the license key will result in a 
failure of the authentication process. 
Virtual (including VMware®), shadowed, mirrored, dynamic, or distributed hardware 
configurations cannot be used as a SmartPlant License Manager licensing computer. This 
includes terminal (application) servers, networked and distributed storage management 
systems, and so forth. When these specialized systems occur in the user's network, the 
SmartPlant License Manager Server licensing computer should be installed on a separate 
dedicated hardware configuration system. The SmartPlant License Manager licensing computer 
should be situated on the user's network where it can be accessed by all systems that are 
running application software that relies on the SmartPlant License Manager licensing computer 
for license management.  
Multiple SmartPlant License Manager licensing computers can be used in the user's network as 
long as each system is a unique hardware system/installation. If SmartPlant License Manager 
licensing computers are cloned after the license key has been installed, then the license 
management will fail on the cloned system. Each SmartPlant License Manager licensing 
computer requires its own unique license key. 

  
 RAID (redundant array of independent disks) and SAN (storage area networks) are not 

supported on a SmartPlant License Manager license computer. 
The license computer must have the same version (or later) of SmartPlant License Manager 
installed as any client computers. In other words, you cannot use a newer version on a client 
computer to retrieve a license from an older version of SmartPlant License Manager on the 
licensing computer. The license computer must have the same version (or a newer version) 
installed than the clients. 
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Silent Installation 
You can use the Windows Installer to install and uninstall the software using a command line 
rather than the normal user interface. One advantage of using a command line to install 
software is that you can perform unattended installations. The following command line 
parameters and arguments can be used with the Windows Installer executable (msiexec.exe) to 
perform a silent installation of the product: 
To get a list of command line arguments for msiexec.exe, enter in a command window: 
msiexec.exe /? 
Required arguments (for silent install): 
/qn 
/i <path and file name of msi file> 
SERIALNUMBER=<serial number> 
SLAACCEPT=Yes 
If the PIDService feature is added, the following are also required: 
NAMEGENUSERNAME=<mydomain\myuserid> 
NAMEGENPASSWORD=<mypassword> 

 
 /qn means no user interface of any form is displayed. If you do not include /qn on the 

command line, dialog boxes are displayed during the installation process. 
 SLAACCEPT=Yes means that you are accepting the Software License Agreement. 

Optional Arguments Default 

INSTALLDIR=<path to install to> C:\Program Files\SmartPlant\3D 

ADDLOCAL=<comma delimited list of user-selectable 
features to install> 

See the table below for additional 
information. 

REMOVE=<comma delimited list of user-selectable 
features to remove> 

See the table below for additional 
information. 

/L <path, file name of logging file>  

/x <path to msi file> Uninstalls SmartPlant 3D 

 
 ADDLOCAL and REMOVE refer to user-selectable features. There are features that the 

user cannot see that are automatically installed that are not referenced in the list below. 
 For ADDLOCAL and REMOVE, ALL can be used, as in, ADDLOCAL=ALL or 

REMOVE=ALL 

  
 The arguments for the command line are case-sensitive. 
 If you are going to install SmartPlant 3D silently with a script under a Terminal Services 

Server in Application Server mode, we recommend that you update the script to include a 
Change User mode command to set the user mode to Install mode first, and then back to 
Execute mode after the SmartPlant 3D installation command. This ensures that changes 
written to registry key HKEY_CURRENT_USER are properly redirected to their 
corresponding HKEY_LOCAL_MACHINE registry after each user logs in into the 
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system. These steps are also recommended when applying hot fixes and service packs in a 
silent install. 

List of User-Selectable Features 
In the following table, the first column contains the displayed feature name as seen on the 
Select Features dialog box during regular installation. The second column contains the 
command line feature name, which is case sensitive, to use with the ADDLOCAL and REMOVE 
arguments. The third column displays if the feature is displayed by default if ADDLOCAL and 
REMOVE are not set. 
To add or remove user-selectable features, use ADDLOCAL and REMOVE. If neither of these 
arguments is used, the features shown below are not installed. If ADDLOCAL is set to 
ProjectEnvironment and Server (ADDLOCAL=ProjectEnvironment,Server), 
ProjectEnvironment (Project Management) and Server (SmartPlant 3D Server Connectivity) 
are installed. 
 

Displayed Feature Name Command Line Feature Name Installed by Default 

Project Management ProjectEnvironment No 

Piping Specification Remote 
Access Server 

PIDService No 

SmartPlant 3D Server 
Connectivity 

Server No 

Bulkload Reference Data Bulkload No 

Database Interference Detection 
Service 

IFCService No 

Examples of running client silent install from the command line: 
This command line installs the product into the default location, C:\Program 
Files\SmartPlant\3D. No logging file is created unless a problem occurs. If a problem occurs, a 
logging file with a brief description of the problem is created in the Temp folder. 
msiexec.exe /i "<Path>\S3DInstallation.msi" SERIALNUMBER=12345678901234 
SLAACCEPT=Yes /qn 

 
This command line installs the product into the default location, C:\Program 
Files\SmartPlant\3D. It also creates a verbose logging file called loggingfile.log into the path 
provided. 
msiexec.exe /i "<Path>\S3DInstallation.msi" SERIALNUMBER=12345678901234 
SLAACCEPT=Yes /qn /Lvoicewarmup "<path>\loggingfile.log" 

 
This command line installs the product into location, D:\Program Files\SmartPlant\3D. It also 
creates a verbose logging file called loggingfile.log into the path provided. 
msiexec.exe /i "<Path>\S3DInstallation.msi" SERIALNUMBER=12345678901234 
SLAACCEPT=Yes INSTALLDIR="D:\Program Files\SmartPlant\3D" /qn 
/Lvoicewarmup "<Path>\loggingfile.log" 

 
This command line installs all features of SP3D, including PIDService into the location, 
D:\Program Files\SP3D. No logging file is created (unless an error occurs). 
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msiexec.exe /i "<Path>\S3DInstallation.msi" SERIALNUMBER=12345678901234 
SLAACCEPT=Yes INSTALLDIR="D:\Program Files\SmartPlant\3D" ADDLOCAL=ALL 
NAMEGENUSERNAME=<mydomain\myuserid> NAMEGENPASSWORD=<mypassword>/qn 

 
This installs all of the features listed above except PIDService into the location D:\Program 
Files\SmartPlant\3D. No logging file is created (unless an error occurs). 
msiexec.exe /i "<path>\S3DInstallation.msi" SERIALNUMBER=12345678901234 
SLAACCEPT=Yes INSTALLDIR="D:\Program Files\SmartPlant\3D" ADDLOCAL=ALL 
REMOVE=PIDService /qn 

 
This command line uninstalls the software with no user interaction but displays the progress on 
screen. 
msiexec.exe /passive /x "<path>\S3DInstallation.msi" /l+* 
C:\temp\Passive_Removal.log  

 
 You can identify installation errors by searching for the string "return value 3" in the log file. 

If you do not specify a name or location for the log file, it is automatically given a unique name 
beginning with the characters "MSI" and ending with the .LOG file extension. The log file is 
created in the %temp% folder. 

Reference Data Installation Options 
You must specify which version of the reference data product to install, such as SP3D, SM3D, 
or MHE. The argument that controls the version is PRODUCTTOINSTALL. 
Example of running reference data silent install from the command line: 
To install SP3D reference data in default location (C:\Program Files\SmartPlant\3D): 
msiexec /i "<path>\S3DReferenceData.msi" SLAACCEPT=Yes ADDLOCAL=ALL 
PRODUCTTOINSTALL=SP3D /qn 
 

Name Generator Installation Options 
The name generator requires a separate installation procedure after installing the reference 
data. You must include the NAMEGENUSERNAME and NAMEGENPASSWORD arguments 
when installing the name generator. 
Example of running name generator silent install from the command line: 
To install the Name Generator in default location (C:\Program Files\SmartPlant\3D):  
 On the 32-bit computers, you can use the following command-line argument: 

msiexec /i "<path>\S3DNameGenerator.msi" SLAACCEPT=Yes ADDLOCAL=ALL 
NAMEGENUSERNAME=<mydomain\myuserid> NAMEGENPASSWORD=<mypassword> 
/qn 

 You can also use the above command-line argument on the 64-bit computers to install the 
64-bit version of the Name Generator. 

 To install the 32-bit version of the Name Generator on the 64-bit computers, use the 
following  command-line argument:  
Msiexec.exe /i “<path>\S3DNameGenerator.msi” SLAACCEPT=Yes ADDLOCAL=ALL 
X86NAMEGEN=true NAMEGENUSERNAME=<mydomain\myuserid> 
NAMEGENPASSWORD=<mypassword> /qn 
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To install Symbols and Custom Documentation in default location (C:\Program 
Files\SmartPlant\3D): 
msiexec /i "<path>\S3DReferenceData.msi" SLAACCEPT=Yes 
ADDLOCAL=Symbols,CustomDoc /qn 

See Also  
SmartPlant 3D Database Server Recommendations (on page 21) 
Recommendation for Database Monitoring (on page 185) 
Monitoring the Databases (on page 63) 
Assign System Administrator Privileges for SQL Server 2008 (on page 48) 
 

Silent Installation for Service Packs 
You can use the Windows Installer to install the service pack software using a command line 
rather than the normal user interface. One advantage of using a command line to install 
software is that you can perform unattended installations. The Windows Installer and the 
SP3DHotFixInstaller command line options do not run from the UNC path. You need to map to a 
drive letter. If errors occur during installation, they are logged to your temp folder in a file called 
patchinstaller.log. 
The following command line parameters and arguments can be used with the Windows Installer 
executable msiexec.exe) to perform a silent service pack installation of the product: 
To get list of command line arguments for msiexec.exe, enter in a command window: 
msiexec.exe /? 
Syntax 
msiexec.exe /update "<path and file name of msp file>" /qn 
Required arguments (for silent install): 
/qn 
/update <path and file name of msp file> 
Where <command option> is: 
 Installation - This installs the service pack or hot fix. 
 Referencedata - This installs the Reference Data service pack or hot fix. 
 ProgrammingResources - This installs the Programming Resources service pack or hot fix. 
Optional Arguments 
/L Logging file. /L<logging options> "<path>\<Log Filename>.log" 

 The arguments for the command line are case-sensitive. 

See Also 
SmartPlant 3D Database Server Recommendations (on page 21) 
Monitoring the Databases (on page 63) 
Assign System Administrator Privileges for SQL Server 2008 (on page 48) 
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S E C T I O N  6  

SmartPlant 3D currently supports Microsoft SQL Server 2008 SP3 and Oracle 11g R2 (11.2.0.2) 
with Patch 8. 

 When using the software in a Global Workshare Configuration (GWC), you must install 
Oracle Enterprise Edition, which includes a fix for a memory leak in streams. Please consult 
your Oracle support representative for more information. 
Installing any database involves significant decisions regarding the size of the database, the 
maximum number of users, the frequency of automatic backups, and other important issues. 
Therefore, the following sections provide only suggestions for tuning your database 
configuration to work with SmartPlant software. The ultimate database creation and 
configuration depends on the policies and standards at your company. 
 

Instructions for Microsoft Windows Server 2008 
When you install Windows Server 2008 R2, most of the services are disabled by default, 
including MSDTC network access. If you are using COM+/DTC, you are most likely to receive 
errors when you attempt to perform distributed actions, including flowing transactions to another 
computer or talking to a resource manager such as SQL Server on another computer. To enable 
your distributed scenarios, you need to enable MSDTC network transactions. 

See Also 
Enable Network Access in Windows Server 2008 (on page 39) 
Configure Microsoft Distributed Transaction Coordinator (Database Server Only) (on Configure 
the Distributed COM Users Group (on page 42) 
 

Enable Network Access in Windows Server 2008 
The following procedures for enabling network access are required only if you are using 
Windows Server 2008 R2 (64-bit) on the computer. 

Enable COM+ Network Access 
1. Open the Control Panel. 
2. Click Turn Windows features on or off to open the Server Manager. 

3. On the Roles page in Server Manager, click  Add Roles. 
The Add Roles Wizard opens. 

4. Ensure that you have completed the preceding steps listed on the Before You Begin page, 
and click Next. 

5. On the Select Server Roles page, select Application Server and click Next. 
 If the server finds any of the required features for Application Server are missing, a 

prompt is displayed informing you to install those features. Click Add Required Features to 
allow the server to install them automatically. 

6. On the Application Server page, click Next. 
7. On the Select Role Services page, select COM+ Network Access, and click Next. 

Setting Up the Database 
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8. Confirm your installation selections and click Install. 
9. After the installation is complete, click Close to exit the wizard. 

 If Application Server is already enabled on Windows Server 2008, follow these steps 
to enable COM+ Network Access: 

10. Open the Control Panel.  
11. Click Turn Windows features on or off to open the Server Manager. 
12. Click Roles > Application Server. 

13. In the Role Services section, click  Add Role Services. 
14. On the Select Role Services page, select COM+ Network Access, and click Install. 

Enable Network DTC Access 
1. Open Component Services by clicking Start > Administrative Tools > Component 

Services. 
2. In the console tree, expand Component Services > Computers > My Computer > 

Distributed Transaction Coordinator > Local DTC. 
3. Right-click Local DTC, and select Properties. 
4. In the Security tab of the Local DTC Properties dialog box, enable Network DTC Access, 

and click OK. 
An MSDTC Service message box is displayed. 

5. Click Yes to stop and restart the MSDTC service. 
6. Click Yes after the MSDTC service is restarted. 

 If you have additional resource manager services that participate in the distributed 
transactions, you must stop and restart those services as well. 

See Also 
Instructions for Microsoft Windows Server 2008 (on page 39) 
 
 



 Setting Up the Database 
 

 
SmartPlant 3D Installation Guide 41 

 

Configure Microsoft Distributed Transaction Coordinator 
(Database Server Only) 

You must configure the Microsoft Distributed Transaction Coordinator (MSDTC). 
1. Open Component Services by clicking Start > Administrative Tools > Component 

Services. 
2. In the console tree, expand Component Services > Computers > My Computer > 

Distributed Transaction Coordinator > Local DTC. 

 
3. Right-click Local DTC and select Properties from the shortcut menu. 
4. Select the Security tab of the Local DTC Properties dialog box. 
5. In the Security Settings section, enable Network DTC Access. 
6. In the Client and Administration section, enable Allow Remote Clients and Allow 

Remote Administration. 
7. In the Transaction Manager Communication section, enable the Allow Outbound, Allow 

Inbound, and No Authentication Required options. 
8. Verify that Enable XA Transactions is enabled. 
9. In the DTC Logon Account section, verify that NT AUTHORITY/Network Service appears 

in the Account box. 
10. Click OK. 

An MSDTC Service message box is displayed. 
11. Click Yes to stop and restart the MSDTC service. 
12. Click OK after the MSDTC service is restarted. 

See Also 
Instructions for Microsoft Windows Server 2008 (on page 39) 
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Configure the Distributed COM Users Group 
You must add users to the Distributed COM Users group. 
1. Open Computer Management by clicking Start > Administrative Tools > Computer 

Management. 
2. Under Computer Management, expand System Tools > Local Users and Groups. 
3. Under the Local Users and Groups node, click Groups. 

 
4. In the right pane of the Computer Management window, double-click Distributed COM 

Users. 
5. In the Distributed COM Users Properties dialog box, click Add. 
6. In the Select Users, Computers, or Groups dialog box, type the user accounts you want to 

add to the Distributed COM Users Group into the Enter the object names to select box. 
 You can enter multiple accounts by separating each one with a semicolon. For 

example, you can type Domain1\User1;Domain1\User2;Domain1/User3, and so on. 
7. Click OK to close the Select Users, Computers, or Groups dialog box. 
8. Click OK to close the Distributed COM Users Properties dialog box. 

See Also 
Instructions for Microsoft Windows Server 2008 (on page 39) 
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Loading Prerequisite Software on the Database 
Server 

The following prerequisite software is required in order to install and use the software on a 
database server: 
 Microsoft .NET Framework 3.5 Service Pack 1 
 Adobe Acrobat Reader (available from www.adobe.com) 

See Also  
Loading Prerequisite Software on the Client (on page 100) 
 
 

Install Microsoft .NET Framework (Database Server) 
Stop any real-time virus checkers before you proceed because they can interfere with 
installation. 
1. Log on to the computer as an administrator. 
2. Start Server Manager. 
3. Select Features in the console tree. 
4. Select Add Features in the Features Summary area. 

The Add Features Wizard appears. 
5. Select .NET Framework 3.5.1 Features from the list of features that you can install. 
6. Click Install and follow the prompts. 

 The software also supports the latest .NET Framework service packs. Run Windows 
Update to check for the latest .NET service pack and fixes. 

See Also  
Loading Prerequisite Software on the Database Server (on page 43) 
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Installing and Configuring Microsoft SQL Server 2008 
Because system configurations, database software, and individual company standards vary, use 
this section as a checklist instead of step-by-step instructions for SQL Server 2008 SP3 (64-bit) 
running on a Windows Server 2008 R2 operating system. Please contact Intergraph Customer 
Support for specific configuration questions. 
If you are using a Global Workshare Configuration, you need to install the Enterprise Edition of 
Microsoft SQL Server 2008 Service Pack 3 for your Host and Satellite locations. 

 Microsoft SQL Server 2008 SP3 requires XML 6.0 and will automatically install it as part 
of the SQL Server 2008 Prerequisite installation. 

 There are internationalization considerations concerning the SQL Server collation 
settings you specify that relate to reference data, using SmartPlant Enterprise integrated 
systems, Global Workshare Configuration, multiple locales, backup/restore, reports, and 
upgrading to future releases. Please contact Intergraph Customer Support for specific 
configuration questions. 
 
 

Install Microsoft SQL Server 2008 
1. Insert your SQL Server DVD and start the setup program.  

 
2. From the Planning page, select System Configuration Checker to check for pre-requisite 

applications as well as identify potential installation problems. 
 You may be asked to restart your computer if any pre-requisite applications were 

installed. 
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3. Click Installation and select the New SQL Server stand-alone installation or add 
features to an existing installation option. 

 
4. As you go through the installation process, make sure you install the Setup Support Files 

and review any Setup Support Rules that identify potential problems. 
5. When you get to Feature Selection, select the features below. 

 Database Engine Services 
 SQL Server Replication (required if the SQL server instance is set up for the 

Global Workshare configuration) 
 Client Tools Connectivity 
 Management Tools - Basic 
 Management Tools - Complete 

 
6. On the Server Configuration page, specify a domain account name with administrative 

privileges on the system to be used. Also, set Automatic as the Startup Type and 
continue. 

 
 If you are not sure, you can use NT AUTHORITY\NETWORK SERVICE or NT 

AUTHORITY\SYSTEM and change the login later on the service. 
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 A domain user account offers more flexibility and is typically used because many 
server-to-server activities can be performed only with a domain user account, including 
remote procedure calls, replication, and backing up network drives. 

7. Click the Collation tab. Use locale-specific collation. These collation settings include the 
character set, sort order, and other locale-specific settings. 

 
8. On the Database Engine Configuration page, identify at least one SQL Server 

Administrator. Select Windows authentication mode. 

 
9. Complete the installation as prompted. 
10. If any errors occur during installation, refer to the Summary Log for more information and 

contact Intergraph Support for further assistance. 
11. Install any required service packs or upgrades for SQL Server 2008. See Install any 

Required SQL Server 2008 Upgrades (on page 47). Currently Microsoft SQL Server 2008 
Service Pack 2. 
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Install any Required SQL Server 2008 Upgrades 
Your version of SmartPlant 3D may require an upgrade or service pack of Microsoft SQL Server 
2008. See SmartPlant 3D Database Server Recommendations (on page 21) for version 
information. If you do need to upgrade, go to the Microsoft website and follow instructions 
provided in the Microsoft Download Center. 
 

Verify Automatic Startup of Microsoft SQL Server 2008 
Services 

1. Open Control Panel > System and Security > Administrative Tools, and then 
double-click Services. 

2. Verify that the Status field is set to Started and the Startup Type field is set to Automatic, 
for each of the following services:  
 Distributed Transaction Coordinator 
 SQL Server (MSSQLSERVER) 

 The MSSQL service is appended with the named instance you specified when you 
installed Microsoft SQL Server 2008 SP3. For example, if you installed SQL Server 2008 as 
an instance named Instance1, the service displays as MSSQL$Instance1. 

3. To change the Status or Startup Type fields, right-click the service name, and select 
Properties from the shortcut menu. 
a. On the General tab, select Automatic from the Startup type list. 
b. In the Service status section, click Start. 
c. Click OK. 

 

Configure SQL Server 2008 Account for Name Generator 
Service 

If the SQL Server 2008 is not registered in the SQL Server Management Studio on the server 
computer, you must register it before using the SQL Server 2008 software. Perform the following 
procedure on the server computer to register the SQL Server in the SQL Server Management 
Studio console. 
1. Open SQL Server Management Studio and select View > Registered Servers. 
2. Right-click Central Management Servers and select Register Central Management 

Services.  
The system displays the New Server Registration dialog box. 

3. On the General tab, enter the name of the server you want to register or select a server 
from the Server name drop-down list. 

4. Click Save. 
 Before exiting SQL Server Management Studio, perform the steps in Assign System 

Administrator Privileges for SQL Server 2008 (on page 48). 
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Assign System Administrator Privileges for SQL Server 2008 
Perform the following steps on the SmartPlant 3D server computer. 
1. Open Microsoft SQL Server Management Studio and expand the listing for your database 

server in the left tree view. 
2. In the tree view, expand the listing under Security and right-click Logins. 
3. Select New Login from the shortcut menu. 
4. On the Login - New dialog box, enter the user account you want to be assigned 

administrative privileges in the Login name text box. For example, type AdminUser1. 

 
5. Select Server Roles under the Select a page heading to display the Server Roles list. 
6. In the Server Roles list, select the sysadmin check box. 

 
 Standard users need db_owner and public database role membership mapping to 

each one of the SmartPlant 3D databases. Administrators need only the sysadmin role. 
7. Click OK. 
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Create a SQL Server 2008 Database Alert 
When the SmartPlant 3D database server is running low on disk space, the software begins to 
display error messages since data can no longer be persisted or logged. Microsoft SQL Server 
2008 SP3, however, does not issue any particular alerts for the workstation computers when the 
disk is full or becoming limited. 
Using the Performance Monitor, the SmartPlant 3D administrator can create a Data Collector 
Set that contains an alert to be issued when a threshold value for a System Monitor has been 
reached. In response to the alert, System Monitor can launch an application to handle the alert 
condition. 
You must perform the following procedure on the SmartPlant 3D server computer. 
1. Open Control Panel > System and Security > Administrative Tools > Performance 

Monitor. 
2. Expand Monitoring Tools in the Performance tree view and start the Performance 

Monitor. 
3. Expand Data Collector Sets in the tree view and right-click on User Defined. 

 
4. Select New > Data Collector Set from the shortcut menu. 

Enter the name you want to use for the data collector set, click Create manually 
(Advanced), and then click Next. 

 
5. Click Check Performance Counter and click Next. 
6. Click Add to open the Add Counter dialog box. 
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7. Set the database server name in the Select counters from computer field. Select the 
Microsoft SQL Server 2008 object in the Available counters section. 

 
8. In the Select counters from list drop-down list, select a counter and click Add. The new 

counter displays in the Added counters list. 
 Use CTRL+ or SHIFT+ to select multiple objects. 

9. After all counters have been added, click OK to close the Add Counters dialog box. 
 To add local counters from a remote computer, you need to have either of the 

following permissions on it: 
 Local administrator privilege  
 Be a member of the Performance Monitor Users local group. 
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10. Under the Performance counters list, select either Above or Below for the Alert when 
value. 

 
11. In the Limit box, enter a threshold value. Depending on the object you selected, the alert 

will be generated when the value for the counter is more than or less than the threshold 
value. Click Next to continue. 

12. Click Finish. Your new data collector set displays in the User Defined page. 
13. To configure the alerts, double-click on your data collector set name and then right-click on 

the data collector. Select Properties from the shortcut menu. 
14. On the Alerts tab, you can set additional alerts and define the unit of time for the duration of 

the sample interval. 

 
15. Set options in the Alert Action and Alert Task tabs to specify the actions to occur each 

time the alert is triggered. 
16. Click OK to close the Properties dialog box and activate the alert settings. 

 For more information about using System Monitor and setting up SQL Server 2008 
alerts, see the documentation delivered with Microsoft SQL Server 2008 SP3 and Windows 
Server 2008 R2. 

 

SQL Server Port Assignments 
The SQL Server database uses the following port assignments. 

 This assignment may not be required if SQL Server is not used as a database within your 
SmartPlant Enterprise implementation. 

Port Number TCP/UDP Communication Comments 

1433 TCP From workstation to 
server; from server to 
workstation 

For SQL Server 
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SQL Server 2008 Collation Utility 
The SQL Server 2008 Collation Utility provides a way for you to specify the default collation that 
should be used by the Database Wizard, Project Management, and the Bulkload utility for 
creating databases. This utility creates a copy of the delivered schema templates 
(AppRepos.dat and CatalogDB.dat) with the desired SQL Server collation. Any site, catalog, 
model, and reports databases and schemas created from these templates will use the specified 
SQL Server collation. 
Only homogeneous configurations are supported at this time, not heterogeneous. For more 
information see Internationalization (on page 17). 

See Also 
Change Database Collation (on page 53) 
SQL Server 2008 Collation Utility Dialog Box (on page 52) 
 

SQL Server 2008 Collation Utility Dialog Box 
The SQL Server Collation Utility provides a way for you to specify the default collation that 
should be used by the Database Wizard, Project Management, and the Bulkload utility for 
creating databases. 

Options: 
Collation - Specifies the collation to be used for the database template. See the Microsoft 
documentation for more information on collation. 
SmartPlant 3D does not support case-sensitive collation. 
Existing AppRepos template - Specifies the path and file name of the existing AppRepos.dat 
template to be copied and converted to the new collation. 
New AppRepos template - Specifies the path and file name of the new AppRepos.dat template 
to be created. This name updates automatically to a new default whenever you change the 
value in the Collation field. 
Existing CatalogDB template - Specifies the path and file name of the existing CatalogDB.dat 
template to be copied and converted to the new collation. 
New AppRepos template - Specifies the path and file name of the new CatalogDB.dat template 
to be created. This name updates automatically to a new default whenever you change the 
value in the Collation field. 
OK - Creates the new templates with the selected collation. 
Cancel - Closes the SQL Server Collation Utility without creating any new templates. 
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Change Database Collation 
1. Install SQL Server with locale-specific collation. These collation settings include the 

character set, sort order, and other locale-specific settings. 
2. Install SmartPlant 3D client and server. 
3. Click Start > All Programs > Intergraph SmartPlant 3D > Database Tools > SQL Server 

Collation Utility. 
The SQL Server Collation Utility displays. See SQL Server 2008 Collation Utility Dialog Box 
(on page 52). 

4. Specify the collation that you need. 
The file names for the “new” templates update to reflect the selected collation automatically. 

5. You can modify the default file names and paths. 
6. Click OK to update the collation in the templates. These templates can now be used to 

create every SmartPlant 3D database in the correct collation for the project. 
7. Click Start > All Programs > Intergraph SmartPlant 3D > Database Tools > Database 

Wizard. 
8. Follow the steps to create a new site. 
9. In the Template file to be used to create site schema field, select the new template with 

the desired SQL Server collation that you created with the SQL Server Collation Utility. 

 
10. When creating or restoring the catalog database for the new site, be sure to select the 

template with the correct collation. If the collation for the selected catalog does not match 
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the collation for the site, the following message appears: "The collation for the selected 
template, CatalogDB.dat, does not match the collation for the site. Please select another 
template." 

 This message also appears in the Bulkload Utility and in the New Catalog 
command in Project Management if the collation does not match the site. 

11. When you create the plant, reports, and reports schemas in Project Management, 
SmartPlant 3D automatically uses the collation of the site database. 

12. In the future, when you create additional sites or catalogs, remember to select the correct 
template with the desired collation. 

See Also 
Install Microsoft SQL Server 2008 (on page 44) 
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Installing and Configuring Oracle Server Software 
Because system configurations and individual company standards vary, use this section as a 
checklist instead of step-by-step instructions. Please contact Intergraph Customer Support for 
specific configuration questions. 

 Intergraph recommends that you set up the Windows server network before installing 
Oracle. Also, Oracle recommends a static IP address. You should install the Oracle server 
software as the local administrator, not as a domain user in the local Administrator Windows 
group. For more information, refer to your Oracle installation documentation. 

 All domain verified user names and passwords must use ASCII7/English 
characters. Oracle does not support non-ASCII / English characters in domain user names or 
passwords and will not work. This limitation applies only to Oracle, not Intergraph. 

Oracle Instances 
If one server hosts the databases of several products, Intergraph recommends that each 
product database be a separate instance, each of which can host multiple plants. 
The advantage of placing each product database in its own instance is that only the affected 
application will be off-line during backup, performance tuning, and other database maintenance 
activities. Additionally, global tuning parameters that apply to one instance can be tailored to the 
specific product requirements. 
According to Oracle documentation, the only limit to the number of instances you can have on 
any machine is the availability of resources. However, the number of instances on one database 
server should be minimized because each additional instance puts additional load on the server. 
Each instance adds redundant tablespaces, rollback segments, background processes, and 
memory requirements for each SGA (System Global Area). For this reason, you should start by 
putting the database of one product for several plants into a single instance. Then, when the 
number of plants increases, or a plant becomes very large, consider separating the database 
into new instances, adding server memory, or even adding database servers. 

 
 Oracle recommends that database activity on the database server consume no more than 

50 percent of the available memory. Refer to your Oracle documentation for specific 
requirements. 

 There are Oracle restrictions for the database global name and corresponding database link 
name (they are required to match). There are three known restrictions on global database 
names: 

1. No hyphens are allowed. 
2. The computer name cannot start with a number. 
3. There is a maximum of 30 characters for the name. 

See Also  
Configure Oracle Networking Components (on page 60) 
Verify Automatic Startup of Oracle Database Services (on page 61) 
Initialize the Oracle Database (on page 57) 
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Install Oracle Database Server Software 11g Release 2 
During installation of the database components, setup displays various dialog boxes that prompt 
you for information. We recommend that you refer to your Oracle documentation for specific 
instructions concerning the dialog boxes and wizard pages. The steps below show an example 
installation using Oracle 11g R2 (11.2.0.2) server software with Patch 8. 

Install Oracle Database Server Software 11g Release 2  
1. Open the hosts file and enter the IP address and server host name. The hosts file is located 

in C:\windows\system32\drivers\etc\hosts. 
2. Add the environment variable ORACLE_HOSTNAME=<server name> in the System 

Environment Variables. 
3. Enter your security update information in the Configure Security Updates screen, and click 

Next. 
4. Select Create and configure a database in the Select Installation Option screen, and 

click Next. 
5. Select Server Class in the System Class screen, and click Next. 
6. Select Single instance database installation in the Grid Installation Options screen, and 

click Next. 
7. Select Advanced install in the Select Install Type screen, and click Next. 
8. Select the installation language in the Select Product Languages screen, and click Next. 
9. Select Enterprise Edition (3.34GB) in the Select Database Edition screen, and click Next. 
10. Specify the Oracle Base location for the base folder and the Software Location for the 

home folder by browsing to the location.  
11. Select General Purpose / Transaction Processing in the Select Configuration Type 

screen, and click Next. 
12. Specify the Global database name and Oracle Service Identifier (SID) values in the 

Specify Database Identifiers screen. 
13. Select the Memory tab on the Specify Configuration Options screen, and select the 

Enable Automatic Memory Management option. The percentage of memory allowed for 
an instance of Oracle should not exceed 40%. If you have more than one Oracle instance 
on this server, the allocated memory should not exceed 40% of the system memory. 

14. Select the Character sets tab on the Specify Configuration Options screen, and select 
the Use Unicode (AL32UTF8) option.  

 
 All products in SmartPlant Enterprise that participate in integration should set their 

encodings to Use Unicode (AL32UTF8) for the Database Character Set option and to 
AL16UTF16 - Unicode UTF-16 Universal character set for the National Character 
Set option.  

 For more information about the Character Set options, see your Oracle installation 
documentation. 

15. Select the Security tab on the Specify Configuration Options screen, and choose your 
security settings option. 

16. Select the Sample Schemas tab on the Specify Configuration Options screen, and select 
the Create database with sample schemas option, and click Next. 
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17. Select the Use Database Control for database management option on the Specify 
Management Options screen. You can also enable notifications through email with this 
option. 

18. Select File System in the Specify Database Storage Options screen, and specify a 
database file location. Click Next. 

19. Specify your recovery options in the Specify Recovery Options screen, and click Next. 
20. Specify your schema passwords in the Specify Schema Passwords screen, and click 

Next. You must choose either the Use different passwords for these accounts or Use 
the same password for all accounts option. 
The software checks that all prerequisite software is installed on the computer. 

21. Click Finish in the Summary screen. 
22. Click Close after the installation process is finished. 
For more information on creating an Oracle database for use with Intergraph software, see 
Global Workshare User's Guide (Oracle). 

See Also 
Installing and Configuring Oracle Server Software (on page 55) 
 

Initialize the Oracle Database 
After the Oracle server software is installed and configured (that is, you can connect from a 
client to the Oracle database), you must configure the database to run with SmartPlant 3D 
software. 
The SmartPlant 3D Reference Data Installation delivers the following sample script files to the 
<Product Folder>\Tools\OracleScriptsToInitDB\Roles folder. These files must be run in the 
following order: 
1. SP3DUser_ROLES.sql 
2. SP3DProjectAdminstrator_ROLES.sql 
3. SP3DUser.sql 
4. SP3DProjectAdministrator.sql 
Use these script files to create the necessary schemas, users, and roles that are used to run the 
software on Oracle. The delivered script files, however, are only samples and must be edited to 
fit your server configurations. 

 
 An administrative user must run the scripts on the server. Before proceeding, place a copy 

of each of the sample script files on the server computer. 
 The scripts must be run in the order listed because previous scripts create items that are 

used in subsequent scripts. Do not deviate from the following sequence of steps. 

Create the Roles Needed for SmartPlant 3D Users 
1. Log on to the Oracle database server computer using the local administrative account. 
2. Open SQL Plus. The SQL Plus dialog box displays. 
3. In the User Name field, type SYS as SYSDBA or SYSOPER. 
4. In the Password field, type the password for the SYS account. 
5. At the SQL prompt, type @<File Location>:\SP3DUser_ROLES.sql, and press Enter.  

 For example, if you placed a copy of the script file in the root folder on the C drive, type 
@C:\SP3DUSER_ROLES.sql. 
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6. After the script finishes, type @<File Location>:\SP3DProjectAdministrator_ROLES.sql, 
and press Enter. 

7. After the second script finishes, click File > Exit. 
 

 If SP3D roles already exist on the Oracle service, you should adjust the roles using the 
Adjust_SP3DRoles.sql file. For more information, see Adjust Roles and Users (on page 59). 

 Users with existing Oracle databases must grant EXECUTE ANY TYPE privilege to the 
SP3DUSER role when upgrading to SmartPlant 3D version 2007 (7.0) or higher by 
executing the following statement in SQLPLUS: 

GRANT EXECUTE ANY TYPE TO SP3DUSER; 

Create the Users Needed for SmartPlant 3D 
1. Log on to the Oracle database server computer using the local administrative account. 
2. Navigate to the SP3DUser.sql script file, and open it in Notepad. 
3. Edit the external user identified in the file as needed. Use the following syntax: DOMAIN 

NAME\USERNAME, and then click File > Save. 
 Any typed alpha character must be capitalized. 

4. Open SQL Plus. The Log On dialog box appears. 
5. In the User Name field, type SYS AS SYSDBA. 
6. In the Password field, type the password for the SYS account. 
7. At the SQL prompt, type @<File Location>:\SP3DUser.sql, and press Enter. 

For example, if you placed a copy of the script file in the root folder on the C drive, type 
@C:\SP3DUser.sql. 

8. After the script finishes, click File > Exit. 

Create the Administrative User 
1. Log on to the Oracle database server computer using the local administrative account. 
2. Navigate to the SP3DProjectAdministrator.sql script file, and open it in Notepad. 
3. Edit the external user identified in the file as needed. Use the following syntax: DOMAIN 

NAME\USERNAME, and then click File > Save. 
 Any typed alpha character must be capitalized. 

4. Open SQL Plus. The Log On dialog box appears. 
5. In the User Name field, type SYS AS SYSDBA. 
6. In the Password field, type the password for the SYS account. 
7. At the SQL prompt, type @<File Location>:\SP3DProjectAdministrator.sql and press 

Enter. 
For example, if you placed a copy of the script file in the root folder on the C drive, you type 
@C:\SP3DProjectAdministrator.sql. 

8. After the script finishes, click File > Exit. 
 If the Project Administrator user is already created on the Oracle service, you should use 

the Adjust_SP3DProjectAdministrator.sql file to adjust the login. For more information, see 
Adjust Roles and Users (on page 59). 

See Also  
Installing and Configuring Oracle Client Software (on page 106) 
Installing and Configuring Oracle Server Software (on page 55) 
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Adjust Roles and Users 
If the SmartPlant 3D roles and project administrator logins are already created on the Oracle 
service, use the following procedures to adjust them. 

Adjust SP3D Roles 
 During setup, SmartPlant 3D delivers the Adjust_SP3DRoles.SQL script files in the folder 

<Product Folder>\ProjectMgmt\Tools\ScriptsToInitOracleDB\ AdjustSP3DRoles. 
1. Log on to the Oracle database server computer using the local administrative account. 
2. Open SQL Plus. The Log On dialog box appears. 
3. In the User Name field, type SYS as SYSDBA. 
4. In the Password field, type the password for the SYS account. 
5. At the SQL prompt, type @<File Location>:\Adjust_SP3DRoles.sql and press Enter.  

 For example, if you placed a copy of the script file in the root folder on the C drive, you 
type @C:\Adjust_SP3DRoles.sql. 

6. After the script finishes, click File > Exit. 

Adjust Project Administrator Users 
 During setup, SmartPlant 3D delivers the Adjust_SP3DProjectAdministrator.SQL script 

files in the folder <Product Folder>\ProjectMgmt\Tools\ScriptsToInitOracleDB\ 
AdjustSP3DProjectAdministrator. 
1. Log on to the Oracle database server computer using the local administrative account. 
2. Navigate to the SP3DProjectAdministrator.sql script file, and open it in Notepad. 
3. Edit the external user identified in the file as needed. Use the following syntax: DOMAIN 

NAME\USERNAME, and then click File > Save. 
 Any typed alpha character must be capitalized. 

4. Open SQL Plus. The Log On dialog box appears. 
5. In the User Name field, type SYS as SYSDBA. 
6. In the Password field, type the password for the SYS account. 
7. At the SQL prompt, type @<File Location>:\Adjust_SP3DProjectAdministrator.sql, and 

press Enter. 
F or example, if you placed a copy of the script file in the root folder on the C drive, type 

@C:\Adjust_SP3DProjectAdministrator.sql. 
8. After the script finishes, click File > Exit. 
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Configure Oracle Networking Components 
Oracle Net combines configuration abilities with component control to provide an integrated 
environment for configuring and managing client connections to services via a net service name. 
The SmartPlant 3D software uses the Oracle net service to establish and maintain network 
sessions from client applications to the Oracle database server. After a network connection is 
established, this utility acts as a data courier for the client application and the database server. 
If you follow the procedures provided to Install Oracle Database Server Software 11g Release 2 
(on page 56) and Install Oracle Client Software 11g Release 2 (on page 106), the Oracle 
Networking Components should be configured correctly. 

Oracle Net Configuration Assistant 
The Oracle Net Configuration Assistant allows you to configure the listening protocol address 
and service information for an Oracle database. See the Oracle Net Services Administrator's 
Guide in your Oracle documentation for more information about using this utility and creating net 
service name connections. 

 If you are using Global Workshare, you should configure a net service for each 
server involved in the workshare environment. 

See Also  
Installing and Configuring Oracle Server Software (on page 55) 
Configure the Oracle Client (on page 107) 
Install Oracle Client Software 11g Release 2 (on page 106) 
 

Oracle Database Port Assignments 
The Oracle database uses the following port assignments. 

 These assignments may not be required if Oracle is not used as a database within your 
SmartPlant Enterprise implementation. 

 For the Oracle components listed below, port assignments can be 
custom-configured as indicated. For each component, additional information can be found in the 
cited Oracle documentation. These Oracle references contain links to additional Oracle content, 
providing important considerations, including discussions about other affected components that 
may require matching port changes to be made, as well as the instructions for changing the 
assigned ports. 

Port Number TCP/UDP Communication Comments 

80 TCP From workstation to 
server 

For Oracle HTTP. Can be reassigned. 
Configurable port range is 80, 
7777-7877, 8888. For information, see  
http://download.oracle.com/docs/cd/E1
2524_01/core.1013/e10403/portnums.
htm#i653967. 
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1521, 1526 TCP From workstation to 
server; from server to 
workstation 

For Oracle Client SQL Net Connection 
(1521 is default). Can be changed 
using Oracle Net Configuration Utility 
to port within range 1024-65535. For 
information, see 
http://download.oracle.com/docs/cd/E1
1882_01/install.112/e16773/ports.htm#
CIHCCJCF. 

1158 TCP From workstation to 
server 

For Oracle Enterprise Console (1158 
is default). Configured during database 
installation. Can be changed within 
range 5500-5519. For information, see 
http://download.oracle.com/docs/cd/E1
1882_01/install.112/e16773/ports.htm#
CIHCCJCF. 

5560, 5580 TCP From workstation to 
server 

For Oracle SQL Plus (5560 is default). 
Can be changed within range 
5560-5579. 
For information , see 
http://download.oracle.com/docs/html/
B13805_02/ports.htm#BEHFDBEE – 
section D.5. 

443 TCP From workstation to 
server 

For Oracle HTTP Server SSL Port 
(443 is default). Can be set to either 
443 or 4443. For information, see 
http://download.oracle.com/docs/cd/E1
2524_01/core.1013/e10403/portnums.
htm#i653967. 

 
 

Verify Automatic Startup of Oracle Database Services 
1. Open the Control Panel and double-click Administrative Tools. 
2. Double-click Services. 
3. Verify that the Status field is set to Started, and the Startup Type field is set to Automatic, 

for each of the following services: 
Distributed Transaction Coordinator 
OracleMTSRecoveryService 
OracleService<SID> 
OracleDBConsole<SID> 
Oracle<oracle_home>TNSListener 

 
 The OracleService is your Oracle database instance. It is appended with the named 

Oracle System identifier (SID) you specified when you created the Oracle database. For 
example, if your SID is Plant1, the service appears as OracleServicePlant1. 

 The TNSListener service is required to allow clients to connect to the Oracle database. 
4. To change the Status or Startup Type fields, right-click the service name, and select 

Properties from the shortcut menu. 
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5. On the General tab, select Automatic from the Startup type list. 
6. In the Service status section, click Start. 
7. Click OK. 

See Also  
Installing and Configuring Oracle Server Software (on page 55) 
 

Create the Oracle Streams Tablespace 
Each replicated Plant configuration can use its own Oracle user for the Oracle tablespace and 
the stream administrator. We highly recommend that you separate them this way. You must 
perform the following procedure at the Host and all the Satellite locations that will participate in 
Global Workshare. 
1. Open SQL *Plus and connect as an administrative user who can create users, grant 

privileges, create tablespaces, and alter users. 
2. At the SQL prompt, type a statement similar to the following to create a Streams tablespace: 

CREATE TABLESPACE STRADMABC_TBS 
LOGGING 
DATAFILE 'c:\oracledatafiles\STRADMABC_TBS.ora' SIZE 300M 
REUSE 
AUTOEXTEND ON EXTENT MANAGEMENT LOCAL; 

3. Repeat the procedure at each database that will participate in the Workshare environment. 
 Specify an individual tablespace name for each Plant configuration to match the Streams 

administrator name for each respective Plant configuration. For example, with the Streams 
administrator STRADMABC, you need to create the Streams tablespace named 
STRADMABC_TBS. 
 
 

Create the Oracle Streams Administrator 
You must perform the following procedure at the Host and all the Satellite locations. 
1. Open SQL *Plus and connect as an administrative user who can create users, grant 

privileges, create tablespaces, and alter users. 
2. Create the Streams administrator. At the SQL prompt, type the following statement, and 

press Enter: 
CREATE USER STRADMABC 
IDENTIFIED BY password 
DEFAULT TABLESPACE STRADMABC_TBS 
QUOTA UNLIMITED ON STRADMABC_TBS; 

3. Grant the CONNECT, RESOURCE, and DBA roles to the Streams administrator. At the 
SQL prompt, type the following statement, and press Enter: 
GRANT CONNECT, RESOURCE, DBA TO STRADMABC; 

4. Use the GRANT_ADMIN_PRIVILEGE procedure in the DBMS_STREAMS_AUTH package 
to grant the required privileges to the Streams administrator. At the SQL prompt, type the 
following statement, and press Enter: 
BEGIN 
DBMS_STREAMS_AUTH.GRANT_ADMIN_PRIVILEGE ( 
grantee => ' STRADMABC', 
grant_privileges => true); 
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END; 
/ 

5. To assist with administration, grant the following roles to the Streams administrator. At the 
SQL prompt, type the following statements, and press Enter: 
GRANT SELECT_CATALOG_ROLE 
to STRADMABC; 
GRANT SELECT ANY DICTIONARY 
to STRADMABC; 

6. Repeat steps 1 through 5 to set up a Streams administrator on each of the databases that 
will participate in the Workshare. 

 Specify any Streams administrator user name for each replicated Plant configuration 
like STRADMABC when you create the Streams administrator. STRADMABC is the user 
name used in Project Management when the Plant is duplicated and this user name will be 
used when it generates the replication scripts. You can define your own password (in Step 2 
- IDENTIFIED BY) for the STRADMABC user, but the password has to be the same at all 
locations. 

 

Monitoring the Databases 
You can use the following guidelines for setting up and monitoring your databases. Because 
there are many viable hardware and software configurations that you can use to set up the 
databases, refer to the documentation for your components for more information on 
performance and scalability issues. 

 Database administrators should continuously monitor the status of SmartPlant 3D 
databases, especially as the project grows. If you are using a Global Workshare environment, 
database administrators must ensure that the replication process is functioning. 
To achieve adequate performance and measurements while monitoring the system, use the 
settings outlined in Set Up the Database Server. 

See Also 
Recommendation for Database Monitoring (on page 185) 
Disk Usage (on page 64) 
Disk I/O (on page 63) 
 

Disk I/O 
Data file and log file location and sizing are critical to obtaining optimal performance. I/O is one 
of the most common bottlenecks in database servers. Consequently, sizing I/O is critical to 
performance. 

 Disk drives should not be run at more than 75% of the maximum I/O capacity. 
The two types of I/O are Random I/Os and Sequential I/Os. The type of I/O determines the 
number of I/Os per second that a disk drive can handle. Random I/Os require a longer time to 
complete than sequential I/Os. 

Random I/Os 
The amount of time spent performing random I/Os is governed by the time it takes to perform 
the seek operations. Since the random I/O involves requests for data on different parts of the 
disk, most of the time spent in the I/O will be the seek time. If a disk drive takes 10 milliseconds 
(averaging read and write), it is theoretically possible to perform 100 random seeks per second 
(1/.001 sec), excluding such things as overhead associated with the I/O bus or latencies 
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associated with processing the I/O. Queuing begins as you get closer to the theoretical limit of 
the disk drive. As queuing occurs, the I/O latency increases and database performance begins 
to suffer. 

 You can increase the system's random I/O capacity by spreading the data across multiple 
files or install the data files on a RAID array. 
Data files are mostly accessed by random I/Os. 

Sequential I/Os 
Because there is no seek operation involved in sequential I/O, a disk drive can handle several 
hundred sequential I/Os per second without seeing increasing latencies. Therefore, using 
sequential I/O whenever possible can greatly improve the performance of the disk drives. 
Microsoft SQL Server and Oracle keep a log of the transactions; this log is primarily sequential 
to take advantage of sequential I/Os. 

 In order to achieve maximum performance, the data file and log file must not be on 
the same physical drive. 

See Also  
Recommendation for Database Monitoring (on page 185) 
Monitoring the Databases (on page 63) 
Disk Usage (on page 64) 
 

Disk Usage 
Disk usage should remain under 85% of the maximum disk capacity, and the partition should not 
be compressed. 

Sizing the Files 
With Microsoft SQL Server 2008 SP3, a database is created by default with a data file of 1MB 
and a log file of 1MB. 

 A database can be associated to more than one data file and more than one log file. 
Both files are set to grow by 10% increments until space is no longer available on the drive. 
These defaults, however, are not adequate for monitoring or for a production system. When the 
data or log files are growing, the process may consume a very large amount of server resources 
and slow down the interactive users or perturb the monitoring performed on the system. As a 
result, we recommend that you set the size of the files to avoid automatic growth. 

 Set the size to the maximum anticipated size of the file. Set the growth increment to size 
of the available space or 85% of the capacity of the drive. 
If automatic file growth occurs, re-evaluate the situation and try to set more accurate sizes or 
plan to add more capacity for your database. 

Determining RAID Configuration 
Use the following database activity considerations to determine the appropriate RAID 
configuration for optimum performance: 
 Model Database - High level of reads and writes (select, insert, update, and delete 

activities). 
 Catalog Database - Medium to Low level of reads and writes (select, insert, update, and 

delete activities). Activities such as bulkload and copy to catalog are write activities. Both 
can write a significant amount of data. 
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 Catalog Schema - Low level of reads and very Low level of writes. Activities such as 
bulkload are used to write occasionally, but the amount of data is relatively small. 

 Site - Very Low level of reads and writes. While the Site is not read-only, the write activity is 
limited to a maximum of several rows per week. 

 Site Schema - Very Low level of reads with no writes. 
 Report Database and Report Schema - Read only. They contain views that are composed 

of queries mainly from the Site, Catalog, and Model Databases. 
 SQL Server tempdb has a high level of read and write. 

The following table is based on a SQL Server setup and shows some reasonable orders of 
magnitude for small pilots based on testing conducted by Intergraph Process, Power & Marine. 
The most critical files for performances and monitoring are isolated on their own physical drives 
(the G, H, I, and J drives) while the less critical files share two drives (the E and F drives). The 
operating system, SQL server and paging files are installed on their own drives. 

File Initial Size Growth Increment Drive 

Model data 10 GB 1 GB G 

Model log 1 GB 500 MB H 

Catalog data 1 GB 500 MB I 

Catalog log 500 MB 100 MB J 

Catalog schema data Default Default E 

Catalog schema log Default Default F 

Site data 50 MB 10 MB E 

Site log 50 MB 10 MB F 

Site schema Default Default E 

Site schema log Default Default F 

Report data Default Default E 

Report log N/A N/A F 

Temp DB data 50 MB 50 MB E 

Temp DB log 50 MB 50 MB F 

 
 The size of your Model database log file depends on your backup strategy. For more 

information about backing up your SmartPlant 3D data, see the Project Management User's 
Guide, available from Help > Printable Guides. 

 Tempdb size is reset to the default every time the server is re-started. 

See Also  
SmartPlant 3D Database Server Recommendations (on page 21) 
Recommendation for Database Monitoring (on page 185) 
Monitoring the Databases (on page 63) 
Assign System Administrator Privileges for SQL Server 2008 (on page 48) 
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Install Smart 3D Reference Data 
If you are installing the Smart 3D Reference Data software on a computer running Windows 
Server 2008, you must first enable COM+ Network and DTC access, then manually configure 
the Microsoft Distributed Transaction Coordinator (MSDTC) service, and add the necessary 
users to the Distributed COM Users group. For more information, see Instructions for Microsoft 
Windows Server 2008 (on page 39). 
Prior to installing Smart 3D Reference Data on the database server, verify that the server 
computer meets the required hardware and software requirements and that all prerequisite 
software has been installed. For more information about hardware and software requirements, 
see SmartPlant 3D Database Server Recommendations (on page 21). For more information 
about the prerequisite software, see Loading Prerequisite Software on the Database Server (on 
page 43). 
If you have an older version of SmartPlant 3D software installed on your computer, uninstall it 
before loading the new software. Refer to the section entitled Remove Smart 3D Software (on 
page 182). 
Approximately 1.15 GB of hard disk space is required to load the Smart 3D Reference Data 
software. Prior to installing Smart 3D Reference Data, select and size the hard disk partitions 
accordingly. For additional information, see Disk Partitioning Guidelines (on page 27). 
1. Insert the Intergraph Smart 3D Product DVD. If the installation does not start 

automatically, double-click Setup.exe in the root folder of the DVD. 
2. Select Reference Data Installation. 
3. Click Next on the Welcome to the Smart 3D Reference Data Installation Wizard page. 
4. On the User Information page, enter text in the Full Name and Organization fields, and 

then click Next. 
5. On the Software License Agreement page, select your country from the list and click 

Display to view the license agreement. 

 
 The license agreement is delivered as a PDF file; consequently, you must have 

Acrobat Reader installed on the server computer in order to view the license agreement. 
You can install Adobe Reader from the Adobe web site, www.adobe.com. 
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6. Carefully read the license agreement. Close the PDF document, and click Yes on the 
License Agreement page to accept the terms. 

7. Select if you want to install SmartPlant Reference Data or SmartMarine Reference Data. 
 If you are installing SmartMarine, you only need to select the SmartMarine Reference 

Data option. This option includes those parts of the SmartPlant Reference Data that are 
required to run SmartMarine. 

8. Click Browse and select a folder location for the software, and click Next. 
The Ready to Install the Application page appears. 

9. Review the installation settings, and if they are what you want, click Next. 
The selected reference data is installed to the destination folder. 

10. When the installation is complete, click Finish to exit the Smart 3D Reference Data 
installation sequence. 

 You must share the SharedContent folder after installation is complete. For 
more information, see Configure Network Shares (on page 67). 

11. Restart the computer to complete the installation. 
 

Configure Network Shares 
Before using SmartPlant 3D, you must configure the following network shares. The paths to 
these shares are needed while working in the software. 

Database Templates Share 
 Creating a share for the database templates that are delivered during the Smart 3D 

Reference Data setup is necessary only if you are planning to use Oracle databases. 
Create a share on a computer to hold the database templates that you create for use with the 
software. By default, the database templates are delivered as part of the Smart 3D Reference 
Data setup. 
The user login used to create the SmartPlant 3D databases and the account on which the 
Oracle service (OracleService<SID>) is running require Write permissions to this share. 

 For Oracle, the userid under which the Oracle service runs must have Write permission 
on both the share and the folder where the database templates are located. If the Oracle service 
is running as the local SYSTEM account, you should add the NT AUTHORITY/SYSTEM 
account to both. 

SharedContent Share 
Create a share for the SharedContent folder that is created during the Smart 3D Reference Data 
setup. All users must be granted read permissions on the share; those users responsible for 
creating output and reference data must have write access. You will need to specify this location 
name when you use the Database Wizard to create the Site and Catalog databases. 
Additionally, if you installed Smart 3D Reference Data in the default folder (C:\Program 
Files\SmartPlant\3DRefData\), you must adjust access permissions as follows: 
 Access the Properties page for the SharedContent folder and modify the share permissions 

on the Sharing tab. At a minimum, permissions must allow read access for all users, and 
write access to those users responsible for creating output. 

 Access the Properties page for the SharedContent folder and modify the share permissions 
on the Security tab to give users full control disk access for the SharedContent folder and 
subfolders. 
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Permissions for .NET Assemblies 
Sign Assemblies 
Intergraph Process, Power & Marine signs all delivered .NET assemblies with a strong name. 
Signing an assembly is a way to guarantee the authenticity of an assembly. If you create your 
own custom .NET assemblies, we recommend that you sign them with your company's private 
key. Refer to Visual Studio help for information on signing an assembly. 
Granting Trust to Client Computers 
You must set each computer that uses the signed assemblies trust access to the assemblies. 
The easiest way to do this is to distribute the permissions to each client computer using an .msi 
file. You will need the .NET Framework 2.0 Configuration utility, which is available in the .NET 
Software Development Kit. You can also search the Microsoft web site for "configwizard.msi 
download". 
1. Install the .NET Framework 2.0 Configuration utility on a client computer. 
2. Select Start > Control Panel > System and Security > Administrative Tools > Microsoft 

.NET Framework 2.0 Configuration. 
3. In the Console Root tree, expand .NET Framework 2.0 Configuration > My Computer > 

Runtime Security Policy > Machine > Code Groups > All_Code > LocalIntranet _Zone. 
4. Under Tasks, click Add a Child Code Group. 
5. Select Create a new code group. 
6. In the Name box, type Delivered Smart 3D Content 
7. Click Next. 
8. In the Choose the condition type for this code group, select Strong Name. 
9. Click Import. 
10. Browse to and select one of the signed assemblies. 

 You need to select one of the Intergraph Process, Power & Marine signed 
assemblies from the shared content folder. All Intergraph Process, Power & Marine 
assemblies are signed with the same key, so it does not matter which assembly you select. 
The public key displays. 

11. Clear the Name check box. 
12. Clear the Version check box. 

 By clearing the Name and Version check boxes, the computer trusts all assemblies 
that were signed with the same strong name key. 

13. Click Next. 
14. Select FullTrust from Use existing permission set. 
15. Click Next. 
16. Click Finish. 
17. Right-click Runtime Security Policy, and then select Create Deployment Package. 
18. Select Machine. 
19. Specify the file name and folder location for the .msi file. 
20. Click Next. 
21. Click Finish. 
22. Distribute the .msi file to each client. 

 After you do this procedure for the Intergraph Process, Power & Marine 
assemblies, you need to repeat the steps for the custom assemblies that you have created and 
signed. 
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Command Line Alternative 
Instead of creating and distributing msi files, you can run a command line executable to grant 
the client computer access to the assemblies on the shared content share. You must run the 
following executable as an administrator from a command-line window on each client computer: 
"C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\caspol.exe" -pp off 
-machine -addgroup LocalIntranet_Zone -url \\server\share\* FullTrust 
-name "SharedContent Share" 

where \\server\share is the computer name and share name for the SharedContent share. 
 You must rerun this command line each time a .NET assembly is added to the 

share. 

See Also  
Install the Name Generator Service (on page 72) 
Install Smart 3D Reference Data (on page 66) 
 

Move Custom DLLs to SharedContent Folder 
Custom DLLs are any DLLs that are not originally delivered with SmartPlant 3D or delivered 
DLLs that have been modified by you to suit a specific purpose. Starting with Version 2009 (8.0) 
of SmartPlant 3D, custom DLLs should be saved in the SharedContent\Custom Symbols folder 
on your SharedContent share. Use the following workflow to copy your customized DLLs to this 
single location instead of registering each DLL on all client computers. 
1. Recompile each Visual Basic project in a Version 2011 R1 (9.1)  client installation. 
2. Copy the new DLLs to the [Reference Data Folder]\SharedContent\Custom Symbols folder. 

 
 You can create hierarchy folders as needed under the Custom Symbols folder. 
 If a custom DLL has a localizer DLL, both files should be located in the same folder. 
 DLLs ending "–Ref.dll" or "_Ref.dll" are treated as reference DLLs and are ignored. 

These DLLs do not need to be copied from the client machine containing the rules 
Visual Basic source code. 

3. In the Project Management task, select a catalog that uses the SharedContent folder where 
your custom DLLs are located. 

4. Select Tools > Update Custom Symbol Configuration or right-click the catalog node, and 
select Update Custom Symbol Configuration. 
The command creates or updates the file called CustomSymbolConfig.xml in the [Reference 
Data Folder]\SharedContent\Xml folder. CustomSymbolConfig.xml contains entries with the 
ProgID, CLSID, and DLL name for each class in the custom DLLs. After 
CustomSymbolConfig.xml is created, the software uses the custom DLLs from the 
[Reference Data Folder]\SharedContent\Custom Symbols folder without the need of 
registering the DLL on the local computer. 

 
 The software searches [Reference Data 

Folder]\SharedContent]\Xml\CustomSymbolConfig.xml first and then 
SystemSymbolConfig.xml. If there are duplicate entries in CustomSymbolConfig.xml and 
SymbolSymbolConfigSymbolSymbolConfig.xml for the same ProgID, an error or warning is 
written to the error log that appears when the Update Custom Symbol Configuration 
command finishes processing, and the DLL is not added to either XML file 
(CustomSymbolConfig.xml and SystemSymbolConfig.xml). Please clear any errors or 
warnings that appear in the error log after running this command to prevent such a scenario.  
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 Whenever a symbol or naming rule class is accessed, the software searches for the DLL as 
follows: 
a. It checks if an entry for the ProgID exists in the xml files. If an entry exists, then the 

corresponding DLL is loaded and an instance of the class is created. 
b. If an entry does not exist, it searches previously registered DLLs on the local computer. 
c. If any entry is not found for the ProgID in either XML file and the DLL is also not 

registered on the local machine, the software returns an error. In this case, you should 
copy the DLL to the [Reference Data Folder]\SharedContent\Custom Symbols folder, 
and run the Update Custom Symbol Configuration command in Project Management. 

If an entry exists for a ProgID in the xml files, it is used even though another (or same) copy 
of the DLL is registered on the local machine. The order of priority when creating an 
instance of an object is: CustomSymbolConfig.xml, SystemSymbolConfig.xml, and then the 
registry. 

 When a new custom DLL is added to the[Reference Data Folder]\SharedContent\Custom 
Symbols folder or an existing custom DLL is modified, you must re-run the Tools > Update 
Custom Symbol Configuration command in Project Management. 

 If you choose to use option 1, then the custom DLLs in the [Reference Data 
Folder]\SharedContent\Custom Symbols folder should not be registered on the local 
computer. 

 If any of these components use helper classes and the helper classes are instantiated by 
calling "CreateObject", the "CreateObject" needs to be replaced. If the helper class is in the 
same project, then "new" can be used instead of "CreateObject". If the helper class is in a 
different project, then "SP3DCreateObject" needs to be used instead of "CreateObject". 
SP3DCreateObject tries to instantiate the object using the information in xml files. If no entry 
is found in xml files for the given ProgID, then it calls "CreateObject". SP3DCreateObject is 
implemented in [Product Folder]\Core\Runtime\SP3DCoCreateInstance.dll. When 
SP3DCreateObject needs to be used, [Product 
Folder]\Core\Runtime\SP3DCoCreateInstance.dll needs to be referenced in the Visual Basic 
project. Example usage of SP3DCreateObject is shown below: 
Set oHelperObject = SP3DCreateObject(strHelperProgId) 

 If the symbol class has any public structures or types, they should be made private. For 
example: 
 Public Type InputType 
     Name As String 
     Description As String 
     Properties As IMSDescriptionProperties 
     uomValue As Double 
 End Type 

 Should be changed to: 
 Private Type InputType 
     Name As String 
     Description As String 
     Properties As IMSDescriptionProperties 
     uomValue As Double 
 End Type 

 Debugging and maintaining Visual Basic project references, reference DLLs, and binary 
compatibility are beyond the scope of this document. Contact your SmartPlant 3D Support 
representative if you have questions. 
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Installing the Name Generator Service 
The Name Generator Service supplies unique names to items placed in the model database. 
Although we recommend installing the Name Generator Service on the same computer as the 
reference data software, you can install the Name Generator Service on any computer running 
on the Windows domain. 

Hardware Requirements 
For optimal performance, the following minimum hardware requirements are recommended: 
 2.8 GHz Pentium® 4 processor or higher 
 Minimum of 1 GB memory 
 100 BaseT or higher network interface 
 Minimum of 5 MB hard drive disk space on the drive where Name Generator Service is 

installed 

Prerequisite Software 
For optimal performance, the following minimum software requirements are recommended: 
 For large installations: Microsoft Windows Server 2008 R2 

or 
 For small installations: Windows XP Service Pack 3 32-bit (maximum 10 connections), 

Windows XP Service Pack 2 64-bit (maximum 10 connections), or Windows 7 32-bit or 
64-bit (maximum 20 connections) 

 Microsoft .NET Framework 3.5 SP1 
 Adobe Acrobat Reader 
 32-bit or 64-bit Oracle Client 

 
 

 If you are installing the Name Generator Service on a Windows Server 2008 platform, you 
must manually enable MSDTC network access. For more information, see Enable Network 
Access in Windows Server 2008 (on page 39). 

 If you are installing the Name Generator Service on a server computer on which Microsoft 
SQL Server 2008 SP3 is installed, you must create a SQL Server Login that has a system 
administrator role in SQL Servers. For information about creating a SQL Server Login and 
assigning administrator privileges, see Configure SQL Server 2008 Account for Name 
Generator Service (on page 47). 

 If you are installing the Name Generator Service on a system running the Windows XP 
operating system, you must ensure that Launch and Access permissions are granted in 
COM Security in Windows XP Component Services dialog box for the Windows XP 
Workstation to be used as name generator. This is analogous to the Distributed COM users 
group in Windows 2008 Server. 

 If you are installing the Name Generator Service on an Oracle 32-bit Client computer, the 
computer must be configured to access the Oracle database server through Net Manager. 

 You must install the 32-bit Name Generator if you are using a 32-bit Oracle client. 
 Installing the 32-bit Name Generator with 32-bit Oracle Client on a 64-bit Oracle server 

causes slower database performance. 
 You can install the 32-bit Name generator on 32-bit or 64-bit workstations with 32-bit Oracle 

client loaded. 
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 The Name Generator Service works when installed with the 64-bit Oracle Client on a 64-bit 
database servers. We recommend that if you are running Oracle 64-bit on a 64-bit server 
with 64-bit client loaded, install the 64-bit Name Generator. 

 After installing the Name Generator Service, the firewall on that computer must be 
configured to allow DCOM Dynamic Ports.  For more information, see Configure the 
Firewall to Allow DCOM Communication in Windows 2008 Server (on page 79). 

See Also 
Enable Network Access in Windows Server 2008 (on page 39) 
Configure the Name Generator Service (on page 74) 
Install the Name Generator Service (on page 72) 
Install Smart 3D Reference Data (on page 66) 
 

Install the Name Generator Service 
Prior to installing the Name Generator Service on the computer, verify that all the prerequisites 
have been met. For more information, see Installing the Name Generator Service (on page 71). 
1. You must login to the computer with an account that has administrator privileges. 
2. Insert the Intergraph Smart 3D DVD. If the setup does not start automatically, double-click 

Setup.exe in the root folder of the CD. 
3. Select Name Generator Installation. 
4. Click Next on the Welcome to the Intergraph Smart 3D Name Generator Installation 

Wizard. 
5. On the User Information page, enter text in the Full Name and Organization fields, and 

then click Next. 
6. On the Software License Agreement page, select your country from the list and click 

Display to view the license agreement. 
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 The license agreement is delivered as a PDF file; consequently, you must have 
a PDF Reader installed on the computer in order to view the license agreement. If the 
software detects that a PDF Reader is not installed, an informational message box appears. 

7. Carefully read the license agreement. Close the PDF document, and click Yes on the 
License Agreement page to accept the terms. 

8. Select the 32-bit or 64-bit version of Name Generator to install, and click Next. This option is 
available only on 64-bit computers. 

 
9. Change the installation destination folder, if needed, and then click Next. 
10. On the Server Access page, enter the user account under which the Name Generator 

Service will run in the Username box. 

 
 You must specify an account with Windows administrative privileges on the server. 
 If you are configuring the Name Generator Service on a server computer on which 

Microsoft SQL Server 2008 SP3 is installed, the user account must also be a SQL 
Server Login that has a system administrator role in SQL Servers; otherwise, the Name 
Generator Service will not run. For information about creating a SQL Server Login and 
assigning administrator privileges, see Configure SQL Server 2008 Account for Name 
Generator Service (on page 47). 

11. In the Password and Confirm Password fields, enter the password of the user, and then 
click Next. 

12. Click Next on the Ready to Install the Application page to begin installing the Name 
Generator Service. 
A progress bar appears showing the progress of the installation. 

13. When the installation is complete, click Finish. 
 If a "Name Generation service configuration failed. Failed to update 

password in the SP3DNameGenerator" error message appears, you must configure the 
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name generation service manually. For more information, see Configure the Name 
Generator Service (on page 74). 

 
14. Restart the computer to complete the installation. 

See Also  
Installing the Name Generator Service (on page 71) 
 

Configure the Name Generator Service 
Perform the following steps to verify and, if necessary, manually configure the SmartPlant 3D 
Name Generator Service on a computer. This procedure is only necessary if you received the 
following error message during installation of the Name Generator Service: 

 
1. Log on with an account that has administrator privileges. 
2. Open the Control Panel, double-click Administrative Tools, and then double-click 

Component Services to start the component services MMC snap-in. 
The Component Services window appears as shown in the following illustration: 
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3. Expand the Component Services node under the Console Root, and then expand the 
Computers and My Computer nodes. 

 
4. Expand the COM+ Applications node. 
5. Verify the SP3DNameGenerator icon appears under COM+ Applications. If it exists, skip to 

step 14. If it does not exist, perform steps 6-13. 

 
6. Select COM+ Applications under the My Computer node, and then click 

Action>New>Application on the horizontal toolbar. 
7. Click Next on the Welcome to the COM Application Install Wizard page. 
8. Select Create an empty application on the Install or Create a New Application page. 
9. On the Create an Empty Application page, type SP3DNameGenerator in the Enter a 

name for the new application text box. 
10. Select Server application as the Activation type, and then click Next. 
11. On the Set Application Identity page, enter the user name and password to set the proper 

identity under which the COM+ application will run on the computer, and then click Next. 
 

 You must specify an account with Windows administrative privileges on the computer. 
 If you are configuring the Name Generator Service on a computer on which Microsoft 

SQL Server 2008 SP3 is installed, the user account must also be a SQL Server Login 
that has a system administrator role in SQL Servers; otherwise, the Name Generator 
Service will not run. For information about creating a SQL Server Login and assigning 
administrator privileges, see Configure SQL Server 2008 Account for Name Generator 
Service (on page 47). 

12. Click Finish to begin the installation. 
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 When the installation is complete, a SP3DNameGenerator node is placed under 
COM+ Applications. 

 
13. Next, expand the SP3DNameGenerator node. 
14. Expand the Components node. Verify the NTNameService.UpdateNumber.1 component 

appears. If it exists, skip to step 20. If it does not exist, perform steps 15-19. 
15. On the horizontal toolbar, click Action > New > Component. The COM Component 

Installation Wizard appears. 
16. Click Next on the Welcome to the COM Component Install Wizard. 
17. Select Install new component(s) and browse for NTNameService.dll. 

 The 32-bit component .DLL is located in [Product Folder]\CommonApp\Server\Bin. The 
64-bit component .DLL is located in [Product Folder]\CommonApp\Server\Bin64. 

18. Click Next on the Install new components page, and then click Finish to complete the 
installation procedure. 
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 The Component Services window indicates that the 
NTNameService.UpdateNumber.1 component is installed in the SP3DNameGenerator 
Application. 

 
19. Select the SP3DNameGenerator application icon. 
20. Click Action > Properties, and then click on the Identity tab. 
21. Select the This user: option. 
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22. Enter the user and password to set the proper identity under which the COM+ application 
will run on the computer. 

 
 

 You must specify an account with Windows administrative privileges on the computer. 
 If you are configuring the Name Generator Service on a computer on which Microsoft 

SQL Server 2008 SP3 is installed, the user account must also be a SQL Server Login 
that has a system administrator role in SQL Servers; otherwise, the Name Generator 
Service will not run. For information about creating a SQL Server Login and assigning 
administrator privileges, see Configure SQL Server 2008 Account for Name Generator 
Service (on page 47). 

23. Click Apply. 
24. Select the Security tab. 
25. Under Authorization, clear the Enforce access checks for this application option if 

selected. This option is selected by default in Windows 2003 Server, but must be turned off. 
26. Click OK to complete the configuration procedure. 

See Also  
Installing the Name Generator Service (on page 71) 
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Configure the Firewall to Allow DCOM Communication in 
Windows 2008 Server 

The following procedure presumes that you are using the firewall delivered by Microsoft with 
Windows 2008 Server. If you are using third-party firewall software, please consult that product's 
documentation. 
You must configure the firewall on the Windows 2008 R2 Server computer as described below 
for the Name Generator to run: 
 All RPC Dynamic Ports in the firewall must be open in order for the Name Generator to 

communicate with the client computers.  
 The Name Generator must be able to communicate with the SQL Server default instance 

running over TCP and the SQL Server Browser service.  
 The firewall can reset itself to its default settings. If you encounter an error, review 

your Windows Firewall settings and verify that they are as outlined in this procedure. 

Windows Firewall Instructions for RPC Dynamic Ports 
1. Click Start > Control Panel > System and Security > Windows Firewall. 
2. In the left panel section, select Advanced settings. 
3. In the left panel section, select Inbound Rules. 
4. In the right panel section under Actions, click New Rule. 
5. Select Port, and then click Next. 
6. Select TCP and Specific local ports. 
7. Type 135 in the Specific local ports box. 
8. Click Next. 
9. Select Allow the connection, and then click Next. 
10. Verify that Domain, Private, and Public are selected, and then click Next. 
11. In the Name box, type RPC. 
12. In the Description box, type Smart 3D Name Generator RPC. 
13. Click Finish. 
14. Right-click the new RPC rule in the list, and then select Properties. 
15. Select the Protocols and Ports tab. 
16. In the Local port option, select RPC Dynamic Ports. 
17. Click OK. 
18. Restart your computer so that the changes can take effect. 
 

Windows Firewall Instructions for Microsoft SQL Server 2008 
1. Click Start > Control Panel > System and Security > Windows Firewall. 
2. In the left panel section, select Advanced settings. 
3. In the left panel section, select Inbound Rules. 
4. In the right panel section under Actions, click New Rule. 
5. Select Port, and then click Next. 
6. Select TCP and Specific local ports. 
7. Type 1433 in the Specific local ports box. 
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8. Click Next. 
9. Select Allow the connection, and then click Next. 
10. Verify that Domain, Private, and Public are selected, and then click Next. 
11. In the Name box, type SQL 2008 Instance. 
12. In the Description box, type Smart 3D Name Generator SQL 2008 Instance. 
13. Click Finish. 
14. In the right panel section under Actions, click New Rule. 
15. Select Port, and then click Next. 
16. Select UDP and Specific local ports. 
17. Type 1434 in the Specific local ports box. 
18. Click Next. 
19. Select Allow the connection, and then click Next. 
20. Verify that Domain, Private, and Public are selected, and then click Next. 
21. In the Name box, type SQL 2008 Browser. 
22. In the Description box, type Smart 3D Name Generator SQL 2008 Browser. 
23. Click Finish. 
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S E C T I O N  7  

You can use the SmartPlant 3D client software for general modeling, as well as for performing a 
variety of administrative activities, including managing permissions, backing up and restoring 
data, creating plants, and monitoring database interference detection. Additionally, the software 
provides features that extend the capabilities of the software to include importing model data 
and integrating SmartPlant 3D with SmartPlant P&ID. 
The following table summarizes all the features that are available in the SmartPlant 3D 
installation, as well as any dependencies that exist between one feature and another. By default, 
all the features that are required for modeling are included in a typical setup: 

Task or Feature Name Default Feature Description 

Project Management No Installs the Project Management task for creating plants, 
managing access control, and upgrading databases. Also 
requires the SmartPlant 3D Server Connectivity 
component. 

3D Model Import No Installs the required components for importing model data 
into SmartPlant 3D. These commands are on the File > 
Import menu in all SmartPlant 3D tasks. 

Piping Specification 
Remote Access Server 

No Installs the necessary software for correlating piping 
specification data between SmartPlant 3D and SmartPlant 
P&ID. 

SmartPlant 3D Server 
Connectivity 

No Installs required connectivity components for the Bulkload 
Utility, as well as plant creation and upgrade functionality 
in the Project Management task. 

Bulkload Reference 
Data 

No Installs the Bulkload Utility for adding, modifying and 
deleting reference data from the Catalog database. 
Requires The SmartPlant 3D Server Connectivity 
component. 

Database Interference 
Detection Service 

No Installs the software required for database interference 
detection. You must configure this service through 
Windows Services. Requires the Project Management 
component. 

If you install the optional Project Management task, Microsoft SQL Server 2008 32-bit client 
must be installed on the same computer. These SQL Server components are not required on 
client computers where Project Management is not installed. 
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The Piping Specification Remote Access Server feature sets up the workstation computer as 
a remote access server. Selecting the Piping Specification Remote Access Server feature 
registers the SP3DPipingSpecRemoteAccessServer COM+ component. No additional files are 
copied to the administrator computer. For more information about the P&ID integration 
capabilities of the software, see Integrating with SmartPlant P&ID (on page 119) in the 
SmartPlant 3D Installation Guide. 

 
 SmartPlant 3D has not been fully certified for compatibility with any other Intergraph 

products installed and in concurrent use on the same computer, except those required to 
support PDS functionality. 

 If you have a previous version of SmartPlant 3D installed, you need to remove it before 
installing the new version. For more information, see Application Maintenance (on page 179) 
in the SmartPlant 3D Installation Guide. 
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Instructions for Windows XP with Service Pack 3 
When you install Microsoft XP Service Pack 3, all network Microsoft Distributed Transaction 
Coordinator (MSDTC) transactions are disabled, even if network transactions were previously 
enabled prior to installing the service pack. Consequently, you must manually configure MSDTC 
and re-enable your distributed scenarios. 
Additionally, Microsoft XP Service Pack 3 enables a firewall by default. SmartPlant 3D uses the 
Distributed Transaction Coordinator (DTC) service, which in turn uses Microsoft Distributed 
Component Object Model (DCOM)/Remote Procedure Call (RPC) technology. As a result, you 
must manually configure the Windows firewall to allow the DTC service and confine incoming 
external communication to port 135 (the RPC Endpoint Mapper port). 

See Also 
Configure Microsoft Distributed Transaction Coordinator (XP Client Only) (on page 84) 
Configure the Firewall to Allow DCOM Communication in XP (on page 85) 
 

SmartPlant 3D Port Assignments 
SmartPlant 3D uses the following port assignments: 

 On Windows 7 and Windows XP systems, to avoid opening each TCP port address from 
1024 through 65536 for Microsoft Distributed Transaction Coordinator (MSDTC) 
communications, you can allow MSDTC to work through the system's firewall. For more 
information on allowing MSDTC to work through a firewall, refer to one of the following links, 
depending on your system: 
 Windows XP: http://support.microsoft.com/kb/250367 
 Windows 7 (for a generic procedure on allowing a program through the firewall):  

http://windows.microsoft.com/en-US/windows7/Allow-a-program-to-communicate-through-Wi
ndows-Firewall 

 

Port Number TCP/UDP Communication Comments 

135 TCP From workstation to 
server; from server to 
workstation 

For SmartPlant 3D System 

    

1024 through 
65536 

TCP From workstation to 
server; from server to 
workstation 

For SmartPlant 3D (for MSDTC), see 
note above about an alternate 
configuration. 
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Configure Microsoft Distributed Transaction Coordinator 
(XP Client Only) 

The following procedure is only necessary if you are using Microsoft XP Professional with 
Service Pack 3. 
When you install Microsoft XP Service Pack 3, all network Microsoft Distributed Transaction 
Coordinator (MSDTC) transactions are disabled, even if network transactions were previously 
enabled prior to installing the service pack. Use the following procedure to manually configure 
MSDTC and re-enable your distributed scenarios. 
1. Click Start > Control Panel and double-click Administrative Tools. 
2. Double-click Component Services. 
3. Under Console Root, expand the Component Services and Computers nodes. 
4. Under the Computers node, right-click on My Computer and select Properties. 
5. On the MSDTC tab, click Security Configuration.  

The Security Configuration dialog box displays. 
6. In the Security Settings section, enable Network DTC Access. 
7. In the Transaction Manager Communication section, enable the Allow Outbound, Allow 

Inbound, and No Authentication Required options. 
8. Enable the Enable XA Transactions option. 
9. In the DTC Logon Account section, verify that NT AUTHORITY/Network Service appears 

in the Account box. 
10. Click OK. 

See Also  
Instructions for Microsoft Windows Server 2008 (on page 39) 
Instructions for Windows XP with Service Pack 3 (on page 83) 
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Verify Startup of Microsoft Distributed Transaction 
Coordinator in XP 

1. Open the Control Panel and double-click Administrative Tools. 
2. Double-click Services. 

 You can also right-click My Computer and select Manage. In the Computer 
Management window, expand the Services and Applications node, and click Services. 

3. Locate Distributed Transaction Coordinator in the list of services, and verify that the 
Status is set to Started and Startup Type is set to Automatic. 

 
4. If the Distributed Transaction Coordinator service is not started, follow the steps below to 

start the service. 

Start MSDTC 
1. Open the Control Panel and double-click Administrative Tools. 
2. Double-click Services. 
3. To change the Status or Startup Type, right-click on the Distributed Transaction 

Coordinator service, and select Properties from the shortcut menu. 
4. On the General tab, select Automatic from the Startup type list. 
5. In the Service status section, click Start. 
6. Click OK. 
 

Configure the Firewall to Allow DCOM Communication in XP 
The following procedure presumes that you are using the firewall delivered by Microsoft with 
Windows XP SP3. If you are using third-party firewall software, please consult that product's 
documentation. 
1. Click Start > Control Panel > Security Center, and select Windows Firewall. 
2. On the Exceptions tab in the Windows Firewall dialog box, click Add Program. 
3. In the Add a Program dialog box, click Browse. 
4. In the Browse dialog box, type %SYSTEMROOT%\SYSTEM32\MSDTC.exe in the File 

name box and click Open. 
5. In the Add a Program dialog box, click Change Scope and define the scope per your 

network configurations. 
6. Click OK, and then click OK in the Add a Program dialog box. 



Setting Up the Client 
 

 
86 SmartPlant 3D Installation Guide 

 

7. On the Exceptions tab, verify that MSDTC.exe has been added to the Programs and 
Services list. 

 
 Make sure that the File and Printer Sharing option is checked. This is necessary for 

Project Management, connection to the site database for the first time, and submission of 
NT Batch jobs to other workstations to work properly. 

8. On the Exceptions tab, click Add Port. 
9. In the Add a Port dialog box, type RPC in the Name box and 135 in the Port number box. 
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 Leave the protocol set to the default, TCP. 

 
10. Click Change scope and define the scope per your network configurations. 
11. Click OK to close the Change scope dialog box. 
12. Click OK to close the Add a Port dialog box. 
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13. On the Exceptions tab, verify that RPC has been added to the Programs and Services 
list, and then click OK to close the Windows Firewall dialog box. 

 
14. Restart your computer so that the changes can take effect. 

 The firewall can reset itself to its default settings. If you encounter the error 
"Cannot enlist SQL PDS with MSDTC", review your Windows Firewall settings and verify 
that they are as outlined in this procedure. 

See Also  
Instructions for Windows XP with Service Pack 3 (on page 83) 
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Instructions for Windows Vista with Service Pack 2 
When you install Microsoft Windows Vista Service Pack 2, all network Microsoft Distributed 
Transaction Coordinator transactions are disabled, even if the network transactions were 
previously enabled prior to installing the service pack. Consequently, you must manually 
configure MSDTC and re-enable your distributed scenarios.  
Additionally, Microsoft Vista Service Pack 2 enables a firewall by default. SmartPlant 3D uses 
the Distributed Transaction Coordinator (DTC) service, which in turn uses Microsoft Distributed 
Component Object Model (DCOM)/Remote Procedure Call (RPC) technology. As a result, you 
must manually configure the Windows firewall to allow the DTC service and confine incoming 
external communication to port 135 (the RPC Endpoint Mapper port). 

See Also 
Configure Microsoft Distributed Transaction Coordinator (Vista or Windows 7 Client Only) (on 
page 90) 
Verify Startup of Microsoft Distributed Transaction Coordinator in Vista and Windows 7 (on page 
90) 
Configure the Firewall to Allow DCOM Communication (on page 91) 
 
 

SmartPlant 3D Port Assignments 
SmartPlant 3D uses the following port assignments: 

 On Windows 7 and Windows XP systems, to avoid opening each TCP port address from 
1024 through 65536 for Microsoft Distributed Transaction Coordinator (MSDTC) 
communications, you can allow MSDTC to work through the system's firewall. For more 
information on allowing MSDTC to work through a firewall, refer to one of the following links, 
depending on your system: 
 Windows XP: http://support.microsoft.com/kb/250367 
 Windows 7 (for a generic procedure on allowing a program through the firewall):  

http://windows.microsoft.com/en-US/windows7/Allow-a-program-to-communicate-through-Wi
ndows-Firewall 

 

Port Number TCP/UDP Communication Comments 

135 TCP From workstation to 
server; from server to 
workstation 

For SmartPlant 3D System 

    

1024 through 
65536 

TCP From workstation to 
server; from server to 
workstation 

For SmartPlant 3D (for MSDTC), see 
note above about an alternate 
configuration. 
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Configure Microsoft Distributed Transaction Coordinator 
(Vista or Windows 7 Client Only) 

The following procedure is only necessary if you are using Microsoft Windows Vista or Microsoft 
Windows 7. All network Microsoft Distributed Transaction Coordinator (MSDTC) transactions are 
disabled. Use the following procedure to manually configure MSDTC and re-enable your 
distributed scenarios. 
1. Click Start > All Programs > Accessories > Run.  
2. Type dcomcnfg, and click OK. 
3. Under Console Root, expand the Component Services, Computers, My Computer, and 

Distributed Transaction Coordinator nodes. 
4. If you get a Windows Firewall alert regarding Microsoft Management Console features being 

blocked, select Domain networks, such as a workplace network, and then click Allow 
access. 

5. Under the Distributed Transaction Coordinator node, right-click on Local DTC and select 
Properties. 

6. Select the Security tab. 
7. In the Security Settings section, enable Network DTC Access. 
8. In the Client and Administration section, enable Allow Remote Clients and Allow 

Remote Administration options. 
9. In the Transaction Manager Communication section, enable the Allow Inbound, Allow 

Outbound and No Authentication Required options. 
10. Enable the Enable XA Transactions option. 
11. In the DTC Logon Account section, verify that NT AUTHORITY/Network Service appears 

in the Account box. 
12. Click OK. 
13. Click Yes if you are prompted to stop and restart the MSDTC service. 
 
 

Verify Startup of Microsoft Distributed Transaction 
Coordinator in Vista and Windows 7 

1. Click Start > All Programs > Accessories > Run.  
2. Type dcomcnfg, and click OK. 
3. Double-click Services. 

 You can also right-click My Computer and select Manage. In the Computer 
Management window, expand the Services and Applications node, and click Services. 
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4. Locate Distributed Transaction Coordinator in the list of services, and verify that the 
Status is set to Started and Startup Type is set to Automatic. 

 
5. If the Distributed Transaction Coordinator service is not started, right-click on the 

Distributed Transaction Coordinator service, and select Properties from the shortcut 
menu. 

6. On the General tab, select Automatic from the Startup type list. 
7. In the Service status section, click Start. 
8. Click OK. 
 

Configure the Firewall to Allow DCOM Communication 
The following procedure presumes that you are using the firewall delivered by Microsoft with 
Windows Vista. If you are using third-party firewall software, please consult that product's 
documentation. 
1. Click Start > Control Panel > Security. 
2. In the Security Center section, select Allow a program though Windows Firewall. 
3. On the Exceptions tab in the Windows Firewall Settings dialog box, click Add Program. 
4. In the Add a Program dialog box, click Browse. 
5. In the Browse dialog box, type %SYSTEMROOT%\SYSTEM32\MSDTC.exe in the File 

name box and click Open. 
6. In the Add a Program dialog box, click Change Scope and define the scope per your 

network configurations. 
7. Click OK, and then click OK in the Add a Program dialog box. 
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8. On the Exceptions tab, verify that MSDTC.exe has been added to the Programs and 
Services list. 

 
 Make sure that the File and Printer Sharing option is checked. This is necessary for 

Project Management, connection to the site database for the first time, and submission of 
NT Batch jobs to other workstations to work properly. 

9. On the Exceptions tab, click Add Port. 
10. In the Add a Port dialog box, type RPC in the Name box and 135 in the Port number box. 
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 Leave the protocol set to the default, TCP. 

 
11. Click Change scope and define the scope per your network configurations. 
12. Click OK to close the Change scope dialog box. 
13. Click OK to close the Add a Port dialog box. 
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14. On the Exceptions tab, verify that RPC has been added to the Programs and Services 
list, and then click OK to close the Windows Firewall dialog box. 

 
15. Restart your computer so that the changes can take effect. 

 The firewall can reset itself to its default settings. If you encounter the error 
"Cannot enlist SQL PDS with MSDTC", review your Windows Firewall settings and verify 
that they are as outlined in this procedure. 

See Also  
Instructions for Windows Vista with Service Pack 2 (on page 89) 
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Instructions for Windows 7 
When you install Windows 7 Service Pack 1, all network Microsoft Distributed Transaction 
Coordinator transactions are disabled. You must manually configure MSDTC and enable your 
distributed scenarios. 
Additionally, Windows 7 SP1 enables a firewall by default. SmartPlant 3D uses the Distributed 
Transaction Coordinator (DTC) service, which in turn uses Microsoft Distributed Component 
Object Model (DCOM)/Remote Procedure Call (RPC) technology. As a result, you must 
manually configure the Windows firewall to allow the DTC service. 

See Also 
Configure Microsoft Distributed Transaction Coordinator (Vista or Windows 7 Client Only) (on 
page 90) 
Verify Startup of Microsoft Distributed Transaction Coordinator in Vista and Windows 7 (on page 
90) 
Configure the Firewall to Allow DCOM Communication in Windows 7 (on page 97) 
 

SmartPlant 3D Port Assignments 
SmartPlant 3D uses the following port assignments: 

 On Windows 7 and Windows XP systems, to avoid opening each TCP port address from 
1024 through 65536 for Microsoft Distributed Transaction Coordinator (MSDTC) 
communications, you can allow MSDTC to work through the system's firewall. For more 
information on allowing MSDTC to work through a firewall, refer to one of the following links, 
depending on your system: 
 Windows XP: http://support.microsoft.com/kb/250367 
 Windows 7 (for a generic procedure on allowing a program through the firewall):  

http://windows.microsoft.com/en-US/windows7/Allow-a-program-to-communicate-through-Wi
ndows-Firewall 

 

Port Number TCP/UDP Communication Comments 

135 TCP From workstation to 
server; from server to 
workstation 

For SmartPlant 3D System 

    

1024 through 
65536 

TCP From workstation to 
server; from server to 
workstation 

For SmartPlant 3D (for MSDTC), see 
note above about an alternate 
configuration. 
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Configure Microsoft Distributed Transaction Coordinator 
(Vista or Windows 7 Client Only) 

The following procedure is only necessary if you are using Microsoft Windows Vista or Microsoft 
Windows 7. All network Microsoft Distributed Transaction Coordinator (MSDTC) transactions are 
disabled. Use the following procedure to manually configure MSDTC and re-enable your 
distributed scenarios. 
1. Click Start > All Programs > Accessories > Run.  
2. Type dcomcnfg, and click OK. 
3. Under Console Root, expand the Component Services, Computers, My Computer, and 

Distributed Transaction Coordinator nodes. 
4. If you get a Windows Firewall alert regarding Microsoft Management Console features being 

blocked, select Domain networks, such as a workplace network, and then click Allow 
access. 

5. Under the Distributed Transaction Coordinator node, right-click on Local DTC and select 
Properties. 

6. Select the Security tab. 
7. In the Security Settings section, enable Network DTC Access. 
8. In the Client and Administration section, enable Allow Remote Clients and Allow 

Remote Administration options. 
9. In the Transaction Manager Communication section, enable the Allow Inbound, Allow 

Outbound and No Authentication Required options. 
10. Enable the Enable XA Transactions option. 
11. In the DTC Logon Account section, verify that NT AUTHORITY/Network Service appears 

in the Account box. 
12. Click OK. 
13. Click Yes if you are prompted to stop and restart the MSDTC service. 
 
 

Verify Startup of Microsoft Distributed Transaction 
Coordinator in Vista and Windows 7 

1. Click Start > All Programs > Accessories > Run.  
2. Type dcomcnfg, and click OK. 
3. Double-click Services. 

 You can also right-click My Computer and select Manage. In the Computer 
Management window, expand the Services and Applications node, and click Services. 
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4. Locate Distributed Transaction Coordinator in the list of services, and verify that the 
Status is set to Started and Startup Type is set to Automatic. 

 
5. If the Distributed Transaction Coordinator service is not started, right-click on the 

Distributed Transaction Coordinator service, and select Properties from the shortcut 
menu. 

6. On the General tab, select Automatic from the Startup type list. 
7. In the Service status section, click Start. 
8. Click OK. 
 

Configure the Firewall to Allow DCOM Communication in 
Windows 7 

The following procedure presumes that you are using the firewall delivered by Microsoft with 
Windows 7. If you are using third-party firewall software, please consult that product's 
documentation. 
1. Click Start > Control Panel > System and Security > Windows Firewall. 
2. In the left panel section, select Allow a program or feature though Windows Firewall. 
3. In the Allowed Programs dialog box, click Allow another program. 
4. In the Add a Program dialog box, click Browse. 
5. In the Browse dialog box, type %SYSTEMROOT%\SYSTEM32\MSDTC.exe in the File 

name box, and click Open. 
6. Click Add. 
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7. Verify that Distributed Transaction Coordinator has been added to the Allowed 
programs and features list. 

 
 Make sure that the File and Printer Sharing option is checked. This is necessary for 

Project Management, connection to the site database for the first time, and submission of 
Intergraph Batch Services jobs to other workstations to work properly. 

8. Click OK. 
9. Restart your computer so that the changes can take effect. 

 The firewall can reset itself to its default settings. If you encounter the error 
"Cannot enlist SQL PDS with MSDTC", review your Windows Firewall settings and verify 
that they are as outlined in this procedure. 

Windows Firewall Instructions for RPC Dynamic Ports 
1. Click Start > Control Panel > System and Security > Windows Firewall. 
2. In the left panel section, select Advanced settings. 
3. In the left panel section, select Inbound Rules. 
4. In the right panel section under Actions, click New Rule. 
5. Select Port, and then click Next. 
6. Select TCP and Specific local ports. 
7. Type 135 in the Specific local ports box. 
8. Click Next. 
9. Select Allow the connection, and then click Next. 
10. Verify that Domain, Private, and Public are selected, and then click Next. 
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11. In the Name box, type RPC. 
12. In the Description box, type Smart 3D Name Generator RPC. 
13. Click Finish. 
14. Right-click the new RPC rule in the list, and then select Properties. 
15. Select the Protocols and Ports tab. 
16. In the Local port option, select RPC Dynamic Ports. 
17. Click OK. 
18. Restart your computer so that the changes can take effect. 
 

Windows Firewall Instructions for Microsoft SQL Server 2008 
1. Click Start > Control Panel > System and Security > Windows Firewall. 
2. In the left panel section, select Advanced settings. 
3. In the left panel section, select Inbound Rules. 
4. In the right panel section under Actions, click New Rule. 
5. Select Port, and then click Next. 
6. Select TCP and Specific local ports. 
7. Type 1433 in the Specific local ports box. 
8. Click Next. 
9. Select Allow the connection, and then click Next. 
10. Verify that Domain, Private, and Public are selected, and then click Next. 
11. In the Name box, type SQL 2008 Instance. 
12. In the Description box, type Smart 3D Name Generator SQL 2008 Instance. 
13. Click Finish. 
14. In the right panel section under Actions, click New Rule. 
15. Select Port, and then click Next. 
16. Select UDP and Specific local ports. 
17. Type 1434 in the Specific local ports box. 
18. Click Next. 
19. Select Allow the connection, and then click Next. 
20. Verify that Domain, Private, and Public are selected, and then click Next. 
21. In the Name box, type SQL 2008 Browser. 
22. In the Description box, type Smart 3D Name Generator SQL 2008 Browser. 
23. Click Finish. 
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Loading Prerequisite Software on the Client 
The following prerequisite software is required in order to install and use the software on a client 
computer: 
 Microsoft .NET Framework 3.5 
 Microsoft Visual C++ 2008 SP1 Redistributable Package with MFC Security Update 
 Microsoft XML 6.0 
 Microsoft Data Access Components 2.8.1 or higher 
 Microsoft Office 
 Adobe Acrobat Reader 
 SmartPlant License Manager 2010 (V11.0) 

See Also  
Loading Prerequisite Software on the Database Server (on page 43) 
 

Install Microsoft .NET Framework 
Stop any real-time virus checkers before you proceed because they can interfere with the 
installation. If you are running Windows Vista, you must install .Net Framework 3.5 on Vista 
because it is not delivered with Vista. If you are running Windows 7, .Net Framework 3.0 SP2, 
and 3.5 SP1 are already included with the operating system so you can skip this procedure. 

.NET Framework 3.5 Installation 
1. You must be logged on to the server computer as an administrator. 
2. Insert the Intergraph Smart 3D Product DVD. 

 If the CD does not start automatically, double-click setup.exe in the root folder of the 
DVD. 

3. Click Prerequisite Software. 
4. Click Microsoft .NET Framework 3.5 SP1 Installation. 
5. Click Next. 
6. On the License Agreement page, click I agree and then click Install. 
7. When installation completes, click OK. 

 The software also supports the latest .NET Framework 3.5 service packs. To check for 
the latest service pack, click Start > Windows Update. 
On Windows 2008 R2 Server, .NET Framework 3.5.1 is installed by default. You can confirm 
this by looking at the Role Services in Server Manager. 

See Also 
Loading Prerequisite Software on the Client (on page 100) 
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Install Microsoft Visual C++ 2008 SP1 Redistributable 
Package with MFC Security Update 

Microsoft Visual C++ 2008 SP1 Redistributable Package with MFC Security Update is required 
before installing SmartPlant 3D on a client computer. The installation of SmartPlant 3D will not 
proceed until VC++ 2008 SP1 is installed on the computer. Click Yes if you prompted to install 
this requirement. 
1. You must be logged on to the server computer as an administrator. 
2. Insert the Intergraph Smart 3D Product DVD. 

 If the CD does not start automatically, double-click Setup.exe in the root folder of the 
DVD. 

3. Click Prerequisite Software. 
4. Click Microsoft Visual C++ 2008 SP1 Redistributable Package with MFC Security 

Update. 
5. Click Next. 
6. On the License Agreement page, click “I have read accept the license terms.” and then click 

Install. 
7. When installation completes, click Finish. 
 

Install Microsoft XML 6.0 
To install Microsoft XML 6.0, open your web browser and go to the MSXML Developer Center 
Web Site (http://msdn.microsoft.com/xml/). Follow the guidelines to click the appropriate link for 
downloading MSXML 6.0 on the workstation computer. 
1. When downloading is complete, double-click the setup file. 
2. On the Welcome page, click Next. 
3. On the End-User License Agreement page, click I accept the terms in the License 

Agreement and click Next. 
4. On the Customer Information page, enter your name and organization and click Next. 
5. On the Choose Setup Type page, click Install Now. 
6. Click Finish on the Setup Complete page. 

See Also  
Setting Up the Client (on page 81) 
 

Install Microsoft Data Access Components 
If you are using Microsoft SQL Server databases and intend to include the Project Management 
capabilities as part of the workstation computer setup, skip this procedure. The required MDAC 
component is included as part of the Microsoft SQL Server 2008 SP3 release, which is a 
required prerequisite for installing the Project Management software on a workstation computer. 
In order to run SmartPlant 3D, you must be running MDAC 2.8.1 or higher. You can download 
and install the required MDAC component from the Data Developer Center MDAC Downloads 
(http://msdn.microsoft.com/en-us/data/aa937730) web page. 

See Also 
Loading Prerequisite Software on the Client (on page 100) 

http://msdn.microsoft.com/xml/
http://msdn.microsoft.com/en-us/data/aa937730
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Install Microsoft Office 
Several of the SmartPlant 3D tasks require Microsoft Office. Designers need Microsoft Excel to 
create reports and system administrators rely on Excel to make changes to the reference data 
spreadsheets and bulk load them into the Catalog database. 
The current release of the software supports Microsoft Office 2003, Office 2007, and Office 2010 
(32-bit). 

 
 The system language specified for Microsoft Office must be the same as the system 

language specified by the operating system. For example, if your operating system language 
is English, Microsoft Office must also be set to English. 

 If you choose to do a custom installation of Office, be sure to select the .NET Programming 
Support for Excel, which is required for the Model Data Reuse command. 

See Also  
Loading Prerequisite Software on the Client (on page 100) 
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Installing Microsoft SQL Server 2008 Client 
Because system configurations and individual company standards vary, use this section as a 
checklist instead of step-by-step instructions for Microsoft SQL Server 2008 SP3. Please contact 
Intergraph Customer Support for specific configuration questions. 

 
 Microsoft SQL Server 2008 SP3 requires XML 6.0 and will automatically install it as part of 

the SQL Server 2008 Prerequisite installation. 
 There are internationalization considerations concerning the SQL Server collation settings 

you specify that relate to reference data, using SmartPlant Enterprise integrated systems, 
Global Workshare Configuration, multiple locales, backup/restore, reports, and upgrading to 
future releases. Please contact Intergraph Customer Support for specific configuration 
questions. 

 If a XenApp 6.0 local data store (farm) will be used, Microsoft SQL Server Client must be 
installed before installing XenApp 6.0. 

1. Insert your SQL Server DVD and start the setup program.  

 
2. From the Planning page, select System Configuration Checker to check for pre-requisite 

applications as well as identify potential installation problems. 
 You may be asked to restart your computer if any pre-requisite applications were 

installed. 
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3. Click Installation and select the New SQL Server stand-alone installation or add 
features to an existing installation option. 

 
4. As you go through the installation process, make sure you install the Setup Support Files 

and review any Setup Support Rules that identify potential problems. 
5. When you get to Feature Selection, select the client features that you want to include: 

 Client Tools Connectivity 
 Management Tools - Basic 
 Management Tools - Complete 
 SQL Server Books Online 

 
6. When you get to Installation Rules, make sure all operations have passed.  
7. From Ready to Install, click Install. 
8. When the installation has been completed, review the summary log file for any problems. 
9. Before you use the software, you must register it. See Register SQL Server 2008 (on page 

105). 
10. Install any required service packs or upgrades for SQL Server 2008. See Install any 

Required SQL Server 2008 Upgrades (on page 47). 
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Register SQL Server 2008 
Before using the Microsoft SQL Server 2008 SP3 software, you must register the database 
server with the workstation computer. 
1. Open SQL Server Management Studio and click View > Registered Servers. Registered 

Servers appear in the left tree view. 

 
2. In the tree view, right-click Database Engine, and select New > Server Registration in the 

shortcut menu. The New Server Registration dialog box appears. 
3. On the General tab, enter or select the name of the server you want to register. 
4. Click Save. 

 If you intend to use the server computer in a Global Workshare Configuration, 
register the server with a fully qualified domain. For example, a server on the INGRPPO 
domain named WORKFLOW5 must be registered as WORKFLOW5.INGRPPO.COM. For 
more information about using Workshare, see the Project Management User's Guide, 
available from Help > Printable Guides in the software. 

5. Exit Management Studio. 
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Installing and Configuring Oracle Client Software 
Because system configurations and individual company standards vary, use this section as a 
checklist instead of step-by-step instructions. Please contact Intergraph Customer Support for 
specific configuration questions. 

  
 SmartPlant 3D is a 32-bit application that uses the 32-bit Oracle Client even when loaded on 

a 64-bit client operating system. 
 Do not use the Oracle "light client" as it does not include some DLLs required by SmartPlant 

3D. 

See Also  
Install Oracle Client Software 11g Release 2 (on page 106) 
Configure the Oracle Client (on page 107) 
Verify Startup of Oracle Client Services (on page 107) 
Initialize the Oracle Database (on page 57) 
 

Install Oracle Client Software 11g Release 2 
Installation of the full Oracle Client software is required for a workstation computer so that the 
software can connect to the Oracle database. After the Oracle Client software is installed, you 
will configure the software so that your computer can communicate with the Oracle database. 
1. Select Custom on the Select Installation Type screen, and click Next. 
2. Select a language in the Select Product Languages screen, and click Next. 
3. Specify the Oracle Base location for the base folder and the Software Location for the 

home folder by browsing to the location, and click Next. 
4. On the Available Product Components screen, select the following components: 

 Oracle Database Utilities 
 SQL *Plus 
 Enterprise Manager Minimal Integration 
 Oracle Net 
 Oracle Connection Manager 
 Oracle ODBC Driver 
 Oracle Services for Microsoft Transaction Server 
 Oracle Administration Assistant for Windows 
 Oracle Counters for Windows Performance Monitor 
 Oracle Objects for OLE 
 Oracle Provider for OLE DB 
 Oracle Data Provider for .NET 

5. Specify port number 2030 in the Specify port number field on the Oracle Services for 
Microsoft Transaction Services screen, and click Next. 
The software performs a prerequisite check before continuing. 

6. Click Finish on the Summary screen. 
A progress bar tracks the progress of the installation. 

7. When installation is complete, you must install Patch 8. 
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For more details, see Appendix: Install and Configure Oracle Software (on page 197) in the 
SmartPlant 3D Installation Guide. 
Now that the Oracle Client is installed, you can configure the client. For more information, see 
Configure the Oracle Client (on page 107). 

See Also 
Installing and Configuring Oracle Client Software (on page 106) 
 

Configure the Oracle Client 
Client computers need to be configured before they can connect to an Oracle database. To 
configure the client computer, you must first install Oracle Client software as outlined: 
1. Start Oracle Net Manager. 
2. Select the Service Naming node, Install Oracle Client Software 11g Release 2 (on page 

106), and then click the green plus sign to start the Net Service Name Wizard. 

 
3. Specify a Service Name. 

 The Service Name must be the same on the server and client. You will need to 
provide this net service name when creating databases, bulkloading and configuring 
Workshare. 

4. Select TCP/IP (Internet Protocol). 
5. Specify the Host name (typically the network name of the database server computer) and 

Port Number (default=1521) for your protocol settings. 
6. Specify the Service Name and Connection Type. 
7. Test the new service. 
8. If the default test fails, click Change Login, enter a valid username/password combination 

and, retest the connection. 
9. When the login test is successful, click Finish to close the wizard. 
10. Click File > Save Network Configuration to save your new network service. 

See Also  
Installing and Configuring Oracle Client Software (on page 106) 
 

Verify Startup of Oracle Client Services 
1. Open the Control Panel and double-click Administrative Tools. 
2. Double-click Services. 
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 You can also right-click My Computer and select Manage. In the Computer 
Management window, expand the Services and Applications node, and click Services. 

3. Verify that the Status field is set to Started and the Startup Type field is set to Automatic, 
for each of the following services: 
Distributed Transaction Coordinator 
OracleMTSRecoveryService 

4. To change the Status or Startup Type fields, right-click the service name, and select 
Properties from the shortcut menu. 

5. On the General tab, select Automatic from the Startup type list. 
6. In the Service status section, click Start. 
7. Click OK. 

See Also  
Installing and Configuring Oracle Client Software (on page 106) 
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Install Smart 3D Client Software 
Prior to installing SmartPlant 3D on a workstation computer, verify that the workstation computer 
meets the required hardware and software requirements and that all prerequisite software has 
been installed. For more information about hardware and software requirements, see 
SmartPlant 3D Workstation Recommendations (on page 22) in the SmartPlant 3D Installation 
Guide. For more information about the prerequisite software, see Loading Prerequisite Software 
on the Client (on page 100). 
If you have an older version of SmartPlant 3D software installed on your computer, uninstall it 
before loading the new software. For more information, see Remove Smart 3D Software (on 
page 182) in the SmartPlant 3D Installation Guide. 
Approximately 1.5 GB of hard disk space is required to perform a default setup of the software. 
Alternative installation configurations have other hard disk space requirements. Prior to installing 
SmartPlant 3D on a workstation computer, select and size the hard disk partitions accordingly. 
For additional information, see Disk Partitioning Guidelines (on page 27) in the SmartPlant 3D 
Installation Guide. 
You must have administrator privileges on the computer to install the software. If you are 
installing on Windows Vista or Windows 7, use the Run as Administrator option. 
If you have not already installed and configured SmartPlant License Manager on your computer, 
we recommend doing so before installing SmartPlant 3D. 

 SmartPlant 3D requires the SmartPlant License Manager software for concurrent 
licensing for both the core SmartPlant 3D product and for each module. This licensing software 
is delivered on its own CD that comes with your Smart 3D DVD. For more information about 
using and configuring concurrent licensing, see the SmartPlant License Manager Installation 
and User's Guide (SPLMInstall_UserGuide.pdf). 
1. Insert the Intergraph Smart 3D DVD. If the DVD does not start automatically, double-click 

Setup.exe in the root folder of the DVD. 
2. Click Smart 3D Installation. 
3. Click Next on the Welcome to the Smart 3D Installation Wizard page. 
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 Because the current version of SmartPlant 3D supports both SQL Server and 
Oracle databases, the setup checks the computer to verify that the correct version of the 
database client software is installed. If the software determines that Oracle Client is not 
installed (for example, if you are using the software with SQL Server databases), the 
software displays the following message: 

 
If you are planning to use the software with SQL Server databases, click Yes to continue 
installing SmartPlant 3D. If you are planning to use the software with Oracle databases, click 
No to exit the Smart 3D setup and install the Oracle client software. 

4. On the User Information page, enter information in the Full Name, Organization, and 
Serial number boxes. The serial number sticker is located on the CD package. 

 The serial number is used for product identification only. A license key is 
required to run SmartPlant 3D. For more information about installing and using SmartPlant 
License Manager, see the SmartPlant License Manager Installation and User's Guide 
(SPLMInstall_UserGuide.pdf). 

5. Click Next. 
6. On the Software License Agreement page, select your country from the list, and click 

Display to view the license agreement. 
 The license agreement is delivered as a PDF file; consequently, you must have 

Acrobat Reader installed on the client computer in order to view the license agreement. If 
the software detects that Acrobat Reader is not installed, a message box appears. To install 
Acrobat Reader (from the Intergraph Smart 3D DVD) and continue with the installation, 
click Yes. If you click No on the message box, the setup process immediately stops without 
installing the client software. 

7. Carefully read the license agreement. Close the PDF document, and click Yes on the 
Software License Agreement page to accept the terms. 

8. On the Destination Folder page, click Browse and select the folder location for the client 
software. Then click OK. 
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9. On the Select Features page, select the features that you want to install. For example, if 
you want to be able to create databases in SmartPlant 3D, click the Project Management 
and SmartPlant 3D Server Connectivity options, and select Will be installed on local 
hard drive. 

 
Before adding and removing features from the setup, review the dependencies that can 
exist between one feature and another. 

10. Click Next. 
11. On the Ready to Install the Application page, verify the installation summary. Click Back 

to return to any previous pages and make changes. 
12. Click Next to begin installing client software. 
13. Click Finish to exit the installation sequence. 
14. Restart the computer to complete the installation. 

Additional Information 
During the setup, the %temp% value is defined as the user %temp% of the person who runs the 
setup. In Windows, each user's C:\Documents and Settings\username\Local Settings\Temp is 
protected from other Windows users. Consequently, you must set the system environment 
variable TEMP value to a folder location where everyone has write access (that is, C:\Temp). 
For more information about editing system variables, see the MS Windows online 
documentation. 
If you installed the Piping Specification Remote Access Server feature during the setup, you 
must verify that the COM+ application is installed and configured on the administrator computer. 
For more information, see Configure the Piping Specification Remote Access Server Service 
(Vista and Windows 7) (on page 126) in the SmartPlant 3D Installation Guide. 



Setting Up the Client 
 

 
112 SmartPlant 3D Installation Guide 

 

You can install the Database Interference Detection Service on a different computer. The 
Database Interference Detection Service requires that the optional Project Management and 
SmartPlant 3D Server Connectivity options be delivered. For more information, see Install 
Database Interference Detection Service (on page 154) in the SmartPlant 3D Installation Guide. 

See Also  
Loading Prerequisite Software on the Client (on page 100) 
Application Maintenance (on page 179) 
 

Install Service Packs 
Service Packs contain fixes for known application issues. You should install only those service 
packs that contain fixes that you need or if you are instructed to do so by Intergraph Support. 
Service pack installations contain only those parts of the application that have changed, and 
therefore, must be installed "on top" of a regular installation. 

 You must have administrative privileges on the computer to install the service pack. 
If you are running Windows Vista, you can use the Run as Administrator option. 
1. Exit all other applications running on your computer. 
2. Double-click the service pack's setup.exe file. 
3. If you are installing the service pack on the reference data server, select Reference Data 

Service Pack X Installation. 
-OR- 
If you are installing the service pack on a client workstation, select Service Pack X 
Installation. 

4. Click OK on the exit programs message. 
5. Click Install. 

 
6. If you want to create an uninstall program, click Yes. Otherwise, click No. If you choose not 

to create an uninstall program, you must remove the entire application to remove the service 
pack changes. 

7. Click OK to confirm the installation folder. This folder should be the same folder where you 
installed the regular installation. 
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You will see WinZip Self-Extractor windows appear as the service pack installs. 

 

See Also  
Loading Prerequisite Software on the Client (on page 100) 
Application Maintenance (on page 179) 
 

Configure for Large Model Drawing Generation 
When you are working with large models, especially in the Drawings and Reports task, we 
recommend that you enable the 3GB option for 32-bit operating systems and have 4GB or more 
RAM to improve drawing generation performance. While there is no hard and fast rule as to 
what constitutes a large model, we recommend that you enable the 3GB option if you are going 
to create drawings that contain more than 5,000 elements. That number can be lower if the 
drawing elements are complex. 

For Windows 7 and Vista 
Windows 7 and Windows Vista use the BCDedit.exe (Boot Configuration Data Editor) utility to 
make 3GB of RAM accessible for software on 32-bit Windows 7 and Windows Vista computers. 
This utility is run from a command window as an administrator. You do not need to run this utility 
for 64-bit versions of Windows 7 or Windows Vista. 
1. Click Start > All Programs > Accessories. 
2. Right-click on Command Prompt and select Run as Administrator. 
3. Click Continue when prompted by the User Account Control. 
4. Enable 3GB RAM mode by keying in: 

bcdedit /set IncreaseUserVa 3072 
Disable 3GB RAM mode by keying in: 
bcdedit /deletevalue IncreaseUserVa 

5. Restart your computer. 

For Windows XP 
You must have administrative privileges on the computer to modify the boot.ini file. 
1. Open the Control Panel and double-click System. 
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2. In the System Properties dialog box, select the Advanced tab. 

 
3. Click Settings under Startup and Recovery. 
4. On the Startup and Recovery tab, click Edit under System startup to open the boot.ini file 

in Notepad. 

 
5. In the [Operating Systems] section of the boot.ini file, add the following switch to the end of 

the startup line that includes the /fastdetect switch: /3GB: 
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[operating systems] 
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" 
/fastdetect /3GB 

6. Save the changes to the boot.ini file and close Notepad. 
7. Click OK two times to close the open dialog boxes, and then restart the computer for the 

changes to take effect. 
 

Configure for an Integrated Environment 
Configuring SmartPlant 3D to work in an integrated environment provides a platform for data 
exchange, sharing, and integration across various software tools, enabling concurrent use and 
rapid communication among all SmartPlant 3D project participants. Critical information is stored 
only once in a data-neutral warehouse, eliminating duplication and ensuring that timely, accurate 
data is always available. 
Two steps are required to take advantage of the SmartPlant integration functionality: 
1. Install the SmartPlant Client and Schema Component on your SmartPlant 3D workstation 

computers, as necessary. For more information about installing SmartPlant components, 
see the Integration Setup Guide, available in the SmartPlant Enterprise documentation set. 

 In order to take full advantage of the SmartPlant integration functionality, you 
must install the SmartPlant Client and Schema Component on a SmartPlant 3D workstation 
computer on which the Project Management, SmartPlant 3D Server Connectivity, and 
Piping Specification Remote Access Server options are installed. 

2. Use the Project Management task to register your SmartPlant 3D model. For more 
information about registering models, see the Project Management User's Guide, available 
from Help > Printable Guides in the SmartPlant 3D software. 

 
 

Register Solid Edge .DLL File 
While not a prerequisite, Solid Edge can be used with SmartPlant 3D. For optimum 
performance, install Solid Edge prior to running the SmartPlant 3D software setup. In the event 
that Solid Edge is installed after SmartPlant 3D, you will need to manually register the 
Pvdt80.ocx file. 
Additionally, if you uninstall or reinstall either SmartPlant 3D or Solid Edge from the workstation 
computer, use the steps outlined in the following procedure to manually register the Pvdt80.ocx 
file. 

 You must have administrator privileges for the workstation computer on which you 
wish to register the file. 
1. Open Windows Explorer. On the Windows task bar, right-click on Start and select Explore. 
2. Browse to [INSTALLDIR]\SmartPlant\3d\Core\Register and double-click 

RegisterPvtd80.vbs to register the Pvdt80.ocx file on your computer. 

See Also 
Third-Party Integration (on page 13) 
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Integrating with PDS 
To take advantage of the PDS integration functionality included with the software, PDS software 
is required. In addition to the standard PDS setup, an additional set of files external to PDS are 
also required. For information about installing the files you need to reference a PDS model in the 
software, see Install PDS Data Access (on page 117). For information about installing the files 
you need to export PDS model data into the software, see Install PDS Export Tools (on page 
116). 

 
 The SmartPlant 3D PDS Project Translators component that is required to support the 

export of PDS model data into the software is a separately licensed product. For licensing 
information, please contact Intergraph Support (http://support.intergraph.com/). 

 

Install PDS Export Tools 
Installing the PDS Export Tools component further extends the PDS integration capabilities by 
allowing you to export Piping, HVAC, Electrical, Equipment, and Structure model data from PDS 
into SmartPlant 3D. 
Before installing the PDS Export Tools component, you must install the following prerequisite 
software on a computer on which the Project Management and SmartPlant 3D Server 
Connectivity options are also installed: 
 Batch Services 
 RIS_Share (RIS Shared Components) 
 MicroStation 
 SmartPlant License Manager 
 PD_Shell (Plant Design System environment) 
For more information about acquiring these components, please contact Intergraph Support 
(http://www.intergraph.com/support). 

 The PDS Export Tools component is a separately licensed product. Before 
attempting to install the component, please contact Intergraph Support 
(http://www.intergraph.com/support) for licensing information. 
1. Log on to the computer with a user account that has administrator privileges. 
2. Insert the Intergraph Smart 3D Product DVD. 

 If the setup does not start automatically, double-click Setup.exe in the root folder of the 
DVD. 

3. Select Prerequisite Software. 
4. Select PDS Export Tools Installation. 
5. Click Continue on the Welcome page. 

 If the setup determines that PDS is not installed, an error message appears. Click OK. 
Install PD_Shell and then re-try this procedure. 

 For more information about exporting PDS model data into the software, see the 
Common User's Guide available with the Help > Printable Guides command in the software. 
 

http://support.intergraph.com/
http://www.intergraph.com/support
http://www.intergraph.com/support
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Install PDS Data Access 
SmartPlant 3D integrates with PDS version 2010 SE and higher, thereby extending your plant 
design capabilities. When you install the PDS data access setup files, you enable the software 
to communicate with PDS. As such, you can reference PDS design data in your model. You can 
also use the software to migrate piping specifications and associated catalog data from PDS, or 
directly translate PDS data into the software. 
You need to install the PDS Data Access component on the administration computer where you 
will use the Project Management task to reference the PDS project and on each client 
workstation that needs to reference the PDS project. 
Before installing the PDS Data Access component, you must install the following prerequisite 
software on a computer on which the Project Management and SmartPlant 3D Server 
Connectivity options are also installed: 
 Batch Services 
 RIS_Share (RIS Shared Components) 
 SmartPlant License Manager 
 PD_Shell (Plant Design System environment) 
If you are accessing PDS projects from the same computer, then you need to install SmartPlant 
License Manager along with the other PDS products as required. For more information about 
acquiring these components, please contact Intergraph Support 
(http://www.intergraph.com/support). 

Locate the Schema File 
1. Log on with a user account that has administrator privileges. 
2. Install RIS if you have not already done so. 
3. Click Start > All Programs > RISX.X > RIS Schema Manager. 
4. In the RIS Schema Manager dialog box, click Schema File. 
5. In the Schema File dialog box, click Locate Schema File. 
6. Define the location of your PDS project schema file. 
7. Click Apply. 
8. Click Close. 

Configure the Plant Design System Environment (PD_Shell) 
1. Log on with a user account that has administrator privileges. 
2. Install PD_Shell if you have not already done so. 
3. Click Start > All Programs > PD_Shell > PDS Configure. 
4. Click Modify. 
5. Type the Proj_File information for the PDS project. 
6. Type the Proj_Addr information for the PDS project. 
7. Click Continue. 
8. Click OK. 

Create Batch Queues 
1. Log on with a user account that has administrator privileges. 
2. Install Batch Services if you have not already done so. 

http://www.intergraph.com/support
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3. Click Start > All Programs > PD_Shell > PDS Queue. 
4. Create a batch queue for PD_Shell. 

Verify Access to the Project in PD_Shell 
1. Click Start > All Programs > PD_Shell > PD_Shell. 
2. Verify that the PDS project that you want to reference displays in the PD_Shell environment. 

If it is not available in the PD_Shell environment, you will not be able to reference it. 

Install PDS Data Access 
1. Log on with a user account that has administrator privileges. 
2. Insert the Intergraph Smart 3D Product DVD. 

 If the setup does not start automatically, double-click Setup.exe in the root folder of the 
DVD. 

3. Select Prerequisite Software. 
4. Select PDS Data Access Installation. 
5. Click Continue on the Welcome page. 
6. Click OK when the installation is complete. 
 

Install Smart 3D PDS Project Translators 
Installing the Smart 3D PDS Project Translators component further extends the PDS 
integration capabilities by allowing you to export Piping, HVAC, Electrical, Equipment, and 
Structure model data from PDS into SmartPlant 3D. 
Before installing the Smart 3D PDS Project Translators component, you must install the 
following prerequisite software on a computer on which the Project Management and 
SmartPlant 3D Server Connectivity options are also installed: 
 Batch Services 
 RIS_Share (RIS Shared Components) 
 MicroStation 
 SmartPlant License Manager 
 PD_Shell (Plant Design System environment) 
For more information about acquiring these components, please contact Intergraph Support 
(http://www.intergraph.com/support). 

 The Smart 3D PDS Project Translators component is a separately licensed 
product. Before attempting to install the component, please contact Intergraph Support 
(http://www.intergraph.com/support) for licensing information. 
1. Log on to the computer with a user account that has administrator privileges. 
2. Insert the Intergraph Smart 3D Product DVD. 

 If the setup does not start automatically, double-click Setup.exe in the root folder of the 
DVD. 

3. In the Smart 3D Installation wizard, click Data Converters.  
4. Click Smart 3D PDS Project Translators Installation. 
5. Click Next on the Welcome to the Smart 3D Project Translators Installation Wizard 

page. 
6. On the User Information page, enter information in the Full Name, Organization, and 

Serial number boxes. The serial number sticker is located on the DVD jewel case. 

http://www.intergraph.com/support
http://www.intergraph.com/support
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7. Click Next. 
8. On the Software License Agreement page, select your country from the list, and click 

Display to view the license agreement. 
 The license agreement is delivered as a PDF file; consequently, you must have 

Acrobat Reader installed on the client computer in order to view the license agreement. You 
can install Acrobat Reader from the Adobe web site, www.adobe.com. 

9. Carefully read the license agreement. Close the PDF document, and click Yes on the 
Software License Agreement page to accept the terms. 

10. On the Ready to Install the Application page, verify the installation summary. Click Back 
to return to any previous install pages and make changes. 

11. Click Next to begin installing the software. 
12. Click Finish to exit the installation sequence. 

 For more information about exporting PDS model data into the software, see the 
Common User's Guide available with the Help > Printable Guides command in the software. 
 

Integrating with SmartPlant P&ID 
To take full advantage of the software's SmartPlant P&ID integration functionality, we 
recommend that you install the Piping Specification Remote Access Server and Client setups. 
The remote access server setup is available as an option in the SmartPlant 3D Installation setup 
for the workstation computer. The remote access client is an available option with the 
SmartPlant P&ID product and is installed on a computer running SmartPlant P&ID. 
The Piping Specification utility works with PDS 3D or SmartPlant 3D to validate the piping 
materials class with the temperatures, pressures, and diameters assigned to the pipe run. The 
utility also searches commodity codes (in all 3D databases) and fabrication categories (in PDS 
3D databases only) for piping components. The database tables and library files in the 3D 
product provide source information for the validation and search. For more information about 
this utility, see the SmartPlant P&ID Remote Pipe Specification Access Quick Reference Guide, 
which is available in the Technical Notes and White Papers section on the eCustomer 
SmartPlant P&ID Customer Support Site 
http://crmweb.intergraph.com/ecustomer_enu/start.swe?SWEVI=&SWECmd=Refresh&SWERF
=1&SWEFullRefresh=1&TglPrtclRfrsh=1. 

 
 When installing the Piping Specification Remote Access Server component, you must also 

install the Bulkload Reference Data and the SmartPlant 3D Server Connectivity components 
as they are required for the Piping Specifications Remote Access Server to work. 

 In order to use SmartPlant 3D Piping Specification Remote Access you must perform 
additional installation and configuration on the computers running SmartPlant P&ID. See the 
Installing SmartPlant 3D Piping Specification Remote Access Client section in the 
SmartPlant P&ID Installation and Upgrade Guide for more information about installing the 
SmartPlant 3D Piping Specification Remote Access Client. Also, see the Piping Specification 
Utility section in the SmartPlant P&ID Utilities Guide for additional configuration information. 

 The "server" used by the SmartPlant 3D Piping Specification Remote Access Client and the 
SP3D P&ID Client Tester application is the computer on which the SmartPlant 3D Piping 
Specification Remote Access Server COM+ application has been installed and configured. 
This server can be different from the database server on which the Site database server and 
Site schema server reside. 

For more specific information about using the SmartPlant P&ID integration functionality included 
with the software, please contact Intergraph Support (http://www.intergraph.com/support). 

http://crmweb.intergraph.com/ecustomer_enu/start.swe?SWEVI=&SWECmd=Refresh&SWERF=1&SWEFullRefresh=1&TglPrtclRfrsh=1
http://crmweb.intergraph.com/ecustomer_enu/start.swe?SWEVI=&SWECmd=Refresh&SWERF=1&SWEFullRefresh=1&TglPrtclRfrsh=1
http://www.intergraph.com/support
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See Also 
Configure the Piping Specification Remote Access Server Service (XP Client) (on page " on 
page 126) 
Register the Site Database for P&ID Access (on page 134) 
 
 

Enable Network Access in Windows Server 2008 
The following procedures for enabling network access are required only if you are using 
Windows Server 2008 R2 (64-bit) on the computer. 

Enable COM+ Network Access 
1. Open the Control Panel. 
2. Click Turn Windows features on or off to open the Server Manager. 

3. On the Roles page in Server Manager, click  Add Roles. 
The Add Roles Wizard opens. 

4. Ensure that you have completed the preceding steps listed on the Before You Begin page, 
and click Next. 

5. On the Select Server Roles page, select Application Server and click Next. 
 If the server finds any of the required features for Application Server are missing, a 

prompt is displayed informing you to install those features. Click Add Required Features to 
allow the server to install them automatically. 

6. On the Application Server page, click Next. 
7. On the Select Role Services page, select COM+ Network Access, and click Next. 
8. Confirm your installation selections and click Install. 
9. After the installation is complete, click Close to exit the wizard. 

 If Application Server is already enabled on Windows Server 2008, follow these steps 
to enable COM+ Network Access: 

10. Open the Control Panel.  
11. Click Turn Windows features on or off to open the Server Manager. 
12. Click Roles > Application Server. 

13. In the Role Services section, click  Add Role Services. 
14. On the Select Role Services page, select COM+ Network Access, and click Install. 

Enable Network DTC Access 
1. Open Component Services by clicking Start > Administrative Tools > Component 

Services. 
2. In the console tree, expand Component Services > Computers > My Computer > 

Distributed Transaction Coordinator > Local DTC. 
3. Right-click Local DTC, and select Properties. 
4. In the Security tab of the Local DTC Properties dialog box, enable Network DTC Access, 

and click OK. 
An MSDTC Service message box is displayed. 

5. Click Yes to stop and restart the MSDTC service. 
6. Click Yes after the MSDTC service is restarted. 
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 If you have additional resource manager services that participate in the distributed 
transactions, you must stop and restart those services as well. 

See Also 
Instructions for Microsoft Windows Server 2008 (on page 39) 
 
 

Configure the Piping Specification Remote Access Server 
Service (XP Client) 

In order to take full advantage of the SmartPlant P&ID integration tools available with the 
software, we recommend that the Piping Specification Remote Access Server service be 
installed and properly configured on the system on which SmartPlant 3D has been installed. 
Perform the following steps to verify and, if necessary, manually install and configure the COM+ 
application. 

 
 You must have administrator privileges on the workstation computer in order to perform this 

installation procedure. 
 The Piping Specification Remote Access Server service is installed as part of the 

SmartPlant 3D Installation setup. You must also install the Bulkload Reference Data and the 
SmartPlant 3D Server Connectivity components as they are required for the Piping 
Specifications Remote Access Server to work. For more information, see Install Smart 3D 
Client Software (on page 109). 

 The computer on which you have installed the Piping Specification Remote Access Server 
becomes a "server" for SmartPlant P&ID clients and therefore must be powered on and 
available whenever P&ID needs to access the catalog. For example, you could use the 
computer that is used for the Interference Checking service. 

Verify SP3D Piping Specification Remote Access Server Service 
1. Open the Control Panel and double-click Administrative Tools. 
2. In the Administrative Tools window, double-click Component Services to start the 

component services Microsoft Management Console (MMC) snap-in. The Component 
Services window appears as shown in the following illustration: 
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3. Expand the Component Services node under the Console Root, and then expand the 
Computers and My Computer nodes. 

 
4. Expand the COM+ Applications node. 
5. Verify the SP3DPipingSpecRemoteAccessServer icon appears under COM+ Applications. 

If it exists, skip to step 15. If it does not exist, perform steps 6-14 to install and configure the 
COM+ application. 

 
6. Select Com+ Applications under the My Computer node, and then click Action >New > 

Application on the horizontal toolbar. The COM+ Application Install Wizard displays. 
7. Click Next on the Welcome to the COM Application Install Wizard page. 
8. Select Create an empty application on the Install or Create a New Application page. 
9. On the Create an Empty Application page, type SP3DPipingSpecRemoteAccessServer 

in the Enter a name for the new application text box. 
10. Select Server application in the Activation type field, and then click Next. 
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11. On the Set Application Identity page, verify that This user is selected, and enter the user 
name and password to set the proper identity under which the COM+ application will run on 
the computer. 

 You must specify an account with Windows administrative privileges on the 
computer. 

12. Click Next. 
13. Click Finish to begin the installation. 

 When installation is complete, a SP3DPipingSpecRemoteAccessServer.1 node is 
placed under COM+ Applications. 

 
14. In the left tree view, right-click SP3DPipingSpecRemoteAccessServer and select 

Properties. 
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15. On the Advanced tab of the SP3DPipingSpecRemoteAccessServer Properties dialog 
box, change the Minutes until idle shutdown value to 0. 
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16. On the Security tab, disable Enforce access checks for this application and click OK. 

 
17. Next, expand the SP3DPipingSpecRemoteAccessServer and the Components nodes. 
18. Under the Components node, verify that the 

SP3DRefDataMiddleTierService.RefdataMiddle.1 component appears. If it does exist, you 
are finished with this procedure. If it does not exist, perform steps 19-22. 

19. On the horizontal toolbar, click Action > New > Component. The COM Component 
Installation Wizard appears. 

20. Click Next on the Welcome to the COM Component Install Wizard. 
21. On the Import or Install a Component page, select Install new component(s) and 

browse for SP3DRefDataMiddleTierService.dll. 
 The component SP3DRefDataMiddleTierService.dll is located in [Product 

Folder]\RefData\Middle\Bin. 
22. Click Next on the Install new components page, then click Finish to complete the 

installation procedure. 
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23. The Component Services window shows the 
SP3DRefDataMiddleTierService.RefdataMiddle.1 component installed in the 
SP3DPipingSpecRemoteAccessServer application. 

 

See Also  
Integrating with SmartPlant P&ID (on page 119) 
 

Configure the Piping Specification Remote Access Server 
Service (Vista and Windows 7) 

In order to take full advantage of the SmartPlant P&ID integration tools available with the 
software, we recommend that the Piping Specification Remote Access Server service be 
installed and properly configured on the system on which SmartPlant 3D has been installed. 
Perform the following steps to verify and, if necessary, manually install and configure the COM+ 
application. 

  
 You must have administrator privileges on the workstation computer in order to perform this 

installation procedure. 
 The Piping Specification Remote Access Server service is installed as part of the 

SmartPlant 3D Installation setup. You must also install the Bulkload Reference Data and the 
SmartPlant 3D Server Connectivity components as they are required for the Piping 
Specifications Remote Access Server to work. For more information, see Install Smart 3D 
Client Software (on page 109). 

 The computer on which you have installed the Piping Specification Remote Access Server 
becomes a "server" for SmartPlant P&ID clients and therefore must be powered on and 
available whenever P&ID needs to access the catalog. For example, you could use the 
computer that is used for the Interference Checking service. 
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Verify SP3D Piping Specification Remote Access Server Service 
1. Click Start > All Programs > Accessories > Run. 
2. Type dcomcnfg, and click OK. The Component Services window appears as shown in the 

following illustration: 

 
3. Expand the Component Services node under the Console Root, and then expand the 

Computer and My Computer nodes. 

 
4. Expand the COM+ Applications node. 
5. Verify the SP3DPipingSpecRemoteAccessServer icon appears under COM+ Applications. 

If it exists, skip to step 17. If it does not exist, perform steps 6-14 to install and configure the 
COM+ application. 
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6. Select COM+ Applications under the My Computer node, and then click Action > New > 
Application on the horizontal toolbar. The COM+ Application Install Wizard displays. 

7. Click Next on the Welcome to the COM Application Install Wizard page. 
8. Select Create an empty application on the Install or Create a New Application page. 
9. On the Create an Empty Application page, type SP3DPipingSpecRemoteAccessServer 

in the Enter a name for the new application text box. 
10. Select Server application in the Activation type field, and then click Next. 
11. On the Set Application Identity page, verify that This user is selected, and enter user 

name and password to set the proper identity under which the COM+ application will run on 
the computer. 

 You must specify an account with Windows administrative privileges on the 
computer. 

12. Click Next. 
13. Select CreatorOwner on the Add Application Roles page, and click Next. 
14. On the Add Users to Roles page, add any additional users that may need access to this 

application, and click Next. 
15. Click Finish to begin the installation. 

 When the installation is complete, a SP3DPipingSpecRemoteAccessServer node is 
placed under COM+ Applications. 

 
16. In the left tree view, right-click SP3DPipingSpecRemoteAccessServer and select 

Properties. 
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17. On the Advanced tab of the SP3DPipingSpecRemoteAccessServer dialog box, select 
Enable idle shutdown and change the Minutes value to 0. 

 
18. On the Security tab, disable Enforce access checks for this application and click OK. 

 
19. Next, expand the SP3DPipingSpecRemoteAccessServer and the Components nodes. 
20. Under the Components node, verify that the 

SP3DRefDataMiddleTierService.RefdataMiddle.1 component appears. If it does exist, you 
are finished with this procedure. If it does not exist, perform steps 21-25. 

21. On the horizontal toolbar, click Action > New > Component. The COM Component 
Installation Wizard appears. 

22. Click Next on the Welcome to the COM Component Install Wizard. 
23. On the Import or Install a Component page, select Install new component(s) and 

browse for SP3DRefDataMiddleTierService.dll. 
 The component SP3DRefDataMiddleTierService.dll is located in [Product 

Folder]\RefData\Middle\Bin. 
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24. Click Next on the Install new components page, then click Finish to complete the 
installation procedure. 

25. The Component Services window shows the 
SP3DRefDataMiddleTierService.RefdataMiddle.1 component installed in the 
SP3DPipingSpecRemoteAccessServer application. 

See Also 
Integrating with SmartPlant P&ID (on page 119) 
 

File Server Sizing 
You will need a computer to act as a file server with enough disk space for symbols and files. 
This computer does not need to be a high end-server, but should meet the minimum hardware 
requirements for a client computer. See SmartPlant 3D Workstation Recommendations (on 
page 22) for these requirements. 
 
 

Configure the Piping Specification Remote Access Server 
Service (Vista and Windows 7) 

In order to take full advantage of the SmartPlant P&ID integration tools available with the 
software, we recommend that the Piping Specification Remote Access Server service be 
installed and properly configured on the system on which SmartPlant 3D has been installed. 
Perform the following steps to verify and, if necessary, manually install and configure the COM+ 
application. 

  
 You must have administrator privileges on the workstation computer in order to perform this 

installation procedure. 
 The Piping Specification Remote Access Server service is installed as part of the 

SmartPlant 3D Installation setup. You must also install the Bulkload Reference Data and the 
SmartPlant 3D Server Connectivity components as they are required for the Piping 
Specifications Remote Access Server to work. For more information, see Install Smart 3D 
Client Software (on page 109). 

 The computer on which you have installed the Piping Specification Remote Access Server 
becomes a "server" for SmartPlant P&ID clients and therefore must be powered on and 
available whenever P&ID needs to access the catalog. For example, you could use the 
computer that is used for the Interference Checking service. 

Verify SP3D Piping Specification Remote Access Server Service 
1. Click Start > All Programs > Accessories > Run. 
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2. Type dcomcnfg, and click OK. The Component Services window appears as shown in the 
following illustration: 

 
3. Expand the Component Services node under the Console Root, and then expand the 

Computer and My Computer nodes. 

 
4. Expand the COM+ Applications node. 
5. Verify the SP3DPipingSpecRemoteAccessServer icon appears under COM+ Applications. 

If it exists, skip to step 17. If it does not exist, perform steps 6-14 to install and configure the 
COM+ application. 

 
6. Select COM+ Applications under the My Computer node, and then click Action > New > 

Application on the horizontal toolbar. The COM+ Application Install Wizard displays. 
7. Click Next on the Welcome to the COM Application Install Wizard page. 
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8. Select Create an empty application on the Install or Create a New Application page. 
9. On the Create an Empty Application page, type SP3DPipingSpecRemoteAccessServer 

in the Enter a name for the new application text box. 
10. Select Server application in the Activation type field, and then click Next. 
11. On the Set Application Identity page, verify that This user is selected, and enter user 

name and password to set the proper identity under which the COM+ application will run on 
the computer. 

 You must specify an account with Windows administrative privileges on the 
computer. 

12. Click Next. 
13. Select CreatorOwner on the Add Application Roles page, and click Next. 
14. On the Add Users to Roles page, add any additional users that may need access to this 

application, and click Next. 
15. Click Finish to begin the installation. 

 When the installation is complete, a SP3DPipingSpecRemoteAccessServer node is 
placed under COM+ Applications. 

 
16. In the left tree view, right-click SP3DPipingSpecRemoteAccessServer and select 

Properties. 
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17. On the Advanced tab of the SP3DPipingSpecRemoteAccessServer dialog box, select 
Enable idle shutdown and change the Minutes value to 0. 

 
18. On the Security tab, disable Enforce access checks for this application and click OK. 

 
19. Next, expand the SP3DPipingSpecRemoteAccessServer and the Components nodes. 
20. Under the Components node, verify that the 

SP3DRefDataMiddleTierService.RefdataMiddle.1 component appears. If it does exist, you 
are finished with this procedure. If it does not exist, perform steps 21-25. 

21. On the horizontal toolbar, click Action > New > Component. The COM Component 
Installation Wizard appears. 

22. Click Next on the Welcome to the COM Component Install Wizard. 
23. On the Import or Install a Component page, select Install new component(s) and 

browse for SP3DRefDataMiddleTierService.dll. 
 The component SP3DRefDataMiddleTierService.dll is located in [Product 

Folder]\RefData\Middle\Bin. 
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24. Click Next on the Install new components page, then click Finish to complete the 
installation procedure. 

25. The Component Services window shows the 
SP3DRefDataMiddleTierService.RefdataMiddle.1 component installed in the 
SP3DPipingSpecRemoteAccessServer application. 

See Also 
Integrating with SmartPlant P&ID (on page 119) 
 

Register the Site Database for P&ID Access 
Before you complete the steps in this procedure, you must install the SP3D Piping Specification 
Remote Access Server service and configure the COM+ application. For more information, see 
Install Smart 3D Client Software (on page 109). 
You must have administrator privileges on the computer in order to perform this installation 
procedure. 
1. Click Start > Run, and then click Browse in the Run dialog box. 
2. Navigate to [Product Folder]\RefData\Tools\Bin\SetSiteForPIDAccess.exe, and click OK. 

 
3. Click OK in the Run dialog box. 
4. In the Set Site Database for Piping Spec Remote Access dialog box, enter the 

SmartPlant 3D Site and Site schema database names and servers in the appropriate fields. 

 
5. Click OK. 

 
 In order to use SmartPlant 3D Piping Specification Remote Access you must perform 

additional installation and configuration on the computers running SmartPlant P&ID. See the 
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Installing SmartPlant 3D Piping Specification Remote Access Client section in the 
SmartPlant P&ID Installation and Upgrade Guide for more information about installing the 
SmartPlant 3D Piping Specification Remote Access Client. Also, see the Piping Specification 
Utility section in the SmartPlant P&ID Utilities Guide for additional configuration information. 

 The "server" used by the SmartPlant 3D Piping Specification Remote Access Client and the 
SP3D P&ID Client Tester application is the computer on which the SmartPlant 3D Piping 
Specification Remote Access Server COM+ application has been installed and configured. 
This server can be different from the database server on which the Site database server and 
Site schema server reside. 

See Also  
Integrating with SmartPlant P&ID (on page 119) 
 

Integrating with SmartPlant Reference Data 
If you plan to integrate with SmartPlant Reference Data (SPRD), you will need to install the 
SmartPlant Reference Data Client. SmartPlant Reference Data (SPRD) is licensed separately 
from SmartPlant 3D and is delivered on separate media. 
Less than a megabyte of hard disk space is required to load the SmartPlant Reference Data 
Client software. 
1. Insert the SmartPlant Reference Data delivery media. If the setup does not start 

automatically, double-click Browser.exe in the root folder. 
2. Click SmartPlant Reference Data (.NET) Installation on the SmartPlant Enterprise 

Materials page. 
3. Click SmartPlant Reference Data (.NET) Client Installation on the SmartPlant 

Enterprise Reference Data page. 
SmartPlant Reference Data Client installs. 

4. After the installation is complete, you must enter your login credentials for SmartPlant 
Reference Data Client. 

5. You can either use an existing login from the Current Logins tab, or you can create a new 
login from the New Login tab. 

For more information, see the SmartPlant Reference Data Installation Guide (.NET) available on 
the SmartPlant Enterprise Reference Data installation page. 
 

Viewing 3D Model Data 
You can output 3D model data as SmartPlant Review files or CAD (SAT) files through the 
Drawings and Reports task. In order to use this functionality, you must install the SmartPlant 
Schema Component on the local workstation computer. For more information on installing this 
component, see Install SmartPlant Schema Component (on page 136). 
For more information on creating 3D model data, see the Orthographic Drawings User's Guide 
available from Help > Printable Guides in the software. 

See Also 
Install SmartPlant Schema Component (on page 136) 
 



Setting Up the Client 
 

 
136 SmartPlant 3D Installation Guide 

 

Install SmartPlant Schema Component 
The SmartPlant Schema Component allows you to save your 3D model data as a graphics file in 
VUE format (.vue) in the Drawings and Reports task so that it can be viewed using SmartPlant 
Review. For more information on creating 3D model data output, see the Orthographic Drawings 
User's Guide available from Help > Printable Guides command in the software. 

 Before you install the SmartPlant Schema Component, you must use log on to the 
workstation computer with a user account that has administrator privileges. 
1. Insert the Intergraph SmartPlant 3D Product CD. 

 If the CD does not start automatically, double-click Setup.exe in the root folder of the 
CD. 

2. Select Prerequisite Software. 
3. Select SmartPlant Schema Component Installation. 
4. Click Next on the Welcome to SmartPlant Schema Component Setup page. 
5. Click Next on the Select Optional Features page. 
6. On the Select Program Folder page, click Next to begin installing the schema component. 
7. Click Finish when installation completes. 

See Also  
Viewing 3D Model Data (on page 135) 
 

Using Programming Resources 
The Programming Resources component provides developers with the tools necessary to 
customize the software by creating custom commands or custom programs. Before attempting 
to create commands or programs, you should be very familiar with SmartPlant 3D interactively 
and understand its basic concepts of Projects, engineering, architecture, concurrency, and 
datastores, including the following: 
 Microsoft Visual Basic (6.0 or later) at an advanced level, developing client and server 

systems and interfaces, and using Automation (C++ is not a requirement). Although any 
COM-compliant development platform can be used to interact with the software, Visual 
Basic is the preferred language because of its simplicity. 

 Unified Modeling Language® (UML)®. UML is a popular method used to represent 
object-oriented data models. A brief overview of UML describes its relationship to the 
SmartPlant 3D data model. 

 Basic understanding of SmartPlant 3D functionality. If you want to develop a command that 
performs placement of a vessel, you need to understand how to place the vessel 
interactively by using the software. 

 Architecture. SmartPlant 3D software has an architecture that is component-oriented and 
built on three tiers. 

 Basic understanding of relational databases. Making the software task-oriented, SmartPlant 
3D uses one datastore. 

 Engineering and project knowledge. 
The default installation of the Programming Resources component includes online 
documentation, sample code, and installation wizards that add tools to Visual Basic menus to 
help make commands. The following features are available with the Programming Resources 
component: 
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 Command Wizard - Provides tools and methods for a new Visual Basic project and build a 
basic command based on those selected requirements. 

 For more specific information about creating commands using the SmartPlant 
3D application programming interface (API), contact Intergraph Support 
(http://www.intergraph.com/support). 

 Symbol Wizard - Creates and customizes three-dimensional symbols that fit your company 
or project. The wizard produces a Visual Basic project for building the symbol ports and 
graphics, and generates an Excel workbook for bulk loading the symbol data into the 
Catalog database. Included with the Symbol Wizard, is a Visual Basic add-in called the 
Equipment Symbol Upgrade Wizard. This wizard allows you to upgrade SmartPlant 3D 
version 5.0 Equipment symbols to Smart Occurrence-based equipment symbols. 

 References Helper - Locates and references type libraries quickly and easily. The ability to 
reference a type library with this tool saves valuable time otherwise required when searching 
via Project > References in your Visual Basic project. 

 Programming Help - Installs the Programming Help online documentation on the local 
computer. 

 Example Code - Provides source code necessary for creating custom Visual Basic 
commands for SmartPlant 3D.  

 Debug Code for Task Host - Runs your SmartPlant 3D Visual Basic project in debug 
mode. 

 .NET Programming - Installs .NET programming help and examples. 
 In order to register and display the .NET documentation delivered with .NET 

Programming, you must have the Microsoft Document Explorer installed. This module is 
automatically installed when you install any version of Visual Studio.  

 3D Schema Browser - Displays the metadata and the relationships in the software. 
For information about installing the Programming Resources component, see Install 
Programming Resources (on page 137). 

See Also 
Install the SmartPlant 3D Command Wizard (on page 139) 
Install the SmartPlant 3D Symbol/Part Definition Wizard (on page 139) 
 

Install Programming Resources 
Before installing the Programming Resources component, verify that the SmartPlant 3D 
software is installed on the workstation computer. For specific installation guidelines, see Install 
Smart 3D Client Software (on page 109). 
Approximately 270 MB of hard disk space is required to perform a complete installation of the 
Programming Resources component. Before proceeding, verify that enough disk space is 
available on the workstation computer. 
Several of the tools delivered with the Programming Resources component operate within the 
Visual Basic environment as an add-in; consequently, Microsoft Visual Basic 6.0 with Visual 
Studio Service Pack 5 is required to execute these tools. 
1. Insert the Intergraph Smart 3D Product DVD. 

 If the installation does not start automatically, double-click setup.exe in the main DVD 
folder. 

2. Select Smart 3D Programming Resources Installation. 
3. On the Welcome to the Intergraph Smart 3D Programming Resources Installation 

Wizard page, click Next. 

http://www.intergraph.com/support
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4. On the User Information page, enter text in the Full Name and Organization boxes, and 
then click Next. 

5. On the Software License Agreement page, select your country from the list and click 
Display to view the license agreement. 

 The license agreement is delivered as a PDF file; consequently, you must have 
Acrobat Reader installed on the workstation computer to view the license agreement. If the 
software detects that Acrobat Reader is not installed, a message box appears. To install 
Acrobat Reader, visit the Adobe web site, www.adobe.com. 

6. Carefully read the license agreement. Close the PDF document and click Yes on the 
Software License Agreement page to accept the terms. 

7. On the Select Features page, select the features you want to install. 

 
8. Click Browse and select the folder location for the selected features, and then click OK. 
9. Click Next. 
10. On the Ready to Install the Application page, click Next. 
11. When installation is complete, click Finish. 

 
 During installation of the Programming Resources component, the References Helper 

feature (if selected in step 7) is registered on the local computer and can be accessed via 
the Add-Ins > Add- In Manager command in the Visual Basic application. 

 In order to register and display the .NET documentation delivered with .NET Programming, 
you must have the Microsoft Document Explorer installed. This module is automatically 
installed when you install any version of Visual Studio. 

 If you select the 3D Schema Browser feature in step 7, the software delivers it to [Product 
Folder]:\SmartPlant\3D\Programming\Tools\Bin. 

 The online documentation for Programming Resources can be accessed via Start > 
Programs > Intergraph SmartPlant 3D > Programming Help. 
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 For information about accessing the sample code, contact Intergraph Support 
(http://www.intergraph.com/support). 

See Also  
Using Programming Resources (on page 136) 
 

Install the SmartPlant 3D Command Wizard 
The SmartPlant 3D Command Wizard is available only as a feature with the Programming 
Resources component. For more information about Programming Resources, see Using 
Programming Resources (on page 136). 
To install the wizard, you must have administrator privileges on the client computer. 
1. On a workstation computer, double-click SP3DCommandWizardV2.EXE in the [Product 

Folder:\SmartPlant\3D\Programming\Tools\CommandWizard folder. 
2. On the Welcome page, click Next. 
3. On the Destination Folder page, click Next to install the SmartPlant 3D Command Wizard 

in the default installation folder. 
 Click Browse to navigate to another installation location and then click OK. 

4. On the Ready to Install the Application page, click Next. 
5. After the wizard has successfully installed, click Finish. 

 During installation, the software registers the Command Wizard on the client computer. 
The wizard can be accessed from the Add-Ins menu in the Visual Basic application. 

See Also  
Using Programming Resources (on page 136) 
 

Install the SmartPlant 3D Symbol/Part Definition Wizard 
The SmartPlant 3D Symbol/Part Definition Wizard is available only as a feature with the 
Programming Resources component. For more information about Programming Resources, see 
Using Programming Resources (on page 136). 
To install the wizard, you must have administrator privileges on the client computer. 
1. On a workstation computer, double-click setup.exe in the folder [Product 

Folder:\SmartPlant\3D\Programming\Tools\SymbolWizard. 
2. On the SmartPlant 3D Part Definition Wizard Setup page, click OK. 

http://www.intergraph.com/support
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3. If the default installation folder is acceptable, click the installation button. Otherwise, click 
Change Directory, browse to another installation folder, and click OK. 

 
4. Click OK after the wizard has successfully installed. 

 
 During installation, the software registers the wizard on the client computer. The wizard 

can be accessed from the Add-Ins menu in the Visual Basic application. 
 A Visual Basic add-in called the Equipment Symbol Upgrade Wizard is also delivered 

during installation of the SmartPlant 3D Symbol/Part Definition Wizard. The Equipment 
Symbol Upgrade Wizard allows you to upgrade SmartPlant 3D version 5.0 Equipment 
symbols to Smart Occurrence-based Equipment symbols. For more information about 
registering and launching the Equipment Symbol Upgrade Wizard, see the SmartPlant 
3D/SmartMarine 3D Programmer's Guide available from Help > Printable Guides in the 
software. 

See Also  
Using Programming Resources (on page 136) 
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You must have the server components from Microsoft SQL Server 2008 SP3 installed on the 
server in order to create the databases. The server components are installed on the server by 
default when following the procedure outlined in Install Microsoft SQL Server 2008 (on page 44). 

 Administrative privileges are required for the following utilities to run correctly and 
for you to change the necessary items. 

Understanding the Databases 
SmartPlant 3D uses seven databases: Catalog, Catalog Schema, Model, Site, Site Schema, 
Reports, and Reports Schema. These databases must be created before running SmartPlant 
3D. 
The Catalog database contains reference data, which includes part dimensions and industry 
standards. The Catalog database contains the non-graphical information derived from the 
reference data (in the form of Excel workbooks) delivered with the software. You can modify the 
delivered reference data by editing and bulk loading Excel workbooks. You also can use your 
own custom Excel workbooks and custom symbols, to create a new Catalog database 
specifically for your project. For more information about customizing the delivered reference 
data, refer to the SmartPlant 3D Reference Data Guide available from Help > Printable Guides. 
You can create a starting Catalog database and schema using the database template file 
delivered with the software. The CatalogDB.dat file is a backup of an already complete Catalog 
database and contains the definition of a default catalog of objects, including specific sizes of 
pipes, pipe specifications, steel section sizes, and so forth. Once the Catalog database is 
created, you can then bulk load your customized piping specifications into the Catalog database 
as needed. For more information about creating the required Catalog database for SQL, see 
Create the Site, Catalog, and Schema Databases for SQL (on page 143).  If you are using 
Oracle, see Create the Site, Catalog, and Schema Databases for Oracle (on page 147). 
The Model database contains all instances of parts in the physical representation of the model. 
The Catalog and Model databases share the same schema. A Plant is all three databases used 
together: Catalog database, Catalog schema database, and Model database. 
The Site database and schema are containers for the other databases. The Site database 
stores work-breakdown and user access for the model. A Site database can have multiple 
Model and Catalog databases. Typically, there is one Site database set for each customer 
location. For information about Site databases, see the Project Management User's Guide 
available from Help > Printable Guides. 
The Reports database and schema interact with the other five databases to generate tabular 
reports from SmartPlant 3D data. For information about reports, see the Reports User's Guide 
and Drawings and Reports Reference Data Guide available from Help > Printable Guides. 
The Catalog contains two hierarchies. The first is a Site database hierarchy made up of catalog 
permission group folders and permission groups. To view the Site database hierarchy for the 
Catalog, start the Project Management task. The second hierarchy is an object hierarchy made 
up of equipment, piping, and so forth. To view the hierarchy and its contents, start the Catalog 
task. For more information about the functionality in these tasks, refer to the Project 
Management Help and the Catalog Help files. These help files are delivered in [Operating 
System drive where Product is installed]:\Program Files \Common 
Files\Intergraph\SmartPlant\Help on the workstation computer. 

Configuring the Databases 
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For creation date and size information on each database, you can open the SQL Server 
Enterprise Manager. This software also provides further technical details about the relational 
tables in each database. 
The following illustration shows the relationships of the databases: 

 
(A) - Reports Database 
(B) - Site Database 
(C) - Model Database 
(D) - Catalog Database 
(E) - Site Schema 
(F) - Catalog Schema 
(G) - Reports Schema 
These databases are created on a central server using the Database Wizard on a workstation 
computer on which the Project Management and SmartPlant 3D Server Connectivity options 
are installed. 

Using Linked Servers 
If your Site/Catalog/Model database server is different from your Reports database server, you 
can use linked servers for communication between the data sources. However, if linked servers 
are not configured correctly, the login can fail when you run queries against the linked server. 
For linked servers to work correctly, ensure that the following conditions exist: 
 The database link is created on the Site/Catalog/Model database server, not the Reports 

database server. 
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 The linked database server supports Windows Authentication Mode. 
 The user is connected to SQL Server using Windows Authentication Mode on both database 

servers. 
 Security account delegation is available on the client and the sending server. 
For more information about setting up linked servers, see the Microsoft SQL Server 
documentation. 

See Also 
Create the Site, Catalog, and Schema Databases for SQL (on page 143) 
Create the Site, Catalog, and Schema Databases for Oracle (on page 147) 
Assign Access Permissions (on page 152) 
 

Upgrading Databases 
If you need to upgrade the databases from a previous version to the current version, you must 
have the Project Management and SmartPlant 3D Server Connectivity options installed. 
Upgrading your older databases to the latest installed version of the software involves several 
different upgrade tasks. For more information, see the Project Management User's Guide 
available from Help > Printable Guides in the software. 

 It is only possible to upgrade a Plant configuration using the same database type. It is 
not possible to upgrade, for example, a Version 2009.1 configuration on a Microsoft SQL Server 
database to a Version 2011 configuration on an Oracle database. 

See Also  
Configuring the Databases (on page 141) 
 
 

Create the Site, Catalog, and Schema Databases for 
SQL 

This procedure is for Microsoft SQL Server 2008 SP3 databases. Site and Catalog database 
creation requires that you install the Project Management and SmartPlant 3D Server 
Connectivity components. 
You must have the appropriate server components from Microsoft SQL Server installed on the 
server computer in order to create the databases. The user login used to create the databases 
must be part of the Administrators group on the local computer and the database server. Other 
users do not need to be part of the Administrators group on the local computer in order to run 
the product. 
1. Open the Database Wizard. 
2. Select Create a new site, and then click Next. 
3. On the Create Site Database and Schema page, select MSSQL from the Database type 

list. 
4. Next, select the name of the server in the Site database server list on which your Site 

database will reside. 
 Only registered SQL Servers appear in the Site database server list. 

5. Enter the name of your Site database in the Site database name text box. Include the type 
of database in the name you type. For example, type Model1SiteDB. 



Configuring the Databases 
 

 
144 SmartPlant 3D Installation Guide 

 

 When you name the Site database, the Site schema server and Site schema name 
default to match the Site database server and name. 

6. Enter the workshare location for the Site database in the Site database workshare 
location text box. You can use any string that represents your physical location. 

 This location is the location of the host Site database and is required even if the host 
is not going to be replicated for worksharing purposes. During generation of the Site 
database, the software creates a location object and associates it with the Site database. 

7. Enter a name rule ID in the Name rule ID text box. By default, the software leaves this field 
blank. You can enter any string identifier, numeric or alpha. 

 The Name Generator Service that runs on the server computer you specify in the 
Name generator server for site box (step 8) supplies unique names to items placed in the 
Plant (Model database). In a replicated configuration, there are multiple servers and multiple 
instances of the Name Generator Service running at each location; consequently, there is 
no way to ensure unique and sequential naming of placed objects. The value entered in the 
Name rule ID text box functions as a substring (an internal ID number) that represents the 
location at which an item is placed into the replicated model. 

8. Enter the name of the server computer on which the Name Generator Service is configured 
in the Name generator server for site box. 

 A name server must be a valid computer running on the Windows domain and one 
that has been properly configured to run as a name server. 

9. Use the default paths for the site database files in the Physical database and Log file 
boxes. 

10. Select the button to the right of the Template file to be used to create site schema text 
box and browse for the name of the template file (AppRepos.dat) the software uses when 
creating your Site schema database. The location of the file is on the server computer in 
[Product Folder]\DatabaseTemplates. 

11. Click Next. 
12. On the Catalog Database and Schema page, select the name of the server in the Catalog 

database server list on which your Catalog database will reside. 

  
 The option control at the top of the page allows you either to create a new Catalog 

database by restoring a backup or to use an existing Catalog database. If you choose to 
create a new Catalog database using the Restore option, the wizard will restore the 
.DAT file specified in the Template file to be used to create the Catalog database 
and schema field. The software delivers one selection for this field, CatalogDB.dat. The 
default is to Restore catalog from backup. If you select Use existing catalog, then no 
further options are available. 

 If you intend to create a custom catalog, select the Use existing catalog and use the 
Bulkload utility delivered with the product. Alternately, you can customize your catalog 
data using the Catalog task. 

13. Enter the name of your catalog database in the Catalog database name box. This step also 
automatically populates the name of your Catalog schema database in the Catalog schema 
name text box. 

14. Use the default paths for the catalog database files in the Physical database and Log file 
boxes. 
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15. Select the ellipsis button to the right of the Symbol and custom program file folder box, 
and browse for and select the SharedContent share on the SmartPlant 3D reference data 
computer. 

 
 The SharedContent share is created automatically on the reference data computer 

during the SmartPlant 3D Reference Data installation. 
 The path in the Symbol and custom program file folder box must be a UNC path. To 

obtain a UNC path, click the ellipsis button and browse under My Network Places, not 
under My Computer. 

16. Select the ellipsis button to the right of the Template file to be used to create catalog 
database and schema text box and browse for the name of the template file 
(CatalogDB.dat) you want the software to use when creating your Catalog and schema 
databases. The location of the file is on the database server computer in [Reference Data 
Product Folder]\DatabaseTemplates. 

 If you are installing the Materials Handling software, the path for the MHE catalog is 
[ReferenceData]\MaterialsHandling\DatabaseTemplates. 

17. Click Next. 
18. On the Ready to Create Databases page, click Create DB to create your databases. 
19. When the Database Wizard displays the database names that you entered, click Finish. 

 You must name the databases with unique entries. 

See Also  
Configuring the Databases (on page 141) 

Create the Model and Reports Databases for SQL 
Model and Reports database creation requires that the Project Management and SmartPlant 
3D Server Connectivity options be installed. 
1. Open the Project Management task. 
2. Click the Plant icon in the Project Management tree view, and then click Database > New 

> Plant. 
3. On the General tab of the New Plant dialog box, select the Value cell in the Name row, and 

enter a model name, such as Model1. 

 
4. In the Value cell in the Description row, enter a description, such as Model Number 1. 
5. In the Value cell in the Site row, enter a site description, such as Huntsville. 
6. In the Value cell in the Owner row, enter an owner description, such as XYZ Group. 
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7. On the Databases tab, click in the cell under Type, and select Catalog in the list. 

 
8. Click in the DB Provider cell for the Catalog database, and select MSSQL from the list. 
9. Click in the Server cell for the Catalog database, and select the server on which the Catalog 

database resides. 
10. Click in the Name cell for the Catalog database, and select the Catalog database name that 

you created earlier. 
11. In the second row, click the cell in the Type column, and select Model in the list. The 

software automatically populates the Name field with the name of the new Model database. 
12. Click in the DB Provider cell for the Model database, and select MSSQL from the list. 
13. Click in the Server cell for the Model database, and select the server on which the Model 

database will reside. 
14. In the third row, click the cell in the Type column, and select Reports in the list. The 

software automatically populates the Name field with the name of the new Reports 
database. 

15. Click in the DB Provider cell for the Reports database, and select MSSQL from the list. 
16. Click in the Server cell for the Reports database, and select the server on which the Reports 

database will reside. 
17. In the Name generator server for model box, specify the server on which the Name 

Generator Service is installed. 
 A name server must be a valid computer running on the Windows domain and one 

that has been properly configured to run as a name server. For more information about 
installing and configuring the Name Generator service, see the Installing the Name 
Generator Service (on page 71). 

18. Specify the path for location of the model database files in the Physical database and Log 
file boxes. 

19. Click OK on the New Plant dialog box. Wait for the process to complete. Icons for the new 
Plant and its associated Catalog database appear in the tree view of the Project 
Management task. 

 Reports databases do not appear in the tree view of the Plant hierarchy. 
Reports database information can only be accessed via the Database tab of the Plant 
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Properties dialog box. Right-click a Plant and select Properties on the short-cut menu to 
display the Plant Properties dialog box. 

 
 The Reports and Reports schema database are created automatically during the Plant 

generation process. 
 After creating the Plant, you can open the software on a workstation computer and begin 

designing the Plant. 
 During the Plant (Model database) creation process, you can specify the location for the 

physical database files when the Plant is created. 

See Also  
Configuring the Databases (on page 141) 
 

Create the Site, Catalog, and Schema Databases for 
Oracle 

This procedure is for Oracle databases. Site and Catalog database creation requires that you 
install the Project Management and SmartPlant 3D Server Connectivity components. You 
must have the appropriate server components from Oracle server software installed on the 
server computer in order to create the databases. 

 The dump files used to create the Site and Catalog database are delivered on the server 
computer to [Product Folder]\DatabaseTemplates. This location must be shared and write 
permissions given to both the user login used to create the SmartPlant 3D databases and the 
account on which the Oracle service (OracleService<SID>) is running. For example, NT 
AUTHORITY\SYSTEM. Before proceeding, verify that the share (with the appropriate 
permissions) exists on the server computer. 
1. Open the Database Wizard. 
2. Select Create a new site, and then click Next. 
3. On the Create Site Database and Schema page, select Oracle from the Database type 

list. 
4. In the Oracle service list, select the name of the Oracle net service for the site database 

connection. 
5. Enter the name of your Site database in the Site database name text box. 

 
 To better differentiate between one database and another, include the type of database 

in the name you type. For example, type Model1SiteDB. 
 Do not use a name which starts with a digit as its first character. For example, if you 

enter a name such as 1ModelSiteDB, Oracle will not create the database. 
 When you name the Site database, the Oracle service (for the Site schema) and Site 

schema name default to match the Oracle service for the Site database and the Site 
database name. 

6. Enter the workshare location for the Site database in the Site database workshare 
location text box. You can use any string that represents your physical location. 

 This location is the location of the host Site database and is required even if the host 
is not going to be replicated for worksharing purposes. During generation of the Site 
database, the software creates a location object and associates it with the Site database. 
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7. Enter a name rule ID in the Name rule ID text box. By default, the software leaves this field 
blank. You can enter any string identifier, numeric or alpha; however, special characters are 
not supported. 

 The Name Generator Service that runs on the server computer supplies unique 
names to items placed in the Plant (Model database). In a replicated configuration, there are 
multiple servers and multiple instances of the Name Generator Service running at each 
location; consequently, there is no way to ensure unique and sequential naming of placed 
objects. The value entered in the Name rule ID text box functions as a substring (an internal 
ID number) that represents the location at which an item is placed into the replicated Plant. 

8. In the Name generator server for site box, type the name of the server computer on which 
the Name Generator Service is installed. 

 A name server must be a valid server running on the Windows domain and one that 
has been properly configured to run as a name server. 

9. Use the default paths for the site database files in the Data tablespace file name and 
Index tablespace file name boxes. 

10. Click the Browse button to the right of the Template file to be used to create site schema 
text box to browse for the name of the dump file (AppRepos.dmp) the software uses when 
creating your Site schema database. The location of the file is on the reference data 
computer at \\[Server Name]\DatabaseTemplates\AppRepos.dmp. 

11. Click Next. 
12. On the Catalog Database and Schema page, select the name of the Oracle net service for 

the Catalog database connection in the Oracle service list. 

 
 The option control at the top of the page allows you either to create a new Catalog 

database by restoring a backup or use an existing Catalog database. If you choose to 
create a new Catalog database using the Restore option, the wizard will restore the 
.dmp file specified in the Template file to be used to create the Catalog database 
and schema field. The software delivers one selection for this field, CatalogDB.dmp. 
The default is to Restore catalog from backup. If you select Use existing catalog, 
then no further options are available. 

 If you intend to create a custom catalog, you must select the Use existing catalog 
option and use the Bulkload utility delivered with the product. 

13. Enter the name of your catalog database in the Catalog database name box. This step also 
automatically populates the name of the Catalog schema database in the Catalog schema 
name text box. 

14. Use the default paths for the catalog database files in the Data tablespace file name and 
Index tablespace file name boxes. 

15. Click Browse to the right of the Symbol and custom program file folder box to browse for 
and select the SharedContent share on the SmartPlant 3D reference data computer. 

  
 The SharedContent share is created automatically on the reference data computer 

during the SmartPlant 3D Reference Data installation. 
 The path in the Symbol and custom program file folder box must be a UNC path. To 

obtain a UNC path, click Browse and browse under My Network Places, not under My 
Computer. 

16. Click Browse to the right of the Template file to be used to create catalog database and 
schema text box to browse for the name of the dump file (CatalogDB.dmp) you want the 
software to use when creating your Catalog and schema databases. The location of the file 
is on the reference data computer at \\[Server Name]\DatabaseTemplates\CatalogDB.dmp. 
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17. Click Next. 
18. On the Ready to Create Databases page, click Create DB to create your SmartPlant 3D 

databases. 
19. When the Database Wizard displays the database names that you entered, click Finish. 

 
 The software delivers two log files - one for the Site database generation process and one 

for the Catalog database restore process - on the server computer at the local user %temp% 
folder. 

 You must name the databases with unique entries. 
 During the Site database creation process for an Oracle plant, the software attempts to 

connect to the Site database to create the user interface prior to generating the views, 
resulting in a "table or view does not exist" error being reported in the various log files. Since 
views are generated after the user interface is created, these errors cannot be avoided. 
Additionally, these errors do not have any negative impact on using the software and can be 
disregarded when reviewing the log files. 

 Intergraph recommends that you increase and/or redefine initial tablespace values based on 
the expected scope of your project(s). For more information, see your Oracle 
documentation. 

See Also  
Configuring the Databases (on page 141) 
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Create the Model and Reports Databases for Oracle 
Model and Reports database creation requires that the Project Management and SmartPlant 
3D Server Connectivity options be installed. 
1. Open the Project Management task. 
2. Click the Plants icon in the Project Management tree view, and then click Database > 

New > Plant. 
3. On the General tab of the New Plant dialog box, select the Value cell in the Name row, and 

enter a model name, such as Model1. 
4. In the Value cell in the Description row, enter a description, such as Model Number 1. 
5. In the Value cell in the Site row, enter a site description, such as Huntsville. 
6. In the Value cell in the Owner row, enter an owner description, such as Plant Owner 1. 

 
7. On the Databases tab, click in the cell under Type, and select Catalog in the list. 
8. Click in the DB Provider cell for the Catalog database, and select Oracle from the list. 
9. Click in the Service cell for the Catalog database, and select the Oracle net service for the 

Catalog database connection. 
10. Click in the Name cell for the Catalog database, and select the Catalog database name that 

you created earlier. 
11. In the second row, click the cell in the Type column, and select Model in the list. The 

software automatically populates the Name field with the name of the new Model database. 
12. Click in the DB Provider cell for the Model database, and select Oracle from the list. 
13. Click in the Service column for the Model database, and select Oracle net service for the 

Model database connection. 
14. In the third row, click the cell in the Type column, and select Reports in the list. The 

software automatically populates the Name field with the name of the new Reports 
database. 

15. Click in the DB Provider cell for the Reports database, and select Oracle from the list. 
16. Click in the Service column for the Reports database, and select Oracle net service for the 

Reports database connection. 
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17. In the Name generator server for model box, specify the server on which the Name 
Generation Service is installed. 

 A name server must be a valid computer running on the Windows domain and 
one that has been properly configured to run as a name server. For more information about 
installing and configuring the Name Generator service, see the Installing the Name 
Generator Service (on page 71). 

 
18. Specify the path for location of the model database files in the Physical database and 

Index file boxes. 
19. Click OK on the New Plant dialog box. Wait for your computer to complete its processing. 

Icons for the new plant and its associated Catalog database appear in the tree view of the 
Project Management task. 

 Reports databases do not appear in the tree view of the Plant hierarchy. Reports 
database information can only be accessed via the Database tab of the Plant Properties 
dialog box. Right-click a plant and select Properties on the shortcut menu to display the 
Plant Properties dialog box. 

 
 The Reports and Reports schema database are created automatically during the plant 

generation process. 
 After creating the plant, you can open the software on a workstation computer and begin 

designing the plant. 
 During the plant (Model database) creation process, you can specify the location for the 

physical database files when the plant is created. 
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 Intergraph recommends that you increase and/or redefine initial tablespace values based on 
the expected scope of your project(s). For more information, see your Oracle 
documentation. 

See Also  
Configuring the Databases (on page 141) 
 

Assign Access Permissions 
Perform the following steps on the database server computer. 
1. Open Microsoft SQL Server Management Studio and expand the list for your database 

server in the left tree view. 
2. Expand the list under Security in the left tree view. 
3. In the left pane, right-click Logins. 
4. Select New Login from the shortcut menu. 
5. On the Login - New dialog box, enter the user account you want to be assigned 

administrative privileges in the Login name text box. For example, type AdminUser1. 
6. Select Server Roles under the Select a page heading to display the Server Roles list. 
7. In the Server Roles list, select the sysadmin and dbcreator check boxes. 

 Standard SmartPlant 3D users need dbcreator access. Administrators need both 
sysadmin and dbcreator access. 

8. Select User Mapping under the Select a page heading to display the Users mapped to 
this Login list. 

9. Select the Map check box for one of the seven databases created previously, and then 
select db_owner and public as the database roles on the Database role membership for 
list. 

10. Repeat the procedure for each of the remaining six databases. 
11. Click OK. 

 You can repeat steps 2-11 for each additional user/group for whom you want to 
assign access permissions to the databases. 

12. In the left tree view, select Logins to display the various logins you have created. 
13. In the right list view, right click the SQL Server 2008 login you created in the Configure SQL 

Server 2008 Account for Name Generator Service (on page 47) procedure, and select 
Properties. 

14. On the Users mapped to this Login list, select the Map check box for one of the seven 
databases created previously, and then select db_owner and public as the database roles 
in the Database role membership for list. 

15. Repeat the procedure for each of the remaining six databases. 
16. Click OK. 

See Also  
Configuring the Databases (on page 141) 
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S E C T I O N  9  

Unlike the traditional file-based method of manually defining groups of parts to check against 
each other, Check Interference is a separate software process that runs directly on the Model 
database. Although the interference detection process can be run on any computer on which the 
Database Interference Detection Service has been installed, due to the intensive nature of the 
interference check computations, the recommendation is to have a computer dedicated to run 
as an interference server. 

 In order to monitor interferences, you must install the Database Interference Detection 
Service option on the same computer on which the Project Management option is installed. 
Database detection options are set in the Project Management task. You also start and stop 
the interference detection service in the Project Management task. 
Interference detection requires disk space for the file cache that temporarily stores the 
interference data. Before starting the interference process, the interference server checks to see 
if enough space exists in the TMP location for the file cache. The server also checks to see if 
you have the proper permissions to write, read, and delete files in the TMP location. During the 
process, if the space becomes too low, the software stops IFC and displays an error message. 
These checks primarily apply to the server-based interference process, although they can apply 
to the local checking process if extremely low or no disk space is available for the temporary 
folder on the local computer. 

 Configure automatic disk defragmentation in order to free space for the file cache. 
After you start the process, you can use the Status tab on the Interference Server Settings 
dialog box to monitor the start time, progress of the interference checking, time when the last 
part was modified, and the status of the checking. A box at the top of the dialog box identifies 
the model that you are checking. 
The software automatically checks new or modified objects apart from existing objects. When 
you create or modify an object, the software checks for interference against all objects in the 
Model database. The interferences generated by this process are persistent; that is, the 
interferences are stored in the database like any other objects in the software. You can also 
modify these objects by changing the properties. Interferences are also assigned to a 
permission group; thereby the entire process is under the control and restrictions of an 
administrator. 
You can interrupt the automatic interference checking process during a work session without 
forcing a recheck of all parts in the database when the process is brought back online. When 
you restart the interference check process, the software begins checking where it left off when 
the process went offline. However, if you change any of the options on the Interference Server 
Settings dialog box for Database Detect, all pre-existing interference checking processes are 
cleared from the database, and checking starts again from the beginning. 
The server-based interference checking runs continuously; therefore, you can perform an 
interference check at any time and view the interferences of interest that result from the 
background check by refreshing the workspace. After you have reviewed the interferences, you 
can remove an interference automatically from the database by editing the objects so that the 
interference no longer exists. You can then see the results of your edit by refreshing the 

Server-Based Interference Checking 
(Database Detect) 
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workspace. Because certain types of interferences are allowable, you also have the capability to 
mark such interferences as acceptable. 
Be aware that there is a four minute interval between the time you make your edits and the time 
that the database detect service rechecks the objects. After the database detect process 
reaches 100%, the software will issue a query only every two minutes to locate newly modified 
objects. Therefore, it is possible that there will be a six minute delay before a modified object is 
processed. 
When the Database Detect process reaches 100%, it does not mean that all clashes between 
SmartPlant 3D and other foreign objects, such as PDS, referenced MicroStation objects, 3D 
AutoCAD files, or referenced point cloud objects, have been processed. Here, 100% indicates 
that all SmartPlant 3D objects have been processed against each other. 

 
 You must stop the Database Detect process before starting a backup of the databases. 
You must run the Database Detect process  before runni ng an i nterfer ence report . The report  is not i ntended to run on local inter fer ences. 

What do you want to do? 
 Install Database Interference Detection Service (on page 154) 
 Configure Interference Service Properties (on page 155) 
 Start the Database Interference Detection Service (on page 156) 
 Set IFC Permission Requirements (on page 156) 
 Create IFC Permission Group Folder and Permission Group (on page 157) 
 Set IFC Permissions (on page 158) 
 Check Database Interferences (on page 159) 
 

 

Install Database Interference Detection Service 
Prior to installing the Database Interference Detection Service on a computer, verify that all 
prerequisite software has been installed. If you have an older version of the Database 
Interference Detection Service installed on your computer, remove it before loading the new 
software. 
You must have administrator privileges on the computer to install the software. 
1. Insert the Intergraph Smart 3D Product DVD. 

 If the setup does not start automatically, double-click Setup.exe in the root folder of the 
DVD. 

2. Select Smart 3D Installation. 
3. Click Next on the Welcome to the Smart 3D Installation Wizard page. 
4. On the User Information page, enter information in the Full Name and Organization 

boxes. 
5. Click Next. 
6. On the Software License Agreement page, select your country from the list, and click 

Display to view the license agreement. 
 The license agreement is delivered as a PDF file; consequently, you must have 

Acrobat Reader installed on the computer in order to view the license agreement. If the 
software detects that Acrobat Reader is not installed, a message box appears. 

7. Carefully read the license agreement. Close the PDF document, and click Yes on the 
Software License Agreement page to accept the terms. 
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8. On the Select Features page, click Browse and select the folder location for the software, 
and click OK. 

 If you install the Database Interference Detection Service on a computer on 
which the Smart 3D Reference Data software is also installed, they must be installed in two 
separate folders. 

9. On the Select Features page, in addition to the default options that are to be delivered, set 
the following options to Will be installed on local hard drive: Project Management, 
SmartPlant 3D Server Connectivity, and Database Interference Detection Service. 

10. Click Next. 
11. Click Next on the Custom Documentation page. 
12. Click Next on the Start Copying Files page to begin installing the software. 
13. Click Finish to exit the installation sequence. 
14. Restart the computer to complete the installation. 

 
 During the setup, the %temp% value is defined as the user %temp% of the person who runs 

the setup. In Windows, each user's C:\Documents and Settings\username\Local 
Settings\Temp is protected from other Windows users. Consequently, you must set the 
system environment variable TEMP value to a folder location where everyone has write 
access (e.g. C:\Temp). For more information about editing system variables, see the 
Windows on-line documentation (click Start > Help from the Windows task bar). 

 If you plan to check interferences with a referenced PDS® project, you must install and 
configure the PDS Data Access component (with all prerequisites) on the IFC database 
detection server. For more information, see the SmartPlant 3D Plant Design System (PDS) 
Guide. 

See Also 
Server-Based Interference Checking (Database Detect) (on page 153) 
 

Configure Interference Service Properties 
1. Click Start > All Programs > Intergraph SmartPlant 3D > Database Tools > Configure 

Interference Service. 
2. In the Configure Interference Service dialog box, select the Site and Site schema 

databases connection information on which the Interference service will run. 
3. Click OK. 
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Start the Database Interference Detection Service 
Prior to starting the Database Interference Detection Service, you must configure its properties. 
For more information, see Configure Interference Service Properties (on page 155). 
1. Log on with Administrative privileges to the computer where you have installed the Project 

Management task and Database Interference Detection Service option. 
2. Open the Control Panel and double-click Administrative Tools. 
3. In the Administrative Tools window, double-click Services. 
4. Right-click the SmartPlant 3D Interference Detection Service, and select Properties from 

the shortcut menu. 
5. On the Log On tab, enable the This account option, and then type the user name that has 

Administrative privileges. 
 This version of the software does not support the Local System account option. 

6. In the Password and Confirm password boxes, enter the password for the user account. 
7. On the Recovery tab, set the options as required. 
8. On the General tab, verify that the Startup type is set to Automatic. 
9. In the Service status section, click Start. 
10. Click OK. 

  
 If clashes between the Point Cloud and the SmartPlant 3D objects are selected to check for 

interferences, then the SmartPlant 3D Interference Detection Service should be started from 
the command prompt. From the command prompt, navigate to install\Foul 
Check\Middle\bin, and then type IFCNtSvc.exe /Auto/0 and press Enter. 

 Errors that are encountered during startup of the Database Interference Detection service 
are logged to the Event Viewer Application Log with the source name IfcNtSvc. 

 

Set IFC Permission Requirements 
You must install the Database Interference Detection Service option in order to monitor 
interferences. For more information about installing and configuring this service, see the 
SmartPlant 3D Installation Guide available from Help > Printable Guides. 

 The user account running the IFC Windows service must have at least Read access 
to the SharedContent folder. Otherwise, IFC generates a bad part marker with clashes against 
structural fireproofing. 
An Interference Detection Service icon is placed under the Plant node in the Project 
Management tree. After the proper access permissions are configured, you can start and stop 
the Database Detect process from any computer on which the Project Management task is 
installed. 
The SmartPlant 3D database hierarchy is comprised of a Plant that consists of the Model and 
Catalog databases. For the IFC Database Detection process to run correctly, permissions must 
be set on the Plant and Plant permission groups according to the following guidelines: 
Log on privileges for the IFC Administrator include: 
 Read access on the Plant (Model database) at a minimum 
 Full Control permissions or access on a minimum of one permission group 

 In the Project Management task, create a new permission group folder and 
permission group under the Plant icon to store the IFC results. For example, type IFC 



 Server-Based Interference Checking (Database Detect) 
 

 
SmartPlant 3D Installation Guide 157 

 

Permission Group Folder and IFC Permission Group in the New Permission Group 
Folder and New Permission Group dialog boxes, respectively. For more information, refer 
to Create IFC Permission Group Folder and Permission Group (on page 157). 

 Read access on all other Plant (Model database) permission groups at a minimum. 
 
 

Create IFC Permission Group Folder and Permission 
Group 

1. Log on with administrative privileges to the computer where you have installed the Project 
Management task and Database Interference Detection Service option. 

2. In the Project Management tree view, navigate to the Plants icon on the tree view. 
3. Expand the Plants folder. 
4. Right-click on a Plant under the Plants folder. 
5. On the shortcut menu, select New Permission Group Folder. 
6. Type IFC Permission Group Folder for the name of the new permission group folder. 
7. Click OK to close the New Permission Group Folder dialog box. 
8. In the tree view, navigate to the IFC Permission Group Folder icon on the tree view. 
9. Right-click IFC Permission Group Folder. 
10. On the shortcut menu, select New Permission Group. 
11. Type IFC Permission Group for the name of the new permission group. 
12. Click OK to close the New Permission Group dialog box. 

 After the IFC permission group is created, you must assign the proper access 
permissions. For more information, see Set IFC Permissions (on page 158). 
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Set IFC Permissions 
1. Log on with administrative privileges to the computer where you have installed the Project 

Management task and Database Interference Detection Service option. 
2. In the Project Management tree, navigate to the IFC Permission Group icon on the tree 

view. 

 
3. Right-click IFC Permission Group. 
4. Select Permissions. 
5. On the Access Permissions dialog box click Add. 
6. In the Add names grid, double- click in the User cell, type the domain and name of the user 

or group that you want to add. 

  
 You can also click Add and search for users using the Select Users and Groups 

dialog box. This is a common Windows dialog box. For information regarding the 
options in this dialog box, see your Windows documentation. 

 To remove a user or group from the Add names grid, select the appropriate row and 
click Remove. 

In the Type of access list, select the type of access you want to assign. The software 
automatically updates the associated row in the Add names grid. 

7. Click OK. 
8. Click OK again to close the Access Permissions dialog box. 
 



 Server-Based Interference Checking (Database Detect) 
 

 
SmartPlant 3D Installation Guide 159 

 

Check Database Interferences 
Before performing the following procedure, you must first manually configure the Interference 
Detection Service on the computer where the service is installed. 

1. In the Project Management tree, right-click the Interference Server icon  under the Plant 
for which you want to start Database Detect. Then select Properties on the shortcut menu. 

2. In the Interference Server Settings dialog box, assign interference checking priorities to 
aspects. 

 Maintenance, for example, is a typical aspect listed in the Aspect column. If a check 
of this aspect is important, you can indicate the priority as Required. If Maintenance is low 
priority or not important, you can indicate the priority as Optional or Not Checked. 

3. Specify the interference comparison criteria: 
 Required - Required - Defines interferences classified as hard/hard. For example, one 

pipe physically intersects with another pipe. 
 Required - Optional - Defines interferences that are not as severe and are classified as 

hard/soft. For example, one pipe overlaps the optional aspect of the other object. 
 Optional - Optional - Defines interferences that are not severe and are classified as 

soft/soft. For example, the maintenance aspect of one piece of equipment overlaps the 
maintenance aspect of another. 

 SmartPlant 3D - Foreign Interferences - Considers objects outside the active model 
for interferences. For Local Detect, this option is enabled by default. For Database 
Detect, this box must be checked if you want referenced 3D models, referenced PDS 
objects, referenced MicroStation objects, and 3D AutoCAD files to be considered. This 
option only checks objects against foreign objects. It does not check for interferences 
between two foreign objects. 

 SmartPlant 3D - Point Cloud - Considers SmartPlant 3D objects and point cloud 
objects for interferences. For Database detect, this option must be selected to consider 
SmartPlant 3D objects and point cloud objects. For Local detect, select the SmartPlant 
3D Point Cloud check box to consider local interferences. The point cloud must have a 
valid connection to the model with no unresolved vendor licensing issues for this check 
box to be available. 

4. In the Include clearance list, select the desired clearance rule. 
5. From the Assign results to permission group box, choose the permission group to which 

all the detected interferences are assigned. 
6. In the Marker size field, type the value for the size of the interference symbols that will be 

generated in the model. 
 Choose a marker size that is clearly readable, but one that does not interfere with the 

smaller details in the workspace view. 
7. Click Start on the Database Detect tab. After you click Start, the Status tab on the 

Interference Server Settings dialog box displays the progress of the processing for parts 
that existed previously and for new or changed parts during the run. 

 If the IFC Server detects that your system resources are too low (due to a 
significant process requiring the majority of system memory), then the IFC process will stop and 
display a message box notifying you that the service has stopped for this reason. 

 
 To start the server interference detection process, you must have at least Read access to all 

objects in the model and Write access to the model itself. Access privileges are assigned for 
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each permission group in the Project Management task. During the IFC process, if the 
software denies access to an object, the server process stops and a message appears. 

 To view the status of the database interference detection process, right-click the 
Interference Server icon in the Project Management tree, and click Properties. On the 
Interference Server Settings dialog box, click the Status tab. 

 When the database interference check process is running, only the Stop command is 
available. When the process is not running, the Start command and all process property 
gadgets are available. The Stop command is not available. 

 When the database interference check is running and you add any permission group without 
Read permissions for the server, the server automatically receives Read permissions and 
finds collisions with the placed objects in that permission group. 

 When you modify permission groups in Project Management, the host for the existing, 
running task does not receive the changes. To update the information, you must exit and 
restart the interference detection process. 

See Also 
Interference Server Settings Dialog Box (on page 160) 
 

Interference Server Settings Dialog Box 
Provides options to change or accept the default properties for the interference marker size and 
the status of those interferences. Also, you can assign interference checking priorities to aspects 
and indicate whether the interferences are optional or required. Optionally, you can indicate if 
you want interference checking to include a clearance rule. You can activate this dialog box in 
the Project Management task by right-clicking on the Interference Server node under the Model 
database, and then selecting Properties. 
Remember, if you change any of the options on this dialog box for Database Detect, all 
pre-existing interference checking processes are cleared from the database, and checking 
begins from scratch. 

 The Interference Server Settings dialog box is only available on computers on 
which the Project Management and Database Interference Detection Service options are 
installed. 

See Also 
Database Detect Tab (Interference Server Settings Dialog Box) (on page 160) 
Status Tab (Interference Server Settings Dialog Box) (on page 162) 
 

Database Detect Tab (Interference Server Settings Dialog 
Box) 

Provides options for assigning interference checking priorities to aspects, specifying the 
comparison methods, and optionally including a clearance rule. You can also assign the 
interference results to a selected permission group. 
All properties on this tab when viewed outside the Project Management task are read-only. 

 You must run the Database Detect option before running the delivered Interference 
report. The Interference report is not intended to run on local interferences. 
Check Plant - Specifies the name of the model that the server process needs to check. The 
server software must have the Site database locations predefined. This option is not available if 
you are in the Project Management task. 
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On server - Specifies the name of the server on which the interference checking is completed 
for the identified model. 
Assign interference checking priority to aspects - Provides a two-column table listing the 
object aspects in one column and the type of comparison to check against that object in the 
other column. 
 Aspect - Lists all the object aspects identified for use in the model. This list includes the 

system-defined aspects and the user- defined aspects. Select those aspects in the Aspect 
column that apply to your objects, and then specify the type of comparison in the Type 
column. The delivered aspects include Simple physical, Detailed physical, Insulation, 
Operation, Maintenance, and Reference Geometry. The Diagnostic Interference Checking 
report lists these aspects settings in its header. 

 Type - Lists the types of checking you can apply to the selected aspect: Required, 
Optional, and Not checked. Choose the appropriate type for each aspect you select in the 
Aspect column. Not checked means the software does not use the selected aspect for 
interference checking. 

Compare - Provides the following check box options for specifying which aspect types are to be 
compared against each other to find interferences. 
 Required - Required - Defines interferences classified as hard/hard. For example, one pipe 

physically intersects another pipe. 
 Required - Optional - Defines interferences that are not as severe and are classified as 

hard/soft. For example, one pipe overlaps the optional aspect of the other object but does 
not actually intersect the other object. 

 Optional - Optional - Defines interferences that are not severe and are classified as 
soft/soft. For example, the maintenance aspect of one piece of equipment overlaps the 
maintenance aspect of another. 

 SmartPlant 3D - Foreign Interferences – Considers referenced 3D models, referenced 
PDS objects, referenced MicroStation objects, and 3D AutoCAD files for interferences. This 
option is enabled after you have selected a Plant at the top of this tab. For PDS objects, the 
selected Plant has to have an attached PDS project. For Database Detect, this box must be 
checked if you want PDS objects considered. In the case of Local Detect, the software by 
default considers referenced 3D models, PDS objects, MicroStation objects, and 3D 
AutoCAD files that are in the workspace. 

 This option only checks active model objects against foreign objects. It does not 
check for interferences between two foreign objects (PDS to 3D AutoCAD for example). 

 SmartPlant 3D - Point Cloud - Considers an attached point cloud during interference 
checking. The Point Cloud check box must be selected to consider SmartPlant 3D objects 
and the point cloud. The point cloud must have a valid connection to the model with no 
unresolved vendor licensing issues for the Point Cloud check box to be available. 

Include clearance rule - Specifies the clearance rule to add to the Required type of 
interference check. 
Assign results to permission group - Specifies the permission group to which all the detected 
interferences are assigned. The list displays only those permission groups to which the server 
containing the interference checking software has Write access. 
Marker size - Specifies the size of the interference graphic marker. Choose a size that is clearly 
readable, but one that does not interfere with the smaller details in the workspace view. 
Check all objects in database - Provides buttons to start and stop the interference checking 
process. 
Start - Begins the process. This option is only available in the Project Management task. 
Stop - Halts the process. This option is only available in the Project Management task. 
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Status Tab (Interference Server Settings Dialog Box) 
Displays the status of the Database Detect process on the server. The status information 
includes the percentage of checking that has been completed, the amount remaining, when the 
process was started, and the estimated completion time. 
The information on this tab is read-only. 
Plant - Displays the name of the model that is checked. 
New and modified parts since process start - Displays the following time information for any 
new and modified parts since the process was started. 
Last part modified - Displays the date and time (mm/dd/yyyy hh:mm:ss) at which the last part 
was created or modified in the Model database. 
Current range to - Displays the date and time (mm/dd/yyyy hh:mm:ss) at which the last part 
modified was in consideration for interference checking. 
From - Displays the date and time (mm/dd/yyyy hh:mm:ss) at which the interference check 
completed checking the last part modified. 
Elapsed time - Displays the amount of time (hour, min, sec) during which the interference 
checking has been running for the new or changed parts. 
Estimated completion - Displays the amount of time (hour, min, sec) estimated until the 
interference checking process completes. Then displays Completed when the process is 
complete. 
Process start - Displays the time (mm/dd/yyyy hh:mm:ss) the process started. 
Existing parts at process start - Displays the following time information for existing parts when 
the process was started. 
Current range to - Displays the date and time (mm/dd/yyyy hh:mm:ss) at which the interference 
checking started for the existing parts. 
From - Displays the date and time (mm/dd/yyyy hh:mm:ss) at which the interference checking 
ended for the existing parts. 
First part created - Displays the date and time (mm/dd/yyyy hh:mm:ss) at which the first part 
was created in the database. 
Elapsed time - Displays the amount of time (hour, min, sec) during which the interference 
checking has been running for the existing parts. 
Estimated completion - Displays the amount of time (hour, min, sec) estimated until the 
interference checking process completes. Then displays Completed when the process is 
complete. 
Status message - Displays textual information about the current status of the process on the 
server. 
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S E C T I O N  1 0  

SmartPlant 3D uses the Intergraph Batch Services application to help you run large, 
time-consuming operations on a separate computer or during off hours, leaving your 
workstations available for other tasks. Due to the intensive nature of batch operations, using one 
or more computers dedicated as batch computers is recommended. 
You can install both batch processing methods on any computer on which the SmartPlant 3D 
Workstation software has been installed. You must also install the Project Management and 
SmartPlant 3D Server Connectivity features on your batch computers. 
The Intergraph Batch Services application (Version 6.1.0.3 or later) is used to run batch 
processing for Project Management, Drawings, and Structure tasks such as running database 
integrity checks or updating documents. Intergraph Batch Services is delivered on separate 
media than SmartPlant 3D. 

 Intergraph Batch Services does not require a serial number. 
 

Installing Intergraph Batch Services 
1. Open Control Panel > Administrative Tools > Services and determine the current status 

of the TCP/IP NetBIOS Helper service on your computer. Start that service if it is not already 
running. 

2. Insert the Intergraph Batch Services CD into your computer's drive. 
3. To start setup, do one of the following: 

 Press the Windows key + R to activate the Run dialog box. Type drive:\setup, where 
drive is the drive letter for the CD/DVD drive. 

 In Windows Explorer, select the CD/DVD drive; then double-click setup.exe. 
4. Select Batch Services Installation. 

Batch Service 
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5. Click Next on the Welcome page. 

 
6. Type your name and organization name, and then click Next. 
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7. On the License Agreement page, select your country from the list, and then click Display. 

 
8. Read the license agreement, and then close the PDF file. 
9. Click Yes to accept the license agreement. 
10. To accept the default destination folder ($WindowsDrive:\Win32App\Ingr\Batch), click Next. 

-OR- 
Click Change, and specify a new installation folder. 

 If you plan to use this installation of Intergraph Batch Services with Plant 
Design System (PDS), do not install Intergraph Batch Services to a folder path that contains 
spaces, such as c:\Program Files\Batch. While Intergraph Batch Services does support 
spaces in folder paths, PDS does not. 
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If the destination folder already contains a version of Intergraph Batch Services, a warning 
message displays. You can install the new version of the Batch Services over the currently 
installed version, or you can install the new version in another folder. 

 
11. Select whether you want jobs to have access to the desktop. If you allow jobs to have 

access to the desktop, an iconified and non-active window will appear on the screen when a 
job is runs. These windows will only appear when a user is logged on to the system. 

 Windows Vista, Windows 2008 Server, and Windows 7 do not allow jobs to have 
access to the desktop. Therefore, you will not see this dialog when installing Batch Services 
in these operating systems.  

 
If your site is one where batch jobs might require some user input, you should select Yes.  
If your site is one where security is a major concern, you should select No; a logged-on user 
will be able to interact with running batch jobs, even if the job is running as a different user. 
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You can change whether you want jobs to have access to the desktop later. See Granting 
Jobs Access to the Desktop (on page 168) for details. Jobs that try to access the desktop 
will not run unless the user running the job is a member of the Administrators group. 

12. Setup asks if you want to run all jobs as the same user. 

 
If you select Yes to configure account mapping, define the username and username 
password under which jobs should run.  
If you select No, setup warns you that you must configure account mapping before you can 
submit jobs. Use Batch Manager to configure account mapping after setup is complete. 

13. Click Next, and then click Install. 
Intergraph Batch Services is installed on your computer. This may take a few minutes. 

14. Click Finish. 
15. After setup completes, restart your computer. 
 

Starting and Stopping Batch Services 
When you install Intergraph Batch Services software, the batch server service is configured to 
start automatically each time you restart your computer. No further configuration is required. 
Intergraph recommends leaving the batch server service as configured.  However, if you want 
to configure Intergraph Batch Services to be started manually instead of automatically, do the 
following: 
1. Open Control Panel > Administrative Tools > Services. 
2. In Services, right-click on Intergraph Batch Server, and select Properties. 
3. Set Startup type to Manual, and then click OK. 
4. Close the Services window. 

 Batch Services also delivers an Intergraph NQS Listener service that is configured to 
start automatically. If your site is not using Intergraph NQS, you can configure the NQS 
Listener service to be started manually. Repeat steps 1-3, selecting Intergraph NQS 
Listener from the Service list. 
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If you configure Batch Services to be started manually, you must start the batch server each 
time you restart your system, or each time you want to run Batch Services. 
To start Batch Services manually: 
1. Open Control Panel > Administrative Tools > Services. 
2. In Services, select Intergraph Batch Server from the list, and then click Start. 
To stop Batch Services: 
1. Open Control Panel > Administrative Tools > Services. 
2. In Services, select Intergraph Batch Server from the list, and then click Stop. 
 
 

Granting Jobs Access to the Desktop 
If required, batch jobs can have access to the desktop. If jobs are allowed to have access to the 
desktop, a window that is iconified and non-active displays on the screen while a job is running. 
These windows will only be seen when a user is logged in. 

 Windows Vista, Windows 7, and Windows 2008 Server do not allow jobs access to the 
desktop. 
Granting jobs access to the desktop depends on your site's security requirements. If jobs are 
granted access to the desktop, a logged in user will be able to interact with batch jobs that are 
running, even if the batch job is running as a different user. If security is not a concern, sites 
where batch jobs may require some user input should configure Batch Services to allow jobs to 
have access to the desktop. Sites where security is a main concern should configure Batch 
Services not to allow jobs to have access to the desktop. When you install Batch Services 
software, you are given the option of whether or not jobs may have access to the desktop. After 
installation, if you want to change the way Batch Services is currently configured, do the 
following: 
1. Open Control Panel > Administrative Tools > Services. 
2. Right-click on Intergraph Batch Server in the list, and then click Properties. 
3. Select the Log On tab.  
4. The Allow service to interact with desktop checkbox determines whether or not jobs may 

access the desktop. If you want jobs to have access to the desktop, make sure the 
checkbox is selected. If you do not want jobs to access the desktop, make sure the 
checkbox is cleared.  

5. Click Apply to reconfigure the startup parameters.  
The Intergraph Batch Server service must be stopped and restarted for the change to take 
effect.  

6. Select the General tab. 
7. Click Stop. 
8. Click Start to restart Batch Services. 
9. Click OK to close the properties window.  
10. Exit the Services window. 
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Granting Batch Service Privileges 
Before you begin using Intergraph Batch Services, you should use Intergraph Batch Manager to 
ensure that users on your system (and users on other systems if appropriate) are granted the 
proper privileges for access to Batch Services.  
A user with manager privileges can use all the commands that affect batch server configuration 
and operation, including granting and removing privileges, and creating and deleting queues. A 
user with operator privileges can manage jobs, including those belonging to other users, and 
can start and stop batch server queues. Users or groups without privileges can only submit 
requests to queues to which they have been granted access; most users or user groups are 
non-privileged users. 
On Windows 7 and Windows Vista with User Account Control turned off, the Administrators 
group on your system has manager privileges. From an account belonging to the Administrators 
group, you can add users and groups of users, on your system or other systems, to the 
manager and operator privilege lists. 
1. Open Start > All Programs > Intergraph Batch Services > Intergraph Batch Manager.  
2. Select your computer name in the tree view on the left. 
3. Click Server > Properties. 
4. Select the Security tab.  

Users and groups, and their Batch Service privileges, display in the Managers and 
Operators list. 

 
Figure 1: Server Properties Dialog: Security Page 

5. Click Add, and then type the username of a user into the Add Names box, or the group 
name of a group, to which you want to grant privileges. 

6. Specify local users and groups (on your computer) by username or group name only. Use 
one of the following formats when keying in a username or group name: 
domain_name\username or system_name\username 
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domain_name\group_name or system_name\group_name 
Separate multiple users or groups with a semicolon (;). 

7. Select the type of privilege you want to grant the user or group (Manager or Operator). 
8. Click OK. 
9. Repeat steps 5 through 8 for each user or group to which you want to grant privileges. 
10. When you have finished assigning privileges to users or groups, click OK on the Server 

Properties dialog box. 

To remove privileges from a user or group: 
1. Open Start > All Programs > Intergraph Batch Services > Intergraph Batch Manager.  
2. Select your computer name in the tree view on the left. 
3. Click Server > Properties. 
4. Select the Security tab. 

The current users and groups with Batch Service privileges are displayed in the Managers 
and Operators list. 

5. In the Managers and Operators list, select the user or group for which you want to remove 
privileges. 

6. Click Remove. 
7. Repeat steps 5 and 6 for each user or group from which you want to remove privileges. 
8. When you have finished removing privileges from users and groups, click OK. 

 To change a user’s or group’s privileges, first remove the current privileges from the user or 
group; then re-add the user or group to the privilege list with the new privilege. 
 

Configure Account Mappings 
Batch Services requires an account name and password to use when running jobs. The process 
of determining the account name to use is called account mapping. You can use Batch Manager 
to enter and modify account-mapping information for your system. An account mapping entry 
comprises two parts: the user information to match (the “from” user), and whom that user maps 
to (the “to” user). Account mapping entries allow users submitting a job to assume the 
environment and permissions of the user to whom they are mapped. 
To perform account mapping, the batch server tries to match the job owner with an account 
mapping entry, using the following order (items are listed on the account mapping dialog in the 
order in which they are applied): 
1. The batch server first tries to find an exact match, matching the job owner’s domain or 

computer name and username with the “from” user in the account mapping entries.  
2. If the batch server cannot find an exact match, the batch server then searches the account 

mapping entries using the job owner’s domain or computer name, with “*” (meaning any 
user) as the username.  

3. If no match is found, the batch server then searches the account mapping entries using “*” 
(meaning any computer or domain) as the domain name, with the job owner’s username.  

4. Finally, if a match still has not been found, the batch server searches with “*” as the domain 
name and “*” as the username. 

How you configure account mapping depends on the security needs and configuration of your 
site. For more information on configuring account mapping, see Configure Account Mappings in 
the Installation Guide. 
Configure default account mappings: 



 Batch Service 
 

 
SmartPlant 3D Installation Guide 171 

 

1. Click Start > All Programs > Intergraph Batch Services > Intergraph Batch Manager. 
2. Select the computer name in the tree view. 
3. Select Server > Account Mapping. 
4. Enter * for the Map From Account Domain/Host and the User. 
5. In the Map To Account Domain/Host box, select the domain of the Windows user account 

you want to run jobs as. 
6. In the Map To Account User box, type the user name to use. 

 The map-to-account user must have access to the SmartPlant 3D site, catalog, 
and model databases because it is under this user name that the batch jobs will run. Give 
this user those access rights using SmartPlant 3D Project Management. 

7. Click Add. 
8. Enter and confirm the password for the "to account" user name. 
9. Click OK. 

 The ConfigureDrawingsBatch utility must be run each time mapped account settings 
are changed. For more information, see Configuring the Batch Services Server for Drawings 
Tasks (on page 172). 
 

Create Batch Services Queues 
You must create the Intergraph Batch Services queues that SmartPlant 3D will use. 
1. Open Windows Explorer on computer on which Intergraph Batch Services is installed. 
2. Navigate to and double-click c:\Program 

Files\SmartPlant\3D\ProjectMgmt\Tools\bin\ConfigureSP3DBatchQueue.exe. 
A message box appears informing you that the queues have been created and that you 
need to restart the Intergraph Batch Server service. 

3. Open Control Panel > Administrative Tools > Services. 
4. In Services, select Intergraph Batch Server from the list, and then click Stop. 
5. With Intergraph Batch Server service still selected, click Start. 
6. To verify that the batch queues were created, open Intergraph Batch Manager and select 

your server in the tree view. 

 
 If you install WinZip on the computer where you installed Intergraph Batch Services, the 

batch process automatically zips the log files in the temp folder after the batch job finishes. 
 Intergraph Batch Services can optionally send the zipped or unzipped log files using email. 

You must define a SMTP host in Intergraph Batch Services. Refer to the Intergraph Batch 
Services documentation for more information on configuring email. 
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Making Other Batch Servers Available 
You can make other computers running Intergraph Batch Services available for selection as the 
Task server by following these steps: 
1. Edit <SharedContent>\Xml\SP3DBatchQueues.xml. 
2. In the <SP3DBatchServers> section of the file, uncomment and add the computer names 

that you want to make available. 
<SP3DBatchServers> 
<SP3DBatchServer ServerName="batchserver1" />  
<SP3DBatchServer ServerName="batchserver2" />  
</SP3DBatchServers> 

3. Save and close the SP3DBatchQueues.xml file. 
4. Navigate to and run as an administrator [Product 

Folder]\ProjectMgmt\Tools\bin\ConfigureSP3DBatchQueue.exe. The default product folder 
is c:\Program Files\SmartPlant\3D. 

5. In Custom Batch Queues file location, type the path to the 
<SharedContent>\Xml\SP3DBatchQueues.xml file that you edited in step 2. 

6. Click OK. 
A message box appears informing you that the queues have been created and that you 
need to restart the Intergraph Batch Server service. 

7. Open Control Panel > Administrative Tools > Services. 
8. In Services, select Intergraph Batch Server from the list, and then click Stop. 
9. With Intergraph Batch Server service still selected, click Start. 

 Additional task servers are only supported for Structural import and export batch jobs. 
 

Configuring the Batch Services Server for Drawings Tasks 
1. In the folder [SmartPlant 3D Installation folder]\Core\Container\Bin\Assemblies\Release, run 

ConfigureDrawingsBatch.exe. 
2. Click Yes, and then click OK. 

 
 The printer name on the client computer must match the printer name on the batch server. 
 Every mapped account must open Microsoft Excel once on every batch server. 
 Microsoft Excel must have the same security settings that are necessary for interactive 

updates. Excel must be configured correctly for every IBS-mapped account on the batch 
server. 

 Updating drawings and reports using Intergraph Batch Server requires access to the 
desktop. For more information, see Granting Jobs Access to the Desktop (on page 168). 

 The following entries need to be added to the system path for 3D model data documents to 
update: 
 [Product Folder]\Core\Runtime 
 [Product Folder]\Common2D\Rad2d\Bin 
 [Product Folder]\GeometryTopology\Runtime. 

 The ConfigureDrawingsBatch utility must be run each time mapped account settings are 
changed. 
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This section discusses how to map individual workstation computers to the server databases, 
start the software, and begin performing various tasks in the software environment. 

 You must create the seven databases before running the software. For additional 
information, refer to the section entitled Configuring the Databases (on page 141). 

See Also  
Open SmartPlant 3D (on page 175) 
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Define Your Workspace ................................................................. 176 
Save Session Files ........................................................................ 177 
 
 

Update Site Database Name and Path 
Perform the following steps from a SmartPlant 3D workstation computer on which the Project 
Management and SmartPlant 3D Server Connectivity options are installed. 

SQL Server Databases 
1. Open the Modify Database and Schema Location utility. 

 
2. In the Site database server box, type the name of the server on which the Site database 

resides or select it from the drop-down list of recently used Site database servers. 
3. In the Site database name box, type the name of the Site database or select it from the 

drop-down list of recently used Site databases. 
4. The Site schema server box value is set when you specify the Site database server and 

Site database name. 

Getting Started 
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5. The Site schema name box value is set when you specify the Site database server and 
Site database name. 

 If SQL is not installed locally, you can get the names from your database administrator. 
6. Click OK. 

Oracle Databases 
1. Open the Modify Database and Schema Location utility. 

 
2. In the Database type list, select Oracle. 
3. In the Oracle service name box, type the name of the Oracle net service for the Site 

database connection or select it from the drop-down list of recently used Oracle service 
names. 

4. In the Site database name box, type the name of the Site database or select it from the 
drop-down list of recently used Site databases. 

5. The Oracle service name box value is set when you specify the Oracle net service and Site 
database name. 

6. In the Site schema name box value is set when you specify the Oracle net service and Site 
database name. 

7. Click OK. 
 The first time you run the software after installing it, the software prompts you for the Site 

database name and sets the Site database name and path automatically. 

See Also  
Getting Started (on page 173) 
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Open SmartPlant 3D 
Each time that you use SmartPlant 3D, you can create a session that allows you to save certain 
settings, such as window size, layout, and view orientation from one work session to the next. 

 
 Before using the software, verify that the Microsoft Distributed Transaction Coordinator 

(MSDTC) is started on all computers. For information on starting MSDTC, see Verify Startup 
of Microsoft Distributed Transaction Coordinator in XP (on page 85). 

 A user who is a member of the Windows Administrators group on the workstation computer 
must start the software once on the workstation computer before a user without 
administrative privileges can successfully start the software. 

1. Click Start > All Programs > Intergraph SmartPlant 3D > SmartPlant 3D. 
2. Select one of the templates on the New dialog box. 

 A template is a standard Workspace file. You use a template as a pattern to assemble 
the parameters that you want for a new work session. Two standard templates are delivered 
with the software: English Units and Metric Units. 

3. Click OK. 
 After you open SmartPlant 3D, you can use commands on the File menu to create new 

sessions, open previous sessions, save sessions, and close sessions. For more information, 
refer to the online documentation for the Common task or the Common User's Guide available 
from Help > Printable Guides command in the software. 

See Also  
Getting Started (on page 173) 
 

Configure Your Tasks 
Common operations within the various tasks of SmartPlant 3D are performed the same way. 
Therefore, the Common task refers to the functions shared with other tasks and identifies the 
commands required to accomplish these functions. 
The Common task allows you to define a workspace, as well as perform common operations on 
that workspace. The workspace represents the portion of the plant data that you need to 
perform your intended task. The session includes the view settings for user modeling, as well as 
your personal filters for viewing the data. Many other tasks on the Tasks menu are not available 
until you have defined your workspace. 
After defining your workspace, you can use the Tasks menu to move between the various 
design tasks. You can perform specified functions, depending on your access permissions. After 
you select a task, the interface and available functionality is displayed. Some of the commands 
and functionality are unique to the particular task. For example, some commands for the Piping 
task are not available in the Equipment and Furnishings task. However, most of the Common 
task commands are available in all of the various design tasks. You use the Common task 
commands and functionality the same way regardless of the active task. For example, the 
commands that appear on the View and File menus function the same way in every task. 
To use the tasks available in SmartPlant 3D, you must configure them for your session. Once 
you configure the tasks that you wish to use, you must then define your workspace. Once you 
define your workspace and configure your task list, you can save your session file. 
1. In SmartPlant 3D, click Tasks > Configure Task List. 
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2. On the Configure Task List dialog box, select each task in the list that you want to add to 
the menu from the Available task environments list. 

 You can select multiple tasks by dragging down the list or holding Shift and dragging. 
3. Click Add. 
4. Click OK. 

 
 You have to perform the above procedure only once for your session file. The software 

remembers the tasks when you re-open the session file. 
 For detailed information regarding how to configure tasks in SmartPlant 3D, refer to the 

online documentation for the Common task or the Common User's Guide available from 
Help > Printable Guides. 

See Also  
Getting Started (on page 173) 
 

Define Your Workspace 
When you begin to work in a task, you must first define the content of the workspace, that is, the 
items with which you want to begin working. By defining only those items that you want from the 
database, you avoid cluttering the workspace with unneeded and unrelated items. 
Select the items for your workspace by using a filter. The filter is a query that retrieves from the 
database only those items that you specify in the filter criteria. 
Defining a workspace also allows you to create and name filters that restrict the data of the 
entire model into more manageable subsets for working. 
The workspace contents that you define appear in the Workspace Explorer (WSE) in a 
classification hierarchy that reflects the various relationships for the design objects. The 
contents represent the current items loaded from the database into the active workspace. 
1. If you are not already in the Common task, click Tasks > Common. 
2. Click File > Define Workspace. 
3. Select the name of the plant database you want to use in the  Plant box. 
4. Select Create New Filter in the Filter box. 
5. On the New Filter Properties dialog box, type a name for the new filter in the Name box. 
6. Specify the filter search properties by using one or more of the displayed tabs. 
7. Click OK to close the New Filter Properties dialog box. 
8. Click OK to return to the model. 

 
 After the Define Workspace dialog box closes, the window refreshes. Once the refresh is 

complete, the Common window is active. Everything in the Tasks menu is now available. 
 For more information on workspaces, sessions, and filters refer to the online documentation 

for the Common task or the Common User's Guide available from Help > Printable Guides. 

See Also  
Getting Started (on page 173) 
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Save Session Files 
Once you define your workspace and configure your task list, you can save your session file.  
1. Click File > Save. 
2. Browse to the folder location where you want to store your session file. 
3. On the Save As dialog box, type the name of your session file in the File Name box. 
4. Click Save. 

 For more information on saving session files, refer to the online documentation for the 
Common task or the Common User's Guide available from Help > Printable Guides command 
in the software. 

See Also  
Getting Started (on page 173) 
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You have three options for Application Maintenance for SmartPlant 3D: 
 Modify - Change the selected features that were installed. Install and/or uninstall individual 

features to match the new selection. 
 Repair - Using the current feature set installed, repair any missing or corrupted files from 

the installation. 
 Remove - Removes registry entries, files, and directories that do not contain user data and 

are not shared by other programs and were put there by the installation. 
You can access Application Maintenance by: 
 Insert the product CD, or rerun Installation, on a machine that already has the product 

installed. 
 From Control Panel, select Add/Remove Programs, select SmartPlant 3D, and click 

Change. 
 Selecting Remove from the Add/Remove Programs dialog box does not access the 

Application Maintenance utility. The Remove process is started automatically. 
Because the product is already installed on the machine, the Application Maintenance dialog 
appears and you can specify the type of action needed. 

 
For more information on modifying, repairing, or removing the software, see Modify or Repair 
SmartPlant 3D (on page 180). 

See Also 
Setting Up the Client (on page 81) 

Application Maintenance 
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Modify or Repair SmartPlant 3D 
You can use the Application Maintenance utility to modify, repair, or even remove the 
SmartPlant 3D application. The procedure below shows how to modify or repair the application. 
For more information on removing (uninstalling) the software, see Remove Smart 3D Software 
(on page 182). 
On a computer where the software is installed, insert the product DVD, or rerun Installation. 
The Application Maintenance dialog box appears. 

 
 You can also access this dialog box by selecting Control Panel > Add/Remove 

Programs, then selecting the Smart 3D application and Change. 

Modify the Currently Installed Features 
You can change the selected features that were installed. Install and/or uninstall individual 
features to match new selections. 
1. Select the Modify option on the Application Maintenance page and click Next. 
2. On the Select Features page, select the features that you want to install. For example, if 

you want to create databases, click the Project Management and SmartPlant 3D Server 
Connectivity option icons and select Will be installed on local hard drive. 
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 Before adding and removing features from the setup, review the dependencies that can 
exist between one feature and another. For more information, see Setting Up the Client 
(on page 81). 

 If you selected the Piping Specification Remote Access Server feature to be 
installed, the Piping Specification Remote Access Server page appears. Enter a 
username with administrative privileges to the computer. In the Password and Confirm 
Password boxes, enter the password of the user, and then click Next. 

3. Click Browse and select the folder location for the client software, and click OK. 
4. Click Next. 
5. On the Ready to Modify the Application page, verify the installation summary. Click Back 

to return to any previous install pages and make changes. 
6. Click Next to begin installing SmartPlant 3D client software. 
7. When the installation process is complete, click Finish. 

  
 During the setup, the %temp% value is defined as the user %temp% of the person who 

runs the setup. In Windows, each user's C:\Documents and Settings\username\Local 
Settings\Temp is protected from other Windows users. Consequently, you must set the 
system environment variable TEMP value to a folder location where everyone has write 
access (that is, C:\Temp). For more information about editing system variables, see the 
Windows online documentation (click Start > Help from the Windows task bar). 

 If you installed the Piping Specification Remote Access Server feature during the 
setup, you must verify that the COM+ application is installed and configured on the 
administrator computer. For more information, see Configure the Piping Specification 
Remote Access Server Service (Vista and Windows 7) (on page 126). 
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 You can install the Database Interference Detection Service on a different workstation 
computer. For more information, see Install Database Interference Detection Service 
(on page 154). 

Repairing the Currently Installed Features 
Using the current feature set installed, you can use the Application Maintenance utility to repair 
any missing or corrupt files from the installation. 
1. Select the Repair option on the Application Maintenance dialog box and click Next. 
2. On the Ready to Repair the Application dialog box, click Next to begin the repair process. 

See Also 
Application Maintenance (on page 179) 
 
 

Remove Smart 3D Software 
There are two ways to remove, or uninstall, the software from the computer. You can go through 
the Control Panel and use Add/Remove Programs to remove the software, or you can insert 
the product DVD and select Remove on the Application Maintenance dialog box. 
You should keep the following things in mind before removing the software: 
 Remove previous versions of SmartPlant 3D software before installing any new versions. 
 The Interference Checking Server must be stopped manually before you uninstall.  
 The Duplication Synchronization Service must be stopped before you uninstall. 
 You must have administrative privileges on the computer before removing the software. 

Refer to Windows Help for instructions on how to establish administrative privileges. 
 Before removing SmartPlant 3D software, ensure that you have preserved all reference data 

Excel files that are pertinent to your specific project. When you uninstall the software, all files 
that are stored in the SmartPlant 3D product folders are removed from your computer. 

Remove the Software Through Control Panel > Add/Remove Programs 
1. Click Start > Settings > Control Panel. 
2. Double-click Add/Remove Programs. 
3. On the Add/Remove Programs dialog box, select Intergraph Smart 3D or Intergraph 

Reference Data from the installed programs list, depending on the product that you need to 
remove. 

 In a stand-alone computer configuration where SmartPlant 3D Reference Data 
and SmartPlant 3D workstation software are installed on the same computer, you must 
uninstall the client software before you uninstall SmartPlant 3D Reference Data; otherwise, 
the Registry Engine Editor returns a fatal error. 

4. Click Remove, and then click Yes in the Add/Remove Programs confirmation box. 
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5. When the uninstall process is complete, close the Add/Remove Programs dialog box and 
close the Control Panel window. 

6. Restart the computer to complete the uninstall. 
7. Right-click Start on the Windows taskbar, select Explore, and browse to the SmartPlant 3D 

product folder. 
8. Right-click the SmartPlant 3D folder, and click Delete to remove the SmartPlant 3D folder 

and log files. 

Remove the Software Using the Application Maintenance Utility 
1. On a computer where the software is installed, insert the product DVD, or rerun Installation, 

to start Installation.  
The Application Maintenance dialog box appears. 

You can also access this dialog box by selecting Control Panel > Add/Remove 
Programs, then selecting the Smart 3D application and Change. 

2. Select the Remove option and click Next. 
3. On the Smart 3D Uninstall dialog box, click Next to remove the application. If you need to 

cancel the uninstall process, click Cancel. 
The Updating System dialog box shows the progress of the uninstall process.  

4. When the uninstall has completed, click Finish. 

See Also 
Application Maintenance (on page 179)  
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This section is a recommendation for monitoring your SQL Server or Oracle databases for 
SmartPlant 3D. There are many possible hardware and software configurations that you can use 
to set up your SmartPlant 3D databases. Refer to the documentation for your components for 
more information on performance and scalability issues. 

See Also 
Server Monitoring (on page 185) 
 

Server Monitoring 
The details on how to monitor system counters and log the results to a file can be found in the 
operating system documentation. Intergraph PPM assumes that the reader is already familiar 
with that topic. 
While doing the monitoring at Intergraph PPM, we started from a very broad selection of 
counters. The analysis of these system parameters with the number of users on the system 
conducted us to focus on a subset of counter found the most relevant for the scalability and 
dimensioning analysis. The list of highlighted counters is not a definitive list of what should be 
monitored, but the list of counters that should be watched with the closest attention. We 
recommend starting from a wide selection of counters and discard later what is found not to be 
pertinent. 

 
 Testing has demonstrated that these counters can be monitored every second to analyze a 

specific workflow or every 10 seconds if you plan on monitoring the system for longer times. 
 A log file of the user activity should be kept in order to relate the server activity to the actions 

of the user. 
 You can also use the System and Configuration Analyzer tool (SCA) to monitor these 

parameters. This tool can be downloaded from eCustomer. 

Processor 
Processor average usage should be kept under 80% for each processor. Isolated spikes over 
80% are acceptable. 
We recommend monitoring the following counters: 
 % Processor time 
 % Privileged time 
 % User time 
 % Interrupt time 
 Interrupts per second 
 Processor queue length 
 Context switches per second 

Recommendation for Database 
Monitoring 
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 Any significant discrepancy between the % Processor time and the % User time 
indicates that the CPU is not available for SQL server and needs to be investigated. This 
problem did not occur during testing. 

Logical Disk and Physical Disks 
The recommendation is to monitor the following counters for each physical drive: 
 % Disk read time 
 % Disk write time 
 % Disk time 
 % Idle time 
 % Average disk queue length 
 % Average disk read queue length 
 % Average disk write queue length 
 Disk second per read 
 Disk second per write 
 Disk second per transfer 
 Disk read per second 
 Disk write per second 
 Disk transfer per second 
 Disk write bytes per second 
 Disk read bytes per second 

Memory 
 Available Mbytes 
 Page fault per second 
 Page read per second 
 Page write per second 
 Pages per second 

 Page fault per second needs to be monitored only to make sure the system is not 
overloaded. 

Network 
 Byte received per second 
 Byte sent per second 
 Current bandwidth 
 Output queue length 
Record PING times between client and server to verify that the software is not being affected by 
other network traffic. 

Database (Microsoft SQL Server) 
Buffer Manager Object 
Counter to monitor: 
 Buffer cache hit ratio 
 Procedure cache pages 
 Free pages 
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 Page read per second 
 Stolen pages 
 Page writes per second 
 Free List Stalls per second 
 Total pages 
 Page Life expectancy 
 Page reads/sec Number 
 Page writes/sec Number 

 Buffer cache ratio should remain over 90%. During testing, the ratio has always 
been in the 95-99% range. 
SQL Databases Object 
We recommend monitoring the following counter at least for the Tempdb, Catalog, and Model 
databases. You can monitor the other SmartPlant 3D databases as well. For performance 
testing, the Tempdb database should be monitored. 
 Data file size 
 Log file size 
 % log used 
 Transaction per second 
 Active transaction 
The transaction per second was not found very relevant for SmartPlant 3D because the software 
executes very few transactions per second (one transaction per command normally). Also, note 
that two different commands, that is, two transactions can have a very different impact on the 
database. Testing has shown that the measure of how much the software "hits" the database 
server is best measured with the number of batch requests per second. 
SQL Statistics Object 
 Batch request per second 
 SQL compilation per second 
 SQL re-compilation per second 
SQL Locks 
 Average wait time (ms) 
 Lock timeouts/second 
 Lock waits/second 
 Number of deadlocks per second 
A certain amount of locking is to be expected because of the way SQL manages data integrity. 
Excessive locking, however, can lead to blocking and needs to be analyzed in order to correct 
the software. Any deadlock situation needs to be analyzed. 
SQL Latches 
 Average latch wait time (ms) 
 Latch wait per second 

Database (ORACLE) 
Oracle performance counters can be monitored using the web-ui that installs with Oracle or by 
using the System and Configuration Analyser tool (SCA) available from eCustomer. Please 
consult Oracle documentation for details on it. 
Oracle Database Counters: 
 Dictionary Cache Hit Ratio – Should be > 90 
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 Library Cache Hit Ratio – Should be >= 99% 
 DB Block Buffer Cache Hit Ratio – Should be > 90 
 Log Switch Interval – Should be greater than 30 minutes 
Oracle Reports: 
 Automatic Database Diagnostics Monitor (ADDM) report – This report can be generated 

from the Oracle Database Console or using the SCA tool available on eCustomer.  

See Also 
Recommendation for Database Monitoring (on page 185) 
 

Results Analysis 
The classical way to analyze database activity is to analyze the activity generated by each 
command (place an order, repeat order, order status, and so on) and extrapolate the response 
of the system to a given load. For example, if placing an order causes one physical read on the 
data file disk, the maximum number of orders that can be placed in one minute can be 
computed. 
Given the huge number of commands that exist in the software, this approach is not practical for 
our system. Instead, the focus is placed on measuring the typical activity per interactive user for 
a given environment. Getting reliable average data requires having several users working 
concurrently. The data generated by a single interactive user is usually too noisy to be used. 
After the data is collected for a given load, the response of the system can be extrapolated to a 
higher load assuming a linear response up to a critical value. Refer to Microsoft SQL Server or 
Oracle performance tuning documentation for more details. 

Example 
The following graphic shows some of the system parameters while two users are routing pipes 
and two users are creating beams in structure: 

 
Average CPU usage 15% 

Reads per second ModelDB data 0.003 

Writes per second ModelDB data 2.75 
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Read per second ModelDB log 0.003 

Write per second ModelDB log 2.83 

Reads per second C drive 0.12 

Writes per second C drive 2.50 

Batch per second 290 

CPU 
 CPU capacity = 2 (processors) × 500 MHz = 1 GHz 
 CPU usage per user = CPU capacity × (average CPU % used / number of users) = 1 GHz × 

.15/4 users = approximately .0375 GHz per user 
Therefore, for a single 1.0 GHz processor: 
 Usage capacity = 1.0 GHz × .75 (critical usage percentage or usable capacity) 
 Number of users = Usable capacity / CPU usage per user 
The system should support (0.75/0.0375) GHz per user = 20 users per GHz. 
Model Data File 
 Total physical I/O per second = 2.75 (Model DB writes) + 0.003 (Model DB reads) = 2.75 

physical I/O per second for 4 users = approximately 0.69 physical I/O per second per user 
 Ignoring RAID factor and taking a standard Max I/O = 70 × 75% = 52 
Therefore using the same disk characteristics, can support 59/0.68 = 75 users per disk. 
Model Log File 
 Total physical I/O per second = 2.83 (ModelDB writes) + 0.003 (ModelDB reads) = 2.83 

physical I/O per second for 4 users 
 Ignoring RAID factor and taking a standard Max I/O = 70 × 75% = 52. 
Therefore using the same disk characteristics, can support 52/0.71 = 73 users per disk. 

 
 Testing has determined that the main hardware parameters driving the scalability of the 

system are the CPU and the I/Os. 
 A system different than the one used for testing purposes can lead to completely different 

results. For example, if the memory is scarce, more loads are placed on the I/O system. 
 Because the log file I/Os are mostly sequential, the system can achieve about 150 

sequential I/Os per second per physical disk, compared with only 50 random I/Os per 
second per physical disk. 

Other Considerations 
IFC 
IFC imposes a very significant load on the database server (equivalent to several simultaneous 
interactive users). We recommend turning off IFC to measure the database activity generated by 
the interactive users using the design applications (piping, structure, and so on). 
Reports 
Some reports can put a heavy burden on the server. Intergraph PPM advises monitoring the 
reports activity separately from the database activity generated by the interactive users using 
design applications (piping, structure, and so on). 

See Also 
Recommendation for Database Monitoring (on page 185) 
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S E C T I O N  1 4  

To troubleshoot the software, several of the software components provide log files that can 
provide pertinent information about the software. Additionally, the software delivers a variety of 
utilities as troubleshooting tools. You can locate the various log files by searching the hard drive 
on your computer with *.log. You can open log files and view their contents using a text editor 
such as Notepad. Log and error files are saved to your system Temp folder unless you specify 
another folder. 

Log Files 
To enable the error log file, use Windows Explorer to navigate to [Product 
Folder]\Core\Tools\Administrator\Bin and execute ErrorLogEnable.exe. This utility allows you 
to configure the delivery location of the log file, the file name, and four levels of logged 
information. 

 
Log run time error - Check this box to enable error logging. Clear this box to stop error logging. 
Select the severity of the errors to be reported - Select the error reporting level. The higher 
the level that you select, the more information is written to the log file. Intergraph recommends 
that you use level 1 at all times. The higher level error reporting (2 - Detailed, 3 - Complete, and 
4 - Exhaustive) slows the software performance, and is only necessary if Intergraph support 
requests detailed log information while tracking a problem. In all normal cases, this option 
should be set to 1 - Normal. 

Troubleshooting the Software 
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Error log full file name - Specify the path and name of the log file. We recommend that you 
specify a location where all users have write access; otherwise, problems associated with 
updating the error log file may prevent users from receiving a desired response. For example, if 
you set the log to write to UserA's Temp folder, then UserA is the only one who can create or 
update the log file. Other users (with the exception of an administrator) will not have access to 
UserA's Temp folder. Likewise, if you configure the software to generate the log file in a folder 
under the Program Files path, only those users who belong to the Power Users or the 
Administrator groups will have write access to the log file. Keep disk access privileges in mind 
when you are configuring the log file. 
Generate time-based log file name at each new start of SP3D task host - Depending on 
how you configure it, SmartPlant 3D overwrites the log file each time you start the software. If 
you need to save an existing copy of the log file, rename the file before starting the software or 
check this option. 
Preserve User Settings - Check this option to save severity level setting and the error log file 
name for just the active user. Clear this option to save the severity level setting and error log file 
name for all users on this computer. 
Add OS stats to every record - Check this option to add your operating system status (such as 
CPU percentage and memory usage) to each log message. Please note that selecting this 
option slows down the software performance and likely your entire system's performance. You 
only need to check this option at the request of Intergraph support. It is important to notice that if 
SmartPlant 3D uses more than 2 GB of memory during execution, the OS stats logged for each 
error take more than half a second to calculate. Intergraph recommends that this option be 
checked only temporarily as requested by Intergraph support while tracking an issue. 
Add Stack Traces to Error records - Check this option to add the stack of the function 
registering the error. Please note that this option slows down software performance and likely 
your entire system's performance. 
Start memory monitor automatically when SP3D starts - Check this option to start the 
Memory Monitor automatically every time SmartPlant 3D starts. You can also click Start 
Memory Monitor to manually start the Memory Monitor. For more information, see Appendix: 
S3DMemoryMonitor in the SmartPlant 3D Common User's Guide. 
An error log is always created. If there is not a location specified, the default location is your 
Temp folder, or %TEMP%, for the process being executed. If the Log run time error option is not 
checked, this automatically generated error log is deleted with the software completes 
processing. In case the software crashes or completes in another abnormal way, the error log is 
left on disk to help Intergraph support diagnose the problem that occurred. In addition, it is 
possible that two more files are created: WER_SP3DErrors_<timestamp>.log and 
S3DHost_<timestamp>.dmp. When contacting Intergraph support, please also make these files 
available as part of your Service Request. 

Troubleshooting Tools 
You can use tools delivered with the Core to troubleshoot the software. These tools are located 
in [Product Folder]\Core\Tools\Administrator\Bin. 
 CrashSP3D.exe - Allows you to forcefully crash SmartPlant 3D. This is useful when you 

want to log a hang, either in a command that never completes or a command that takes a 
long time to process. It can also be useful when an unexpected error dialog displays and you 
want to log a Service Request for the issue. In SmartPlant 3D, crash events are recorded in 
a .dmp file and stored in the specified Temp folder. Along with the .dmp file, copies of the 
Errorlog and WER_SP3DErrors.log file are also stored in the specified Temp folder, which 
are all useful in determining the reason for certain problems that occur in the product. 
CrashSP3D.exe allows you to crash SmartPlant 3D to obtain a copy of the .dmp, Errorlog, 
and WER_SP3DErrors file for troubleshooting purposes. When activated, CrashSP3D.exe 



 Troubleshooting the Software 
 

 
SmartPlant 3D Installation Guide 193 

 

allows you to select which instance of SmartPlant 3D you want to forcefully crash. Contact 
Intergraph support for more information about the options available in this utility and when to 
use them. 

 ErrorLogEnable.exe - Specifies the severity of logged runtime errors. The default setting is 
1, which means only critical errors are logged. Setting 4 will log many more errors, including 
warnings, and could impact performance. You can also specify the name and location of the 
log file. 

 IMSRenderFlag.exe - Allows you to troubleshoot video card issues. Contact Intergraph 
support for more information about the options available in this utility and when to use them. 

 VersionCheck.exe - Displays the version for each task component in the software. 
For more detailed information about troubleshooting tools delivered with the software, see the 
SmartPlant 3D Troubleshooting Guide. The guide is available from Help > Printable Guides in 
the software. 
 

User Assistance 
SmartPlant 3D user assistance makes command information available as you perform tasks. 
You can access different kinds of information any time that you are running the software. This 
information could include reference topics, narrative descriptions, or step-by-step instructional 
material. 

Printable Guides 
User's Guides in PDF format are accessible, flexible, and fully searchable alternative to Help. 
The information found in the User's Guides is also available from Help. The User's Guides 
delivered with the software are located in C:\Program Files\Common 
Files\Intergraph\SmartPlant\Help. Copies of the user's guides can also be found in the Help 
folder on the Intergraph Product DVD. To view these PDF documents, you will need Adobe 
Acrobat Reader with Search version 3.0 or higher. You can download the latest version of the 
Acrobat Reader from the Adobe web site. After you have installed the Acrobat Reader, you can 
open files individually by using the File > Open command in the Acrobat Reader. 

Help 
SmartPlant 3D offers a variety of ways for you to receive help on how to use the software.  
A structured table of contents, an index, and full-text search capabilities provide easy access to 
Help topics. You can access the table of contents by clicking SmartPlant 3D on the Help menu.  
SmartPlant 3D Help is a complete reference tool accessible at any time the application is in use. 
Help provides complete command descriptions for each toolbar button, menu command, and 
ribbon in the software. It also gives step-by-step procedures for common tasks; for example, if 
you need to perform a certain task, search and display the topic. You can move or resize your 
application and Help windows so that they are next to each other. As such, you can follow the 
procedures without having to search for the pages in the documentation. 
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SmartPlant 3D Help is task-specific. For example, to view Common Help, enter the Common 
task, and click Help > SmartPlant 3D Help. To see more specific information, select one of the 
major topics or perform a search on a specific topic. 

 
Show/Hide Show or hide the left pane of the dialog box, including the Contents, Index, and 
Search. 
Back - Returns you to the last Help topic you viewed. This button is disabled when you reach 
the first topic in the series. 
Forward - Displays the next topic in a series of related topics. This button is disabled when you 
reach the last topic in the series. 
Options - Displays a list of functions available for the Help viewer. 
Contents - Displays a hierarchical listing of the topics in the Help file. 
Index - Displays an index for the Help file. 
Search - Performs a full-text search on a word or phrase that you entered in the Search box. 

 For more information, refer to the Common User's Guide available from Help > Printable 
Guides within the software. 
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Customer Assistance 
For the latest Support Services information for this product, use a World Wide Web browser to 
connect to http://support.intergraph.com. 
 

Common Acronyms 
Acronym Meaning 

2D Two-Dimensional 

3D Three-Dimensional 

CD Compact Disc 

COM+ Component Object Model - Plus 

DCOM Distributed Component Object Model 

DTC Distributed Transaction Coordinator 

DuSS Duplication Synchronization Service 

EPC Engineering Procurement Construction 

ERP Enterprise Resource Planning 

FAT File Allocation Table 

FEED Front-End Engineering and Design 

GB Gigabyte 

GHz Gigahertz 

GWC Global Workshare Configuration 

IFC Interference Checking 

I/O Input/Output 

MB Megabyte 

MHz Megahertz 

MDAC Microsoft Data Access Components 

MMC Microsoft Management Console 

MSDTC Microsoft Distributed Transaction 
Coordinator 

NTFS NT File System 

O&M Operations and Maintenance 

P&ID Piping and Instrumentation Diagram 

PPM Process, Power & Marine 

RAM Random-Access Memory 



Troubleshooting the Software 
 

 
196 SmartPlant 3D Installation Guide 

 

ROM Read-Only Memory 

RPC Remote Procedure Call 

SQL Structural Query Language 

SP Service Pack 

SM3D SmartMarine 3D 

SP3D SmartPlant 3D 

TIP Transaction Internet Protocol 

VB Visual Basic 

XML Extensible Markup Language 
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A P P E N D I X  A  

Install and Configure Oracle Server Software 
During installation of the database components, setup displays various dialog boxes that prompt 
you for information. We recommend that you refer to your Oracle documentation for specific 
instructions concerning the dialog boxes and wizard pages. 

 All domain verified user names and passwords must use ASCII7/English 
characters. Oracle does not support non-ASCII / English characters in domain user names or 
passwords and will not work. This limitation applies only to Oracle, not Intergraph. 
This is a guide for installing Oracle Database 11g Release 2 Server in a SmartPlant 3D 
environment. 

Topics 
Oracle Server Configuration .......................................................... 197 
Oracle Database 11g Release 2 Server Software Installation ...... 198 
Delete the Default Oracle Database .............................................. 201 
Create the SmartPlant 3D Oracle 11g Database .......................... 202 
Oracle Post-Installation Requirements .......................................... 207 
 
 

Oracle Server Configuration 
1. Log in as a user with administrator access to the server. 
2. Turn off Windows Firewall. If this is not an option, please refer to the Installation Guide for 

information on the exceptions that must be put into place prior to installing Oracle on 
Windows 7. 

3. In the Folder Options of Windows Explorer, remove the check from Simple File Sharing. 
a. Open Windows Explorer. 
b. Press ALT and select Tools. 
c. Select Folder Options. 
d. Select the View tab. 
e. Scroll to the bottom and remove the check from Use Simple File Sharing 

(Recommended).  
4. Click OK. 

See Also 
Oracle Database 11g Release 2 Server Software Installation (on page 198) 
Install and Configure Oracle Server Software (on page 197) 

Appendix: Install and Configure Oracle 
Software 



Appendix: Install and Configure Oracle Software 
 

 
198 SmartPlant 3D Installation Guide 

 

 

Oracle Database 11g Release 2 Server Software Installation 
This section will guide you through the installation process for Oracle 11g R2 (11.2.0.2) server 
software with Patch 8. 
1. Open the hosts file and enter the IP address and server host name. The hosts file is located 

in C:\windows\system32\drivers\etc\hosts. 
2. Add the environment variable ORACLE_HOSTNAME=<server name> in the System 

Environment Variables. 
3. Run setup.exe from the install disk or folder. 
4. Enter your security update information in the Configure Security Updates screen, and click 

Next. 
5. Select Create and configure a database in the Select Installation Option screen, and 

click Next. 
6. Select Server Class in the System Class screen, and click Next. 
7. Select Single instance database installation in the Grid Installation Options screen, and 

click Next. 
8. Select Advanced install in the Select Install Type screen, and click Next. 
9. Select the installation language in the Select Product Languages screen, and click Next. 
10. Select Enterprise Edition (3.34GB) in the Select Database Edition screen, and click Next. 
11. Specify the Oracle Base location for the base folder and the Software Location for the 

home folder by browsing to the location.  

 
12. Select General Purpose / Transaction Processing in the Select Configuration Type 

screen, and click Next. 
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13. Specify the Global database name and Oracle Service Identifier (SID) values in the 
Specify Database Identifiers screen. 
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14. Select the Memory tab on the Specify Configuration Options screen, and select the 
Enable Automatic Memory Management option. The percentage of memory allowed for 
an instance of Oracle should not exceed 40%. If you have more than one Oracle instance 
on this server, the allocated memory should not exceed 40% of the system memory. 

 
15. Select the Character sets tab on the Specify Configuration Options screen and select 

the Use Unicode (AL32UTF8) option.  

 
 All products in SmartPlant Enterprise that participate in integration should set their 

encodings to Use Unicode (AL32UTF8) for the Database Character Set option, and to 
AL16UTF16 - Unicode UTF-16 Universal character set for the National Character 
Set option.  

 For more information about the Character sets option, see your Oracle installation 
documentation. 

16. Select the Security tab on the Specify Configuration Options screen, and choose your 
security settings option. 

17. Select the Sample Schemas tab on the Specify Configuration Options screen, and select 
the Create database with sample schemas option. Click Next. 

18. Select the Use Database Control for database management option on the Specify 
Management Options screen. You can also enable notifications through email with this 
option. 

19. Select File System in the Specify Database Storage Options screen and specify a 
database file location. Click Next. 

20. Specify your recovery options in the Specify Recovery Options screen, and click Next. 
21. Specify your schema passwords in the Specify Schema Passwords screen, and click 

Next. You must choose either the Use different passwords for these accounts or Use 
the same password for all accounts option. 
The software checks that all prerequisite software is installed on the computer. 
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22. Click Finish in the Summary screen. 
23. Click Close after the installation process is finished. 

See Also 
Delete the Default Oracle Database (on page 201) 
Install and Configure Oracle Server Software (on page 197) 
 

Delete the Default Oracle Database 
The default database created earlier in this workflow must now be deleted. The following steps 
will guide you through this process. 
1. From the Start menu, select All Programs > Oracle > Configuration and Migration Tools 

> Database Configuration Assistant. 
2. Click Next on the Welcome screen. 
3. Select Delete a Database, and click Next. 
4. Select the default database that was created, and click Finish. 
5. Click Yes when asked if you want to proceed. 
6. The Database Configuration Assistant asks if you want to perform another operation. 

Click No. 
 Because no databases exist yet, this is a convenient time to load Oracle patches on the 

server. Oracle patch 8 needs to be installed before creating the Oracle database. 

See Also 
Create the SmartPlant 3D Oracle 11g Database (on page 202) 
Install and Configure Oracle Server Software (on page 197) 
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Create the SmartPlant 3D Oracle 11g Database 
These steps will guide you through the database creation process. If you plan on creating a 
Global Workshare, you need to review the steps for that type of database creation.  
1. From the Start menu, select All Programs > Oracle > Configuration and Migration Tools 

> Database Configuration Assistant. 
2. In the Database Configuration Assistant screen, select Create a Database, and click 

Next. 

 
3. In the Database Template screen, select the Custom Database option, and click Next. 
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4. Enter the name of the new database in the Database Identification screen. Generally, the 
Global Database Name and the SID are identical. These names can be no longer than 
eight characters. 

5. In the Management Options screen, click Next without changing the default selections. 
Configure Enterprise Manager and Configure Database Control for local management 
are the default options. 

 
6. In the Database Credentials screen, select a security option and provide the appropriate 

information. Click Next. 
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7. On the Database File Locations screen, select File System and Use Common Location 
for All Database Files. Browse to the appropriate files location, and click OK. A subfolder is 
created in the folder you choose and is named with the SID you provided earlier in step 4. 

 
8. Click Next. 
9. Select Specify Flash Recovery Area in the Recovery Configuration screen, and click 

Next. 
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10. In the Database Content screen, select the Enterprise Manager Repository option and 
click Next. 

 
11. Select the Memory tab on the Initialization Parameters screen and select the Typical 

option. The percentage of memory allowed for an instance of Oracle should not exceed 
40%. If you have more than one Oracle instance on this server, the allocated memory 
should not exceed 40% of the system memory. 

 
12. On the Sizing tab, configure the Processes option based on this formula. 

Processes ≈ (Maximum Number of SmartPlant 3D Users * 10) + (Number of Oracle System 
Processes) 
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 The number of Oracle system processes can vary based on the number of 
background processes that are running. This number is a high estimate. Overestimate the 
number to ensure it will only use the number of processes that the instance needs. 

13. Select the Character Sets tab, and select the Use Unicode (AL32UTF8) option.  

 
 All products in SmartPlant Enterprise that participate in integration should set their 

encodings to Use Unicode (AL32UTF8) for the Database Character Set option, and to 
AL16UTF16 - Unicode UTF-16 Universal character set for the National Character 
Set option. 

 For more information about the Character Set options, see your Oracle installation 
documentation. 

14. Select the Connection Mode tab, and select Dedicated Server Mode. 
15. In the Connection Mode tab, select All Initialization Parameters. 
16. Click Show Advanced Parameters. 
The parameters required by SmartPlant 3D are listed below: 

Name Value Override Def. Basic 

compatible 11.2.0.0.0   
db_domain DOMAIN.COM   
db_files 1000   

distributed_lock_timeo
ut 

180   

global_names TRUE   

job_queue_processes 10   

log_archive_config SEND   

log_archive_dest O:\OracleLogs\ArchiveL
ogs   

open_cursors 3000   
open_links 10   

open_links_per_install
ation 

10   

os_authent_prefix ""   

processes 200   
undo_retention 3600   

1. Click Close after the changes have been made, and click Next on the Database 
Configuration dialog box. 

 The control files should be divided among multiple physical hard drives. This file is 
needed by the database to start. 
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2. Verify that the path in the Tablespaces folder is correct for SYSAUX, SYSTEM, TEMP, 
UNDOTBS1, and USERS. 

 The information in the Datafiles and Redo Log Groups folders can retain the default 
settings as long as the folder path is correct. 

3. Click Next.  
 The Creation Options screen allows you to save your database configuration as a 

template file, and also allows you to generate database creation scripts. 
 Not every setting is preserved in the template file. If you re-use template files, 

check the parameters carefully to verify the settings are correct. 
4. When you have finished configuring the database, click Finish. 

 The first 15% of the creation process validates the configuration settings. After the 
first 15% of the process has successfully passed, the database creation succeeds without 
any errors.  

5. After the Database Configuration Assistant completes the database creation, click Exit. 

See Also 
Oracle Post-Installation Requirements (on page 207) 
Install and Configure Oracle Server Software (on page 197) 
Appendix: Install and Configure Oracle Software (on page 197) 
 

Oracle Post-Installation Requirements 
1. Create an administrator user (local or domain). 
2. Add this administrator to the ORA_DBA group. 

 There is no need to have both Oracle Server and Oracle Client on the same 
computer. 

3. Make sure the Administrators, System, and Users Windows groups have full access to the 
SharedContent folder on the reference data computer. 

4. Make sure the Administrators and System account have full permissions to the Database 
Templates folder. 

See Also 
Install and Configure Oracle Server Software (on page 197) 
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Oracle Database 11g Release 2 Installation 
This section guides you through the installation process for Oracle 11g R2 (11.2.0.2) with Patch 
8. 
1. Open the hosts file and enter the IP address and server host name. The hosts file is located 

in C:\windows\system32\drivers\etc\hosts. 
2. Add the environment variable ORACLE_HOSTNAME=<server name> in the System 

Environment Variables. 
3. Run setup.exe from the installation disk or folder. 
4. Select Custom in the Select Installation Type screen, and click Next. 
5. Select Skip software updates in the Download Software Updates screen, and click Next. 
6. Select the installation language in the Select Product Languages screen, and click Next. 
7. Specify the Oracle Base location for the base folder and the Software Location for the 

home folder by browsing to the location.  

 



 Appendix: Install and Configure Oracle Software 
 

 
SmartPlant 3D Installation Guide 209 

 

8. Select the product components to install in the Available Product Components screen, 
and click Next. 
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9. Specify the port number on which the Oracle MTS Recovery Service will listen for requests 
in the Specify port number box, and click Next. 

 
10. Wait while the software performs the prerequisite checks, and click Next. 
11. Click Install in the Summary screen. 

The Oracle Net Configuration Assistant displays. 
12. Select Perform typical configuration in the Welcome screen, click Next. 
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13. In the Welcome to the Oracle Net Configuration Assistant screen, click Next. 

 
14. Click Finish. 
15. Click Close after the installation process is finished. 

 In MSDTC, the session timeout is implemented by the registry setting 
ORAMTS_SESS_TXNTIMETOLIVE. The general rule for setting timeouts are: 
MSDTC timeout (default 60) (IIS Setting) < ORAMTS_SESS_TXNTIMETOLIVE (set 
to 120) < distributed_lock_timeout (set to 180) 

Use regedit to verify the setting as shown: 

 
 You must install Patch 8 now. 
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See Also 
Delete the Default Oracle Database (on page 201) 
Install and Configure Oracle Server Software (on page 197) 
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